1.19beta7 and WiFi connect



  • @dc: 1.19beta8+1 doesn't change the WiFi behaviour. but can you plz. confirm/check the above post?


  • administrators

    Using ++i or i++ does exactly the same thing if the operand has primitive type and you don't use the value within the same expression, as in this case.



  • I just got a Duet Wifi and I'm having a hell of a time with the WIFI setup. I have tried flashing 1.18 stable as well as 1.19 beta 8. I first attempted upgrades via M997 but eventually tried the erase/reset/reload via samba. I have gotten it to connect once or twice but it seems whenever I edit config.g to uncomment M552 S1 it fails to connect again after reboot. I have fiddled with it quite a bit since then and haven't been able to get it to talk to my router again.

    I've noticed a couple things

    1. when using 1.18 M552 will say that the board is in AP mode but I can't see it in my list of WIFI networks.
    2. when it does this it also says hostname is some bunch of gibberish ascii characters
    3. when using 1.19 Beta 8 M587 returns the two remembered networks I have configured in my SetNetwork macro however when I do a M552 S1 I get

    M587
    SENDING:M587
    Remembered networks:
    seawest
    seawest 5G

    M552 S1
    SENDING:M552 S1
    WiFi reported error: no known networks found
    Wifi module is idle

    I'm starting to think the board is faulty. Is there anything else I can try? It's almost as if the WIFI module is retaining some kind of garbage. Is there a way to purge everything so I'm starting fresh? SD Card, memory, everything?


  • administrators

    The "no known networks found" message means that it did a network scan and didn't find either of the SSIDs you configured. How strong is the signal from your router where the Duet is? Is the Duet surrounded by metalwork that would attenuate the signal?

    The Duet WiFi does 2.4GHz only, and I presume seawest 5G is a 5GHz access point.

    I think access point names are case sensitive. Is 'seawest' exactly how your access point name appears when you connect to it from a smartphone, tablet etc. ?



  • wow thanks for the quick reply. seawest is the name of my 2.4 Ghz network and my seawest 5G is my 5 Ghz network. Both are off of the same ASUS router that sits about 10 feet away. The names are case sensitive and exactly as they're seen from my iphone. My password is alphanumeric and only contains letters and a number.

    The thing that makes me suspicious that the board is bad is the fact that I don't see "Duet WIFI" when the board thinks it's in AP mode when using 1.18. Are there any debug commands I can use to test the functionality of the WIFI module itself? I was able to get the board to connect a handful of times and it seemed tied to loading a new WIFI firmware. However, I have tried reloading firmware several times since then and I haven't been able to re-establish a connection.

    I WAS able to connect to the "Duet WIFI" SSID but only once. When that occurred I could see my neighbor's APs as well as my own. I was also able to get into the web interface but as soon as I uncommented "M552 S1" and rebooted I had the same problems all over again and could not reconnect.


  • administrators

    When you are using firmware 1.18 and the Duet reports that it is in AP mode, you should be able to find it in the network listing on your smartphone assuming your smartphone isn't only looking for 5GHz networks. If you can't, ask for the Duet to be replaced.



  • @DC42: regaring the SSID/PSK topic:

    within the StartClient() you are calling RetrieveSsidData() which overwrites ssidData each time it is called with data from EEPROM.
    But at the end of StartClient() you are calling ConnectToAccessPoint() with the last update of ssidData as parameter (which could store wrong data at this point caused by prior RetrieveSsidData() calls).

    i think RetrieveSsidData() should be called again with WiFi.SSID(strongestNetwork) as paramter right after the strongestNetwork was found to update ssidData with the correct parameters again. adopted version: https://www.dropbox.com/s/60djqiyv9f380xe/DuetWiFiServer.bin?dl=0


  • administrators

    Thanks for spotting that. I'll update it when I am back in the office.



  • Ps. Can also confirm that '@' within passphrase isn't a problem at all!


  • administrators

    Thanks for the confirmation!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.