Prints super slow no matter what I adjust



  • Hello. I am hoping somebody can help me. I had an Ender 3 that I burned out the mainboard on, so I purchased a Duet 2 Wifi (about a year ago, so before the 3 came out), which I recently carefully updated to FW 3.1.1 ... It worked great for a while (around a year). Then I made a few modifications to the printer (linear rails, direct drive, etc) and ran through several configuration steps I found trying to get everything perfect ... but somehow I screwed up. I feel like I somehow put a decimal in the wrong place, or forgot to convert a "mm/sec" to "mm/min" somewhere, because now when I try to print the maximum it will go to is 10 mm/sec despite being set to 25 on the first layer and 50 on subsequent layers in Cura. I tried several different speed and travel settings and nothing changed on the printer's side. Here's a copy of my config.g file:

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    
    ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"Ender 3"                                    ; set printer name
    
    ; Network
    M552 S1                                            ; enable network
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S0                                         ; disable FTP
    M586 P2 S0                                         ; disable Telnet
    
    ; Drives
    M569 P0 S1                                         ; physical drive 0 goes forwards
    M569 P1 S1                                         ; physical drive 1 goes forwards
    M569 P2 S0                                         ; physical drive 2 goes backwards
    M569 P3 S1                                         ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                                   ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                            ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z800.00 E93.75                 ; set steps per mm
    M566 X360.00 Y360.00 Z60.00 E300.00                ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E6000.00            ; set maximum speeds (mm/min)
    M201 X800.00 Y800.00 Z250.00 E5000.00              ; set maximum accelerations (mm/s^2)
    M906 X1400 Y1400 Z1400 E900 I30                    ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; set axis minima
    M208 X235 Y235 Z260 S0                             ; set axis maxima
    
    ; Endstops
    M574 X1 S1 P"xstop"                                ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop"                                ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S1 P"zstop"                                ; configure active-high endstop for low end on Z via pin zstop
    
    ; Z-Probe
    M558 P0 H5 F120 T6000                              ; disable Z probe but set dive height, probe speed and travel speed
    M557 X10:220 Y10:220 S20                           ; define mesh grid
    
    ; Bed
    M308 S0 P"bedtemp" Y"thermistor" T98801 B4185      ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                              ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 A102.2 C478.6 D2.0 S1.00                ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                            ; map heated bed to heater 0
    M143 H0 S80                                        ; set temperature limit for heater 0 to 80C
    
    ; Hotend
    M308 S1 P"e0temp" Y"thermistor" T98801 B4185       ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                               ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 A320.6 C127.0 D3.6 V23.9                ; disable bang-bang mode for heater and set PWM limit
    
    ; Fans
    M950 F0 C"fan0" Q500                               ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                     ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                               ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45                                  ; set fan 1 value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"Hotend" D0 H1 F0                         ; define tool 0
    G10 P0 X0 Y-1.5 Z0                                 ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings
    M572 D0 S0.12                                      ; set linear advance k-factor
    
    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0                                                 ; select first tool
    


  • @Blaidd said in Prints super slow no matter what I adjust:

    Cura

    check your settings in cura, sometimes it has g-code for changing the speed etc in mm/sec. (or look in the sliced file if thats easier)



  • That was the first thing I checked, and everything looks right. It was based on one of the Chep Ender 3 profiles and modified as I did my tests. It's not letting me upload my Cura profile so here it is in text form.

    [general]
    version = 4
    name = Custom 0.2
    definition = creality_base
    
    [metadata]
    intent_category = default
    quality_type = standard
    type = quality_changes
    position = 0
    setting_version = 15
    
    [values]
    clean_between_layers = True
    coasting_enable = False
    cool_fan_speed = =100.0 if cool_fan_enabled else 0.0
    fill_outline_gaps = True
    infill_line_distance = =0 if infill_sparse_density == 0 else (infill_line_width * 100) / infill_sparse_density * (2 if infill_pattern == 'grid' else (3 if infill_pattern == 'triangles' or infill_pattern == 'trihexagon' or infill_pattern == 'cubic' or infill_pattern == 'cubicsubdiv' else (2 if infill_pattern == 'tetrahedral' or infill_pattern == 'quarter_cubic' else (1 if infill_pattern == 'cross' or infill_pattern == 'cross_3d' else 1))))
    infill_pattern = ='lines' if infill_sparse_density > 50 else 'cubic'
    infill_sparse_density = 15
    material_flow = 93.5
    material_flow_layer_0 = 95
    material_print_temperature = 185
    retract_at_layer_change = True
    retraction_amount = 1.5
    retraction_extrusion_window = 2
    retraction_speed = 40
    roofing_layer_count = 1
    skirt_brim_speed = =speed_layer_0
    speed_equalize_flow_enabled = True
    speed_layer_0 = 25.0
    speed_travel_layer_0 = =100 if speed_layer_0 < 20 else 150 if speed_layer_0 > 30 else speed_layer_0 * 5
    speed_wall_x = =speed_wall
    support_brim_enable = False
    top_bottom_thickness = 1.4
    travel_compensate_overlapping_walls_0_enabled = True
    wall_0_material_flow = =wall_material_flow
    wall_0_wipe_dist = 0.4
    wall_line_width = =line_width
    wall_thickness = 1.2
    wipe_retraction_enable = False
    z_seam_corner = z_seam_corner_inner
    z_seam_type = sharpest_corner
    

    Oh, and I suppose I should mention, it's white "3D Best-Q" brand PLA (found it on Amazon), although that shouldn't affect not being able to go up to the requested speed. It was printing decently before I started tweaking it.



  • I'm not familiar with cura since I don't use it, but on kisslicer there is a parameter named Maximum Extruder Flow, which is intended to limit the printer speed to whatever plastic volume the extruder is capable of pushing in order to avoid under extrusion.

    I'd look for a similar parameter in cura and try to adjust it.



  • @Blaidd said in Prints super slow no matter what I adjust:

    and everything looks right.

    start g-code? thats usaully where some profiles have settings to control speed/accl/jerk



  • I never touched the start and end g-code, but here they are anyway just in case:

    Start G-Code:

    G92 E0 ; Reset Extruder
    G28 ; Home all axes
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X1.0 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X1.0 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X1.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X1.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish
    

    End G-Code:

    G91 ;Relative positioning
    G1 E-2 F2700 ;Retract
    G1 E-2 Z0.2 F2400 ;Retract and raise Z
    G1 X5 Y5 F3000 ;Wipe out
    G1 Z5 ;Raise Z more
    G90 ;Absolute positionning
    
    G1 X0 Y225 ;Present print
    M106 S0 ;Turn-off fan
    M104 S0 ;Turn-off hotend
    M140 S0 ;Turn-off bed
    M84 X Y E ; Turn off X, Y, and Extruder motors
    


  • do you have speed and acceleration control enabled in the cura profile?

    that could be another source



  • @Veti No, I set them in the config.g file and turned them off in the slicer.

    Correction, I have "speed" set at 25 for first layer and 50 for all other layers. I have acceleration and jerk (instantaneous speed change) set in config.g file and turned off in the slicer.



  • open the generated g code and look for M201 M203 or M204.



  • @Veti There aren't any in the code.



  • @Blaidd said in Prints super slow no matter what I adjust:

    M92 X160.00 Y160.00 Z800.00 E93.75 ; set steps per mm

    did you buy 0.9 steppers? otherwise you are off by 2 here



  • @Veti Yes, sorry. I forgot to mention that. I was upgrading the stepper motors (something got spilled on 2 of them and to be safe I just replaced them all) and accidentally bought 0.9 instead of 1.8, then decided to just go with it instead of trying to deal with the hassle of returning them. It was working fine, until suddenly everything slowed down to a crawl.



  • post the beginning of your g code file with the first couple of print moves

    also try prusaslicer to test



  • @Veti said in Prints super slow no matter what I adjust:

    post the beginning of your g code file with the first couple of print moves

    ;TIME:2425
    ;Filament used: 1.41972m
    ;Layer height: 0.2
    ;MINX:96.5
    ;MINY:96.5
    ;MINZ:0.2
    ;MAXX:138.5
    ;MAXY:138.5
    ;MAXZ:20
    ;Generated with Cura_SteamEngine mb-master-20200822
    T0
    M190 S60
    M104 S185
    M109 S185
    M82 ;absolute extrusion mode
    ; Ender 3 Custom Start G-code
    G92 E0 ; Reset Extruder
    G28 ; Home all axes
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X1.0 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X1.0 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X1.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X1.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish
    M83 ;relative extrusion mode
    G1 F2400 E-1.5
    ;LAYER_COUNT:100
    ;LAYER:0
    M107
    G0 F7500 X99.698 Y99.764 Z0.2
    ;TYPE:SKIRT
    G1 F2400 E1.5
    G1 F1500 X100.386 Y99.127 E0.0277
    G1 X101.126 Y98.551 E0.0277
    G1 X101.912 Y98.039 E0.02771
    

    And then after the skirt finishes, here's the beginning of the first layer:

    ;MESH:20mm_calibration_cube.stl
    G0 F7500 X126.5 Y126.5
    ;TYPE:WALL-INNER
    G1 F2400 E1.5
    G1 F1500 X108.5 Y126.5 E0.53178
    G1 X108.5 Y108.5 E0.53178
    

    @Veti said in Prints super slow no matter what I adjust:

    also try prusaslicer to test

    It just so happens that I have PrusaSlicer, I just stopped using it because the Chep-Cura setup was (usually) working better, but I did not set up the settings I recently got from all the tests I ran. That said, it did appear to run full speed (only did first 2 layers to test).

    ETA: Okay, now I'm even more confused. Just out of curiosity, I resliced the test cube without making any changes to my Cura settings and ran it... and it's running perfectly. So at this point the only thing I can think of is maybe a corrupt download of the file, somehow? Or maybe a random setting from all the testing got left in memory, and it finally dropped out?

    ETA2: False alarm. I accidentally uploaded the same file a second time, instead of the new one. It's still not going above 10mm/s with the Cura file.



  • did you change cura to reprap flavour?



  • @Veti That was one of the first things I did when I installed the Duet, and it worked for over a year. I did not change it recently.



  • Well, we've established the problem is not with the Duet (or, more accurately, the settings I adjusted on my Duet). So I'll just delete my Cura custom profile and start over with the Chep profile that I know functions properly. I'll have to spend a few hours calibrating stuff all over again, but half the stuff (the ones I saved in Duet config.g) is already done.


  • Moderator

    Did you happen to have a really high minimum layer time set?

    Your X Y jerk is set a bit low. M566 X360.00 Y360.00


Log in to reply