Wifi and USB connection problems.



  • Hey Everybody!

    I have a few questions so ill make a short list:

    A. I just got my duet Wifi Board, I'm installing the dc42 fork on it, (1.15c) Currently i am using a panel Due, (1.14)
    so I'm using the command line there, was able to get connected to the Wifi labeled Duetwifi and i was able to input the Wifi pass and SSID,
    saved ( told me to reboot) after that when i link to my router it dose not show up as connected. ( looking at the connected mac dresses) ( yes i enabled the WiFi)
    it also dose not show back up as "duetwifi" so i know it thinks its connected.

    however i can not see it, and i can not connect to the web interface. any thoughts?
    is there another way to configure the Wifi? do i need to building a custom .bin and flash the WIFi? ( currently not sure even how to build the .bin file)

    did i miss a step? or am i just confused?

    i also tried the original firmware that was on it when it came ( wifitest) no luck, same result,

    i also tried a different router, no luck.
    i'm not sure what to try next?

    A. 1. can we connect to "hidden" networks? i disabled the hidden network to set it up originally, but will it still connect to the hidden network even after a proper config? (Aka i re hide the SSID again after the first config using 192.168.1.1)

    answer to A. i got those working, using the m552 command i was able to see the IP address ( its not the ip address that i put in the config.g file???) (it also dose not show the correct Mac address when looking in the router??? )
    answer to A.1. yes, it will connect to the hidden network, but you must un-hide it to configure it using the 192.168.1.1 config)

    lets just look at the one below, still haven't got that one answered

    B. I cant seem to get the Usb drivers installed, so i can use the command on pronterface. i downloaded the Raw files as suggested, windows does not recognize the files as driver files ????? ( using win 8.1 but also tried it on winxp with the same result)

    this link works: https://github.com/dc42/RepRapFirmware/blob/dev/Driver/duetinf.cat i can click on raw and it will download fine.

    this link seems to not let me download correctly: https://github.com/dc42/RepRapFirmware/blob/dev/Driver/duet.inf i can download the raw file with a right click on the RAW link and save as, but if i just click the raw button it opens it in the browser? I'm not sure if the right click save as function is OK to do??? seems odd to me?

    any thoughts on this let me know,
    i'm kinda sitting dead in the water with USB connections!

    Thanks!!

    ~Russ Gries

    link to my main build thread:
    https://www.duet3d.com/forum/thread.php?id=187



  • Have you tried downloading the entire thing via the 'clone or download' button as a zip file?



  • yes, however i haven't tried to use those files, ill give that a go and see what happens!

    ~Russ



  • ok, tested to work! must download all files via Zip file and then the drivers work!

    might want to update that on the main Wiki page…

    Thanks!!

    ~Russ


  • administrators

    I'll look into it. I have the .inf file flagged as a binary file so that it should download correctly in Raw mode.



  • Thank you for this thread. I just had the same issue on a Windows 10 PC. The only way I could download the Duet USB Driver was to download the entire https://github.com/dc42/RepRapFirmware, unzip and update the driver from there.



  • I am also having the same problem. Windows 10 here. Doing first time setup.

    I installed first using just the DueDriverFiles.zip then extracting.

    When i double clicked the duet.inf file, it simply opened as a text document. So i righ clicked the duet.inf and selected "install" instead. It seemed to succeed (no errors were thrown). But when i then plugged the Duet Wifi into my USB port, no joy. The red LED is illuminated, but nothing shows on my PC. Device manager also shows no COM port objects.

    I then read this post and downloaded the whole reprap firmware file from github. Then extracted the duetdriverfiles.zip again. Same thing, no errors (still had to right click and hit install rather than double click) but also still not showing up on device manager.

    I have tried restarting my pc between attempts to install the driver as well for good measure.

    I decided to try to uninstall the driver manually from my PC, so i found the file in Windows/System32/Driverstore/filerepository/duet.inf_amd64_78c3089bafb78e17 but the files could not be removed. The interesting thing about this is that the duet.inf and duetinf.cat files in this area were time stamped the same as the first driver file i tried to use. no other driver install attempt seems to have overwritten them.

    Open to input on this. I had been following the steps laid out here: https://duet3d.com/wiki/Getting_connected_to_the_Duet_WiFi#Step-by-step_guide
    got stopped at step 2-3.


  • administrators

    If the Duet doesn't show up in Device Manager as a COM port:

    • check that the 5V Usb red led, the 3.3V green Led and the 5V red led next to to it are all lit. If the green led isn't lit, this is usually caused by incorrect endstop switch wiring

    • try another usb cable. Beware of usb cables supplied with chargers that have power connections only and no data connections.



  • It was a reversed endstop connector.

    Silly me for assuming that the 3-pack of endstops would have all 3 sets of cable wired the same at the board connector 🙂 One connector set was different than the other two which caused the issue.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.