Fans on WebUI



  • Hi, I use a duet Wifi + Duex5 (RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05.1 running on Duet WiFi 1.02 or later + DueX5) and I have settled up a COREXYU with two indipendent extruders.

    I'm a bit confused on FANs. I want to set up the following:

    • Extruder 1 with a Thermostatically controlled fan + 1 fan for part cooling
    • Extruder 2 with a Thermostatically controlled fan + 1 fan for part cooling
      where Extruder 1 and 2 are completly separate (extruder 1 on axis X, extruder 2 on axis U)

    here the issue: I configured fans in config.g as below, and in the webUI I was expecting to see the part cooling fans (HO_part, H1_part), and not to see the Thermostatically controlled fans (HO_hotend, H1_hotend). Actually is the other way around: I see the Thermostatically controlled fans and I don't see the part cooling fans.

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0 (bed)
    M143 H0 S100 ; set temperature limit for heater 0 to 100C
    M305 P1 X150 ; set thermistor for heater 1 thrugh the extended mini board
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M305 P2 X151 ; set thermistor for heater 2 thrugh the extended mini board
    M143 H2 S280 ; set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0 I0 F550 H-1 C"HO_part" ; fan part cooling Tool 0
    M106 P1 S0 I0 F500 H1 T45 C"HO_hotend" ; fan hotend on Tool 0
    M106 P3 S0 I0 F500 H-1 C"H1_part" ; fan part cooling Tool 1
    M106 P4 S0 I0 F500 H2 T45 C"H1_hotend" ; fan hotend on Tool 1

    ; Tools
    M563 P0 D0 H1 F0 ; tool 0, using extruder 1 (P0) and heater 1 (H1) and part cooling fan 1 (F1)
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 set initial tool 0 active and standby temperatures to 0C

    M563 P1 D1 H2 F3 ; tool 1, using extruder 1 (P1) and heater 2 (H2) and part cooling fan 4 (F4)
    G10 P1 X24 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C

    ![0_1600857050396_Capture.PNG](Uploading 100%)

    ![0_1600857076443_Capture.PNG](Uploading 100%)


  • Moderator

    Your photos did not upload successfully.

    Your config looks ok.

    What version of DWC are you running? For firmware 2.05.1 it should be 2.0.7

    If you send M106 P0, M106 P1, etc in the console what does it return?



  • The version of WDC is 2.1.2
    and here the image of the webUI with the described confing.g setting

    Capture.JPG

    this is what I see:

    • TOOL 0
    • HO_HOTEND
    • H1_HOTEND

    but I don't see the part cooling fans.

    When I send M106 P0 this is what I get

    Capture2.JPG

    Thanks for helping.
    Marco


  • Moderator

    Please send M106 P3 and M106 P4 as well.
    Please also post the results of sending M122 and M98 P"config.g"

    Please download this zip file and upload it as is to the /sys folder in DWC.

    https://github.com/Duet3D/RepRapFirmware/releases/download/2.05.1/DuetWebControl-SD-2.0.7.zip



  • Hi, I did what you asked.

    on launching diagnostic, here the result:

    25/9/2020, 08:07:56: M122: === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05.1 running on Duet WiFi 1.02 or later + DueX5
    Board ID: 08DGM-9T6BU-FG3SJ-6J1FL-3S86L-18XHF
    Used output buffers: 3 of 24 (8 max)
    === RTOS ===
    Static ram: 25712
    Dynamic ram: 93956 of which 108 recycled
    Exception stack ram used: 544
    Never used ram: 10752
    Tasks: NETWORK(ready,764) HEAT(blocked,1176) DUEX(suspended,160) MAIN(running,3736) IDLE(ready,160)
    Owned mutexes:
    === Platform ===
    Last reset 00:04:28 ago, cause: power up
    Last software reset at 2020-09-23 12:05, reason: User, spinning module GCodes, available RAM 10976 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 5.4ms, max retries 0
    MCU temperature: min 25.3, current 34.1, max 34.1
    Supply voltage: min 23.8, current 24.0, max 24.2, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max 0/9
    Driver 1: standstill, SG min/max 0/0
    Driver 2: standstill, SG min/max 64/254
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Driver 5: standstill, SG min/max 0/35
    Driver 6: standstill, SG min/max 0/0
    Driver 7: standstill, SG min/max 54/203
    Driver 8: standstill, SG min/max 48/209
    Driver 9: standstill, SG min/max not available
    Date/time: 2020-09-25 08:07:55
    Cache data hit count 809711122
    Slowest loop: 120.08ms; fastest: 0.07ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 160, MinFreeDm: 156, MaxWait: 145019ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 19, completed moves: 19, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 136.59ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address ec:fa:bc:2d:df:20
      WiFi Vcc 3.38, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 25456
      WiFi IP address 192.168.1.237
      WiFi signal strength -44dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0

    25/9/2020, 08:08:48: M98 P"config.g": HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled

    Then I uploaded the file you sent to me, and now I have the WDC 2.0.7 and finlly I see all hotends!!! This menas that my version of WDC was not correct?

    Your help has been great, thanks!!

    Ciao,
    Marco


  • Moderator

    That's great. I think either your DWC was corrupt is some way, or you had an incompatible version installed.


  • Moderator

    @Marco_76 you can use the current DWC v3.1.1 if you want. As noted here https://github.com/Duet3D/DuetWebControl/releases/tag/3.1.1

    Compatible files:
    ...
    RepRapFirmware 2 or newer (1.2x may work but untested)

    Ian


Log in to reply