3.2b1 - Height Map issue "Cannot read property 'add' of null"



  • I've not been able to find a work around for this one. Every since we upgraded to 3.2b1, the Height Map returns the error "Cannot read property 'add' of null". This occurs on multiple PCs running both Chrome and Edge. We've tried dumping our cache but no luck. There is nothing apparently wrong with the height map. I'll attach it to this thread.

    I saw another user reported this yesterday as well. If he was able to find a work-around or fix, I am unaware.

    Any assistance would be appreciated as this is really starting to hold us up.. Thanks

    heightmap.csv


  • administrators

    Are you running with or without an attached SBC?



  • @dc42 I did it again.. not reporting my configuration. Sorry. It's a Duet 3 / RPi



  • Just found this error:

    HeightMap.vue:499 TypeError: Cannot read property 'add' of null
        at VueComponent.showHeightMap (HeightMap.vue:358)
        at VueComponent.showCSV (HeightMap.vue:303)
        at _callee2$ (HeightMap.vue:494)
        at tryCatch (runtime.js:63)
        at Generator.invoke [as _invoke] (runtime.js:293)
        at Generator.next (runtime.js:118)
        at asyncGeneratorStep (asyncToGenerator.js:3)
        at _next (asyncToGenerator.js:25)
    _callee2$ @ HeightMap.vue:499
    

    Also, I just tried on my iPad and and received: null is not an object (evaluating 'this.three.scene.add').



  • Yep. already reported it on another thread. Have the Problem on ESP too


  • administrators

    Although I have not yet managed to reproduce this problem I decided to change the init code, which should fix the problem once and for all. This change will be part of the next v3.2-b2.


Log in to reply