Can't control Heaters with Panel Due



  • I can't control my Heaters from my Panel Due. I am running firmware V1.16 on all 3 of my 7". I am running 1.18 and 1.19beta8. When I tap H1 and set temp, nothing happens. I tap and set H2 the temp is entered in H1. Same for H3 entered for H2. I can't activate any of the heaters by tapping the "current" buttons. Everything works fine from DWC.


  • administrators

    I think this is to do with how you have tools mapped to heaters. The temperature setting commands relate to tools (T0, T1 etc.) but the displayed heater temperatures relate to heaters 1, 2 etc. So if you are numbering your tools T1 and T2 instead of the conventional T0 and T1, that would explain what you are seeing.


  • administrators

    I think this is to do with how you have tools mapped to heaters. The temperature setting commands relate to tools (T0, T1 etc.) but the displayed heater temperatures relate to heaters 1, 2 etc. So if you are numbering your tools T1 and T2 instead of the conventional T0 and T1, that would explain what you are seeing.



  • David, I just realized that the Heater activation buttons above the Temp readings are missing. They appear for a second when I power up but then disappear. The bed heater button is still there. I have tried altering the config and Tool settings in DWC.
    ;Tools
    M563 P1 D0 H1 ; Define tool 1
    G10 P1 S0 R0 X-42 Y1.20 ; Set tool 1 operating and standby temperatures
    M563 P2 D1 H2 ; Define tool 2
    G10 P2 S0 R0 X0 Y0 ; Set tool 2 operating and standby temperatures
    M563 P3 D2 H3 ; Define tool 3
    G10 P3 S0 R0 X42 Y0 ; Set tool 3 operating and standby temperatures

    ;Tools
    M563 P0 D0 H1 ; Define tool 1
    G10 P0 S0 R0 X-42 Y1.20 ; Set tool 1 operating and standby temperatures
    M563 P1 D1 H2 ; Define tool 2
    G10 P1 S0 R0 X0 Y0 ; Set tool 2 operating and standby temperatures
    M563 P2 D2 H3 ; Define tool 3
    G10 P2 S0 R0 X42 Y0 ; Set tool 3 operating and standby temperatures

    I cant seem to attach a picture of my screen. Where is the attachment symbol?


  • administrators

    The second one with tools numbered from 0 should work. However, currently PanelDue only reads the tool configuration once when it first connects. So you will have to power it down and up again or press the Reset button on PanelDue to pick up the new tool numbering.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.