BLTouch Homing in wrong direction



  • Hi When I use G30 it sends the BLTouch upwards instead of towards the build plate on my cartesian. I used G92 to allow me to move the axis without the machine being homed to confirm that they are not inverted and they run going the correct direction with the nozzle moving closer to the build platform with negative values.



  • Here is my config.g

    My Printer
    Send code...
    Status
    Idle
    Tool Position
    X
    0.0
    Y
    0.0
    Z
    0.00
    Extruder Drives
    Drive 0
    0.0
    Speeds
    Requested Speed
    0 mm/s
    Top Speed
    0 mm/s
    Sensors
    Vin
    22.1 V
    MCU Temperature
    32.5 C
    Fan RPM
    0
    Z-Probe
    0
    Tools
    Extra
    Control All
    Tool Heater Current Active Standby
    Extruder 1
    T0 - Load Filament n/a n/a
    0
    0
    Temperature Chart
    No Data
    System Directory
    0:/sys/config.g
    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Mon Sep 28 2020 10:10:20 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network

    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S1 ; enable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X310 Y310 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5
    M558 P9 H5 F500 T4000 X0 Y0 Z1 ; Set Z probe to mode 9
    G31 P25 X46.5 Y0 Z0.0 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    M557 X5:205 Y5:165 S20 ; Define mesh grid

    ; Heaters
    M140 H-1 ; disable heated bed (overrides default heater mapping)
    M308 S0 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin e0temp
    M950 H0 C"e0heat" T0 ; create nozzle heater output on e0heat and map it to sensor 0
    M307 H0 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Extruder 1" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • here is homez.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Mon Sep 28 2020 10:10:21 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X15 Y15 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • In your G31 command you have the trigger height as Z=0.

    Is that correct?

    Frederick


  • Moderator

    Are you sure your steps per mm on Z are correct at 400?

    What happens if you send G30 manually?

    You've posted homez, but what do you have in homeall?



  • hi here is home all, I am getting an error saying unable to reach point now.

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Mon Sep 28 2020 10:10:21 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-315 Y-315 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-315 Y-315 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X15 Y15 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning


  • Moderator

    @chris said in BLTouch Homing in wrong direction:

    I am getting an error saying unable to reach point now.

    When are you getting that and what exactly does it say?



  • cheers says,

    Skipping grid point (40.0, 270.0) because Z probe cannot reach it

    this is G31

    G31 P25 X46.5 Y0 Z3.70


  • Moderator

    It can't reach point x40 because the probe is offset by 46.5

    Alter your M557 grid points to account for the probes X offset.

    M557 X50:205 Y5:165 S20 for example



  • will try cheers



  • issue I am having is saying G30 Probe zero not found


  • Moderator

    When are you getting that message?
    What is in your config.g now? homeall.g?



  • @chris said in BLTouch Homing in wrong direction:

    issue I am having is saying G30 Probe zero not found

    As I understand it when trying to probe the point where Z=40 you got the error message about the probe not reaching it.

    Then you changed M557 to use X50:205.

    And you made no other changes?

    Frederick


  • Moderator

    In you rother thread you just updated to 3.1.1, did you also get a new config set?



  • yeah updated here is my new config .g

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Mon Sep 28 2020 10:10:20 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network

    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S1 ; enable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E415 ; set steps per mm
    M566 X720.00 Y720.00 Z18.00 E600.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E3000.00 ; set maximum speeds (mm/min)
    M201 X750 Y750 Z100 E5000 ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z800 E1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X305 Y330 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; Define Z to use Probe. Home to Min

    ; Z-Probe
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5
    M558 P9 H5 F500 T4000 X0 Y0 Z1 ; Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves
    G31 P25 X46.5 Y0 Z3.70 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    M557 X50:280 Y45:310 S50 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"Thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H0 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan 0
    M106 P0 S1 H1 T60 ; enable thermostatic control on fan 0 heater 1 sensor 1
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan 1
    M106 P1 S0 H-1 ; disable thermostatic control on fan 1

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Default firmware retraction configuration
    M207 S3.2 R-0.1 F3600 T1200 Z0 ; Set 3.2mm retraction, -0.1 restart, 3600 mm/min feed rate, 1200 mm/min restart feed rate, no z change

    ; Other settings
    G29 S1 ; Enable automatic bed mesh compensation
    M572 D0 S0.16 ; Enable pressure-advance
    M915 X Y S10 F1 R1 ; Enable stall detection for X and Y axis with a sensitivity of 10 and report only
    M915 Z S0 F1 R1 ; Enable stall detection for Z axis with a sensitivity of 10 and report only

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory


  • Moderator

    @chris said in BLTouch Homing in wrong direction:

    G29 S1 ; Enable automatic bed mesh compensation

    Don't put this in config.g because it will load the heightmap before you have even homed the printer. A better place to put it is in your slicer start gcode after you've done a G28 to home all axis.

    The zprobe section is still formatted for RRF2. In RRF3 you should have something more like this:

    ; Z-Probe
    M950 S0 C"exp.heater7"                         ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F120 T6000           ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X46.5 Y0 Z3.6                         ; set Z probe trigger value, offset and trigger height
    M557 X50:280 Y45:310 S50                      ; define mesh grid
    
    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Sep 30 2020 15:12:19 GMT-0600 (Central Standard Time)
    M280 P0 S10 ; deploy BLTouch
    
    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Sep 30 2020 15:12:33 GMT-0600 (Central Standard Time)
    M280 P0 S90 ; retract BLTouch
    


  • getting this error now
    G28 Warning: Obsolete use of S parameter on G1 command. Use H parameter instead.


  • Moderator

    It looks like you didn't take the full config file set from the configurator as suggested in your other thread. It would have made all the changes needed for RRF3.

    That warning is telling you that your homing files are using G1 S1 and G1 S2 and the S should be changed to H. (G1 S is now used for laser power when in laser mode)

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Sep 30 2020 15:29:23 GMT-0600 (Central Standard Time)
    G91                     ; relative positioning
    G1 H2 Z5 F6000          ; lift Z relative to current position
    G1 H1 X-235 Y-215 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000       ; go back a few mm
    G1 H1 X-235 Y-215 F360  ; move slowly to X and Y axis endstops once more (second pass)
    G90                     ; absolute positioning
    G1 X-31.5 Y15 F6000     ; go to first bed probe point and home Z
    G30                     ; home Z by probing the bed
    


  • Used reprap firmware config tool tool to create new config .g file but now bltouch isn't deploying it does self test fine on powering up the printer but doesn't deploy with M280 P0 Z10.

    here is my new config .g now

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Thu Oct 01 2020 12:28:30 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Creality CR-10" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E415.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X60000.00 Y60000.00 Z30000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X310 Y320 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"exp.heater7" ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z3.7 ; set Z probe trigger value, offset and trigger height
    M557 X50:280 Y50:280 S50 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H1 T60 ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H-1 ; set fan 1 value. Thermostatic control is turned off

    ; Tools
    M563 P0 S"Extruder 1" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • here is home z

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Thu Oct 01 2020 12:28:31 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X50 Y50 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @chris said in BLTouch Homing in wrong direction:

    G31 P500 X0 Y0 Z3.7

    In your config.g file there is this line related to the Z probe.

    Being a BLTouch the P parameter should be 25.

    And I cannot image how the X and Y offsets could be 0. Those values are saying that the BLTouch pin is right where the nozzle is, along the X and Y axes.

    As to the probe self-testing but not working you need to verify that the wiring is correct. It's getting power but it seems it may not be getting the control signal.

    Frederick


  • Moderator

    Replace your zprobe section and deploy and retract macros with the ones I posted above. I took your values from your original config and brought them forward. The one you just generated doesn't have that.

    Was the deploy and retract working before?

    M280 P0 Z10.

    That should be S10 not Z10



  • yeah before I upgraded to v 3.1.1 yeah sorry was M280 P0 S10



  • @fcwilt Sorry this was g31

    G31 P50 X46.5 Y0 Z3.7 ; set Z probe trigger value, offset and trigger height



  • This post is deleted!

Log in to reply