Z-Probing outside of bed area =(



  • I recently built a a core xy machine - everything was working fine but I must have broken something in the config.g on my last few edits -

    Now, when I hit "home all"....X&Y home fine the machine then attempts to do a Z-probe (Bltouch) but it's outside of the build plate area. Typically it moves over the build plate a bit prior to homeing Z but no longer does that.

    The z-probe is offset about x-45mm, y0 from the nozzle. I entered the z-probe offset in the config.g so I'm not sure what's going on. Any help would be greatly appreciated!

    here's my config.g

    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Thu Sep 17 2020 15:58:53 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Corexy" ; set printer name
    M669 K1 ; select CoreXY mode

    ; Network
    M551 P"so505is" ; set password
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S1 ; enable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping (wasM584 X0 Y1 Z2 E3)
    M350 X128 Y128 Z64 E32 I1 ; configure microstepping without interpolation
    M92 X640.00 Y640.00 Z6400.00 E837.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z100.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I10 ; set motor currents (mA) and motor idle factor in per cent
    M84 S10 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z-5 S1 ; set axis minima
    M208 X280 Y295 Z325 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe (new)
    M307 H7 A-1 C-1 D-1 ; disable heater on PWM channel 7 for BLTouch
    M558 P9 F120 H5 R0.2 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 X-45 Y0 Z4.61 ; set Z probe trigger value, offset and trigger height
    M557 X20:280 Y20:280 S40 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0 [M143 H0 S120 ; Set temperature limit for heater 0 to 120C ; Set thermistor + ADC parameters for heater 0 (bed)]
    M143 H0 S80 ; Set temperature limit for heater 0 to 80C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1 (hot end)
    M307 H1 A340.0 C140.0 D5.5 B0 ; Set temperature limit for heater 1 to 265C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets ( T<extruder_number> X<offset_on_X> Y<offset_on_Y>. ) ;was M563 P0 D0 H1 f0
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • the position of z probing is in the homeall.g script


Log in to reply