Debug MAX31865 over CAN



  • Hi,

    My 3D printer is equiped with a Duet 3 MB 6HC and one Duet 3 EB 3HC.

    On the extruder, I use 3 PT100 sensors and a fourth one for the heated build plate. All PT100 sensors are connected to the Duet 3 boards through a MAX31865.

    On this printer, I can read all the temperatures of the PT100 sensors.
    When I heat the extruder and extrude, I can still read all the temperatures normally.

    But, once I start a print, I have two sensors on the extruder showing me 2000°C and the third one 0°C. Shortly after, I lose the connection on the Mother Board and the print is stopped.
    The last time I got that error message : Error: M308: Response timeout: CAN addr 1, req type 6011, RID=901
    The previous time I had this one : Failed to upload dwc2settings.json
    Operation failed (Reason: Your Duet rejected the HTTP request: Unknown message type or not authenticated)

    Once the sensors are showing me these anormal values I wasn't able to reset them, even with a M562, unless reseting the whole printer.
    Here is what I get when trying a M308 S4 : Sensor 4 type PT100 (MAX31865) using pin 1.spi.cs2, last error: success, 2/4 wires, reject 50Hz, reference resistor 400 ohms

    The issue only concerns the sensors that are connected to the Duet 3 EB 3HC. The build plate sensor doesn't have any problem.

    I am kind of stuck here so any help would be appreciated.

    Thanks,



  • [Edit] : It seems that there is a CAN connection failure right when the temperature sensors start showing the incorrect values.
    Once the CAN connection is working again the temperatures are either incorrect either non existent ( no sensor is found.


  • administrators

    What firmware versions are you running on the main and expansion boards?



  • Hi,

    Thank you for taking time to answer.

    The firmware versions of the mother board and the expansion board are respectively :

    • FIRMWARE_NAME: RepRapFirmware for Duet 3 MB6HC FIRMWARE_VERSION: 3.1.0 ELECTRONICS: Duet 3 MB6HC v0.6 or 1.0 FIRMWARE_DATE: 2020-05-15b1

    • Board EXP3HC firmware 3.0RC1 2019-12-16b1



  • from the changelog

    https://github.com/Duet3D/RepRapFirmware/blob/v3-dev/WHATS_NEW_RRF3.md

    RepRapFirmware 3.2-beta2
    M111 supports CAN module debug


  • Moderator

    Time for a firmware update to at least 3.1.1

    https://github.com/Duet3D/RepRapFirmware/releases/tag/3.1.1



  • Hi,

    I tried to update the firmware to 3.1.1 for the expansion board and still had the problem but without having the sensors temperatures showing 2000°C.

    With the firmware 3.2-beta3.2 on both the expansion and the mother boards it seems that the issue is gone.

    Thanks a lot for the answers!


  • administrators

    I'm glad it seems to be solved. Please upgrade to 3.2beta 4, which fixes issues in 3.2beta 3.2.


Log in to reply