Duet 3 standalone not starting



  • I am trying to use my Duet3 in standalone mode until I can get a solution for print failures with SBC.

    Firstly I tried without any firmware changes (last update was to 3.2beta3.2 with SBC) I have setup a new SD formatted to fat32 with sys dir containing previous config files and www file containing js/css/etc... files. Powered up board with that in and connected to switch via ethernet port. I get no lights on either switch or duet3 port. I have connected a paneldue to io0 after swapping to a 5 pin connector as per paneldue instructions. Paneldue powers on but sits on connecting at top right hand corner.

    I then downloaded 3.1.1 firmware, flashed duet3 using bossa over USB, this took an insane ammount of time (close to 1hr) but completed, I swapped over files in www folder for the ones in this download (Duet2and3Firmware-3.1.1) but powering on duet3 gave same result.

    EDIT: Mods can this be moved to correct forum, firmware not installing was me being stupid and now resolved but issues with getting board to start in standalone mode remain.



  • @Via
    Start here - fallback procedure #3. Especially the part which says

    "If using Bossa:

    Check boxes Erase all, Lock, and Boot from Flash "


  • Swear I am going blind 🤦 firmware flashed and verified now...

    Still does not see to be starting up though, powering on I get a flashing diag led, nothing on ethernet port / switch and paneldue still sits on connecting.

    Should Duet3 output anything to serial port on boot like Duet2? Opening serial terminal and resetting board I get absolutely nothing through.



  • @Via said in Duet 3 standalone not starting:

    firmware flashed and verified now...

    and reset?

    also, what does the board identify as in device manager? if it still says bossa you need to flash again and reset the board according to the procdedure. (or use the command line version with -R parameter)



  • @bearer reset and totally powered off and back on. Board shows up as "USB Serial Device" not bossa.



  • @Via said in Duet 3 standalone not starting:

    Board shows up as "USB Serial Device" not bossa.

    should give you some output methinks, or at least respond to g-code like m115. baud rate shouldt matter, but which terminal/settings are you using?

    (edit: worth noting the serial device is removed and re-added when you reset the board, causing you to have to reconnect unless the terminal figures that out on its own. which means it could be tricky to capture the boot message.)



  • @bearer YAT seems to stay connected to the port (which remains the same excluding switching to / from bossa). I have also tried putty which more annoyingly does disconnect but even with finger hovering over connect button for when I hit reset gives me nothing.

    Speed is set as default at 9600 only change to YAT was changing end of line to <LF> as per Duet2 guide (https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7?lang) couldn't see any mention of speed on that (or I really am going blind!) but screenshot shows 9600.

    (edit full settings) data bits: 8, parity: none, stop bits: 1, flow control: none


  • Moderator

    Do you have M552 S1 in your config.g to enable networking?
    Do you have M575 P1 B57600 S1 in your config.g to enable the PanelDue?



  • @Phaedrux No 😞

    Added and needless to say it works now. Can I suggest the networking one being added to getting started. I presumed network would be always on.

    Also the paneldue one to the paneldue bit on getting started as well, checked that to know to change wiring and what IO to use but was previously used on Duet2 with RRF2 so worked out of the box without any config.


  • Moderator



  • @Phaedrux said in Duet 3 standalone not starting:

    How's this?

    https://duet3d.dozuki.com/Wiki/Getting_Started_With_Duet_3?revisionid=HEAD#Section_Running_in_standalone_mode

    Excellent, It's the simple small things like this that are make or break at times, this small addition will help others from enduring similar time consuming frustrations in the future.


Log in to reply