Wrong heater number for tool when no Bed - RRF Config Tool



  • When generating a config using the config tool and the bed is removed as heater, the wrong heater number is populated in the tool definition.
    This is what is generated.

    ; Heaters
    M140 H-1                                      ; disable heated bed (overrides default heater mapping)
    M308 S0 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin e0temp
    M950 H0 C"e0heat" T0                          ; create nozzle heater output on e0heat and map it to sensor 0
    M307 H0 B0 S1.00                              ; disable bang-bang mode for heater  and set PWM limit
    M143 H0 S280                                  ; set temperature limit for heater 0 to 280C
    
    ; Fans
    M950 F0 C"fan0" Q500                          ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                          ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0 T45                             ; set fan 1 value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                              ; define tool 0
    G10 P0 X0 Y0 Z0                               ; set tool 0 axis offsets
    G10 P0 R0 S0                                  ; set initial tool 0 active and standby temperatures to 0C
    

    And it should be

    ; Tools
    M563 P0 D0 H0 F0                              ; define tool 0
    

    @chrishamm


  • administrators

    Thanks, it's fixed in the new version 3.1.8.


Log in to reply