[3.2-beta-3.2] Unexpected token < in JSON at position 0

  • since I upgraded from 3.1.1 to the latest beta, I get this error spammed:

    Connection interrupted, attempting to reconnect... Unexpected token < in JSON at position 0


    I checked all json files in the /sys/ directory, none of them contain a "<" token.

    Board: Duet2 Wifi 1.02

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.2-beta3.2 ELECTRONICS: Duet WiFi 1.02 or later + DueX5 FIRMWARE_DATE: 2020-11-12

    Duet Web Control 3.2.0-beta3

  • do you have special characters in your config for names?

  • @Veti said in [3.2-beta-3.2] Unexpected token < in JSON at position 0:

    do you have special characters in your config for names?

    Not that I am aware of, posting config.g for reference:

    ; General preferences
    M111 S0                                              ; Debugging off
    ; Network
    M550 P"CoreDuet ZXY"								 ; Set machine name
    M551 Pilidm970                                       ; Set password
    M552 S1                                              ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 R21000                                    ; Enable HTTP on Port 21000
    M586 P1 S0                                           ; Disable FTP
    M586 P2 S0                                           ; Disable Telnet
    G21                                                  ; Work in millimetres
    G90                                                  ; Send absolute coordinates...
    M83                                                  ; ...but relative extruder moves
    M555 P2                                              ; Set firmware compatibility to look like Marlin
    M911 S23.0 R24 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Configure automatic saving on power loss
    M667 S1                                              ; Select CoreXY mode
    M208 X0 Y0 Z0 S1                                     ; Set axis minima
    M208 X175 Y269 Z200 S0                               ; Set axis maxima
    ; Drives
    M569 P0 S1                                           ; Drive 0 goes forwards (Alpha)
    M569 P1 S0                                           ; Drive 1 goes backwards (Beta)
    M569 P2 S1                                           ; Drive 2 goes forwards (Z1)
    M569 P3 S0                                           ; Drive 3 goes forwards (E1)
    M569 P4 S1					                         ; Drive 4 goes forwards (E2)
    M569 P5 S1					                         ; Drive 5 goes forwards (Z2)
    M569 P6 S1					                         ; Drive 6 goes forwards (Z3) 
    M92 X160 Y160 Z3200 E837                             ; Set steps per mm
    M350 X16 Y16 Z16 I1                                  ; Configure microstepping with interpolation
    M350 E16 I0
    M566 X300 Y300 Z100 E600                             ; Set maximum instantaneous speed changes (mm/min) - jerk
    M203 X18000 Y18000 Z400 E1800                        ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z30 E300                            ; Set accelerations (mm/s^2) - limit
    M906 X1600 Y1600 Z1500 E1250 I10                      ; Set motor currents (mA) and motor idle factor in per cent
    M84 S10                                              ; Set idle timeout
    M584 X0 Y1 Z2 E3                                      ; Z Single belt setup E:4:5:6:7:8:9 
    ;M584 X0 Y1 Z2:5:6 E3:4:7:8:9                         ; three Z motors connected to driver outputs 2, 5 and 6
    M671 X-85:83:250 Y73:315:73 S3                       ; leadscrews at front left, rear mid, front right
    ; Endstops
    M574 X1 Y1 Z0 S0                                     ; Set active low endstops
    M574 Z1 S2                                           ; Set endstops controlled by probe
    M558 P8 C"^!zprobe.in" X0 Y0 Z1 H6 R0.3 F900 T9000 A6 S0.015     ; Piezo V2 probe used for homing Z axis, dive height 2cm, probe speed 600mm/min, travel speed 150mm/s
    G31 P500 X0 Y0 Z-0.14                                ; Set Z probe trigger value, offset and trigger height
    M557 X25:150 Y20:100 S25:20                          ; Define mesh grid
    M572 D0 S0.08					                     ; pressure advance
    M593 F51                                             ; DAA 51 Hz
    M207 S1.4 R0 F3600 				                     ; firmware retraction
    M929 P"eventlog.txt" S1				                 ; enable eventlogging
    ; Heaters
    M308 S0 A"Bed" P"bed_temp" Y"thermistor" T100000 B4138 C0 R4700; define bed temperature sensor
    M950 H0 C"bed_heat" T0                               ; heater 0 uses the bed_heat pin, sensor 0
    M140 H0                                              ; the bed heater is heater 0
    M143 H0 S140                                         ; Set temperature limit for heater 0 to 140C
    M307 H0 R1.006 C181.5 D1.87 S1.00 V23.7              ; RRF3.2 PID tuning for bed 
    M308 S1 A"Nozzle" P"e0_temp" Y"thermistor" T100000 B4725 C7.06e-8; e3d thermistor
    ;M308 S1 A"Nozzle" P"spi.cs1" Y"rtd-max31865" R395 F50 ; Use PT100 on channel 200 (1st on daughterboard)
    M950 H1 C"e0_heat" T1          						 ; heater 1 uses the e0_heat pin and sensor 1
    M307 H1 R1.447 C295.5:233.5 D7.55 S1.00 V24.1 		; New RRF 3.2 heater tuning, 30W Heater, E3D Thermistor
    ;M307 H1 A482.9 C310.9 D4.0 S1.00 V24.1 B0 ; PID Tuning with 30W heater and PT100
    ;M307 H1 A515.8 C238.9 D6.1 S1.00 V24.1 B0 ; PID Tuning with 25W heater and normal thermistor
    M143 H1 S280                                         ; Set temperature limit for heater 1 to 280C
    ;M141 H2						                         ; chamber sensor uses E1 thermistor input
    ;M305 P2 T100000 B4725 C0.0000000706 R4700            ; Set thermistor + ADC parameters for chamber sensor
    ;M308 S2 A"Chamber" P"e1_temp" Y"thermistor" T100000 B4138 C0 R4700; define chamber temperature sensor
    M308 S2 A"Chamber" P"spi.cs1" Y"rtd-max31865" R395 F50 			   ; Use PT100 on channel 200 (1st on daughterboard)
    ; Tools
    M563 P0 D0 H1                                        ; Define tool 0
    G10 P0 X0 Y0 Z0                                      ; Set tool 0 axis offsets
    G10 P0 R0 S0                                         ; Set initial tool 0 active and standby temperatures to 0C
    ; Fans
    M950 F0 C"fan0" Q500
    M106 P0 S0 H-1                                       ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 
    M106 P1 S255 H1 T45                          ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M950 F2 C"fan2" Q500 
    M106 P2 S40 B0 L0 H-1                        ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M307 H3 A-1 C-1 D-1				     ; disable heater output 3 so that we can use this for our servo motor
    ; Miscellaneous
    M564 H0						     ; Allow movement of axes before homing	
    T0                                                   ; Select first tool

  • FYI, Reverting DWC back to 3.1.1 solves this issue.
    Doing so lost all my settings, ugh

  • administrators

    I've loaded your config.g file on a Duet WiFi, with minor changes (e.g to the HTTP port and password) but I am unable to reproduce the problem. Did you need to do anything to provoke the problem?

    I got a few error/warning messages from your config.g file, although they shouldn't cause that type of problem:

    Error: endstop type 0 is no longer supported. Use type 1 and invert the input pin instead.
    Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 452C
    Error: Heater 3 not found

  • I suspect it's a DWC problem. I had the GCode Viewer plugin installed maybe that is causing the problem.
    Will experiment more tomorrow (printer is printing atm)

  • administrators

    if the problem occurs without the plugin, then a Wireshark trace of the HTTP traffic to/from the Duet's IP address that covers a time when this error is reported would be helpful.

  • So I tried to repupgrade DWC to 3.2 beta 3 and now I no longer get the error.
    I guess DWC did not like something in the settings json file.

  • administrators

    Thanks, I'll mark this as solved.

Log in to reply