Problems in web interface



  • I'm having problems in the web interface, none of the changes I make to config.g are being saved (I click apply settings, and it doesn't ask me if I want to reboot the duet after the config upload).

    Also it seems if I'm on the 5G network (dual bandwidth modem) and the duet is on the 2.4G network, I sometimes have connection issues, and generally after a minute or two I get an AJAX error (I couldn't reconnect on the 5G network so I switched to the 2.4G network and its connected fine now). I'm not super familiar with how routers work, but I would've assumed that I should be able to connect to it on either of the bandwidths without issues since its an ip address on the router? I am using the shortened name (rostock.local instead of the IP address since I'm on OS X), not sure if that makes a difference?

    I'm powering it all over USB, nothing is connected, its just sitting on its own. I tried it on the supplied firmware, and then I updated to the new 1.13b, both with the same problems. I followed the setup instructions on the duet3d site to start the web server from pronterface. Its connecting fine, but I had to take the sd card out of the board to change the config.g file so it starts the web server by default.



  • I'm seeing the same thing, updates to the config.g file are not saving when "Apply Settings" is clicked. No error message either - I'd expect a success check of some sort?

    Otherwise smooth sailing so far, all set up and configured, going to install into a BigBox shortly.


  • administrators

    I don't understand why it's not asking you if you want to restart after you click Apply Settings. If that happens, try clicking on Emergency Stop, or send command M999 from the GCode Console. Either of those will restart the firmware. Then open config.g in the web interface again and check that the changes you made were saved.



  • I can't? What happens is I change the config, I scroll down to apply settings, I click that, then the interface "refreshes", it goes back to the machine control panel, but nothing has changed.

    Also if I change the config file, don't click "apply changes", and go to any other tab (whether it be in the settings pane or to machine control, etc) the changes are not there. Not sure if this is supposed to happen? Maybe the web interface bin is messed up?



  • I go here:

    Add a line:

    Click apply:

    The very next thing that happens is I'm brought to the main screen:

    And if I go back to the config.g:

    The extra line is gone.



  • Same exact thing for me. I really like how simple the interface is to use to configure so I'm waiting to get this figured out before I install it in my printer.



  • So that was in OS X/Safari, in Win7/Firefox I see a upload window flash for a second and then this prompt:

    So it seems to be browser or OS related.



  • Works OK in OSX/Firefox, bug seems to be limited to Safari.



  • Well darn. I tried to connect in chrome but it wouldn't accept the .local thing, it kept googling it

    I downloaded firefox and tried it in that and its working fine now. Is this considered a bug thats going to be fixed? I can use firefox with this, its not a big deal, but I do normally use Safari.

    Also is the 5ghz vs 2.4ghz thing something to be concerned about? Same goes with that, I can connect to the 2.4ghz network but I normally connect to the 5ghz network.



  • Throw a "/" at the end of .local, should force Chrome not to search.

    I imagine it will be fixed, yes.


  • administrators

    DuetWebControl uses Ajax, and apparently Safari doesn't work properly with that but I don't know the details. I'll ask the author of DuetWebControl to take a look. In the meantime I suggest Chrome or Firefox. Edge seems to work OK for me too, but I haven't tested it thoroughly.



  • I've been leaving the duet powered on for an extended period of time connected to my computer. I guess I kinda forgot about it tbh. After a while (first time was 2 or 3 hours, this time it was closer to 30 minutes or less) It does the same disconnection problem I was having earlier with the differing network bandwidths. I can't reconnect after it disconnects, I have to restart the duet completely. Not sure whats going on. Are there any logs I can check to see whats going on?


  • administrators

    To see what is going on, connect Pronterface or a terminal emulator via USB. Check whether the Duet WiFi responds to simple gcode commands such as M119. If it does then try restarting the wifi module by sending M552 S0 followed by M552 S1.

    You can also send M111 S1 which will enable debug output.



  • I'll try this in the morning. Thanks dc



  • So the last things in the log before the disconnect were

    [c]Request: status?type=1 fragment 2147483648
    Resp 2147483648: 000100c8 000001a7 {"st…s
    Class Heat spinning
    Class PrintMonitor spinning
    Class Platform spinning
    Class WebServer spinning
    Class GCodes spinning
    Class Move spinning
    Request: disconnect fragment 2147483648
    Resp 2147483648: 000100c8 00000009 {"err":0}[/c]

    It then repeated the class spinning thing a bit later. I was away when this happened. When I got back I was able to reconnect, but it was several hours later.


  • administrators

    The log shows that web browser requested a disconnection. Assuming you didn't press Disconnect, this usually means it had an Ajax error. Did you copy the details of the Ajax error message in the browser? Sometimes it gives additional information, such as a timeout or a JSON parsing error.



  • Of course I don't get the error I want. I'll try again tonight.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.