Extruder Drives error ( Drive 0 = 9999.9)



  • Hi community, this is my first post at this blog, so first of all, thanks in advance for any kind of help, everything is welcome!

    I am trying to print with dual extruders and at some point the extruder stops extruding material and on the status screen I can see that my Drive 0 has reached 9999.9, and it is not working anymore.

    This happens randomly during the print, and I don't have any kind of idea about why this is happening.

    2020-12-03.png

    Any kind of help is more than welcome, thanks.



  • want to start by posting your config?



  • ; Configuration file for Duet Ethernet (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Feb 05 2018 09:08:53 GMT+0100 (Hora estándar romance)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    ; Automatic saving after power loss is not enabled

    ;Z probe BLTouch
    M557 X63:158 Y50:145 S9 ; define probing gride from X=80 to 180, Y=90 to 190mm with a mesh spacing of 10mm

    M307 H6 A-1 C-1 D-1 ;Confugire heater 6 (PWM 4) as control for BLTouch
    M558 P9 H10 F100 T2000 A4 S0.05 ;Configure probe type
    G31 X0 Y-35 Z-25 P25 ;Offset probe-Nozzle

    ;Configure external triggers, optic sensor, extruder limit

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards X
    M569 P1 S0 ; Drive 1 goes forwards Y1
    M569 P2 S0 ; Drive 2 goes forwards Z
    M569 P3 S0 ; Drive 3 goes forwards Y2 (U)
    M569 P4 S0 ; Drive 4 goes forwards E paste
    M569 P5 S0 ; Drive 5 goes forwards E FDM

    M584 X0 Y1:3 Z2 U8 V9 E4:5 P3 ; Apply custom drive mapping
    M350 X16 Y16:16 Z16 U16 V16 E16:8 I1 ; Configure microstepping with interpolation
    M92 X320 Y320:320 Z320 U320 V819 E819:417 ; Set steps per mm
    M566 X100 Y100:100 Z50 U100 V100 E100:2 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000:6000 Z3000 U6000 V300 E300:500 ; Set maximum speeds (mm/min)
    M201 X100 Y100:100 Z100 U100 V50 E50:1500 ; Set accelerations (mm/s^2)
    M906 X1800 Y1800:1800 Z1800 U1800 V1200 E1200:1680 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    M208 X0 Y0 Z-5 U0 V0 S1 ; Set axis minima
    M208 X200 Y180 Z93.1 U200 V75 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z2 U1 S0 ; Set active low endstops for X, Y, Z
    M574 V1 S0 ; Set active high endstop for E paste

    ;define relay outputs (neumatic system)
    M307 H5 A-1 C-1 D-1 ;disable heater 5 for relay output
    M307 H2 A-1 C-1 D-1 ;disable heater 2 for relay output

    ;define heaters
    M305 P0 R4700 T100000 B3950 ; set bed thermistor parameters
    M305 P3 R4700 T100000 B3950 ; set FDM heater thermistor parameters
    M307 H0 A116.2 C1058.1 D2.6 V21.6 B0 ; set PID parameters bed heater
    M307 H3 A275.3 C82.7 D4.4 V23.9 B0 ; set PID parameters FDM heater

    ; Tools
    M563 P0 D0 S"PASTE" ; Define tool 0
    G10 P0 X0 Y0 Z1.1 ; Set tool 0 axis offsets
    M567 P0 E1 ;define mix ratio

    M563 P1 D1 H3 S"FDM" ; Define tool 1
    G10 P1 X54 Y-7.5 Z-16.7 ; Set tool 1 axis offsets
    M567 P1 E1 ;define mix ratio

    ; Network
    M550 PTRANSPORT-PRINTER ; Set machine name
    M540 PBE:EF:5E:AD:4D:18 ; Set MAC address
    M552 P192.168.84.18 S1 ; Enable network
    M553 P255.255.255.0 ;Set Netmask

    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    G54
    T0 ; Select Tool
    M571 P2 S1 ; turn on logical pin 2 while extrusion is commanded

    M375 P"CustomHeightMap.csv" ; Load Height Map for grid compensation



  • @Oriol said in Extruder Drives error ( Drive 0 = 9999.9):

    M350 X16 Y16:16 Z16 U16 V16 E16:8 I1 ; Configure microstepping with interpolation

    this does not work. the duet wifi can only do interpolation at x16

    ; Configuration file for Duet Ethernet (firmware version 1.20 or newer)

    if you really are on firmware veresion 1, you need to update.



  • In general settings says that the version I am using is Duet Web Control 2.0.4
    Is this related to your comment? Thnaks.



  • post the output from M115



  • 2c3ecd38-0760-4006-86d7-47b824cde8b5-image.png



  • please update to at least 2.05.1

    better would be rrf3, but that means a changed config.



  • Great, I will try it and see if it works. Thanks.


  • Moderator

    Can you post the gcode file you're trying to print?
    Do you get any error messages in the console?


Log in to reply