Bad reply format version



  • I just bought a new DuetWifi board from Spool3d. Duet 2 Wifi-EA v1.04c [16.1944] with an external antenna.
    Right out of the box, after modifying config.g to my needs I was unable to add my network using M587.
    I tried the suggested work around:

    • M552s S-1, M552 S1
    • M588 S"*"
    • Downloading the latest firmware update (2.05.1 - Feb 9, 2020) replaced the files under /sys and used M997 S0:1 to update. Twice.

    Note that I have six 3D printers with an older version of the DuetWifi board with no external antenna here on the same network working flawlessly.

    The error I get is always the same:

    M587: Failed to add SSID to remembered list<LF>ok<LF>Error retrieving WiFi status message: bad reply format version<LF>WiFi module is idle<LF>WiFi reported error: no known networks found
    

    Please advise me. I have no clue why this is happening and how to work around it.

    Cheers!


  • Moderator

    Are you sending the M587 command to add the SSID and password over USB terminal? Does your SSID or password contain any capital letters?

    It may be a better idea to use a macro to execute the command to add the SSID instead. That way the USB sending program can't interfere with the letters being sent.

    You can also test the functionality of the wifi module by putting it in Access Point mode and connecting to the Duet directly.

    https://duet3d.dozuki.com/Wiki/Gcode?revisionid=HEAD#Section_M589_Configure_access_point_parameters



  • I think I've seen one module that was giving me the same issue if I didn't reset it again after clearing the stored networks with m558, also i think i only used m552 s-1 m552 s0 to reset it instead of m552 s-1 m552 s1 until the new network is stored and then just m552 s1


  • administrators

    As @bearer says, you should use M552 S0 (not M552 S1) before trying to store the SSID details using M587 etc.



  • @Phaedrux

    Hey,

    Thank you for your response. I doubt that command sent was off. I am using YAT and I did the same process for the other 6 board I have here so if all letter were capitalized through USB I would have observed this issue before.

    Alright, good to know about access point if I run into any further issues, I'll look into that.



  • @bearer
    @dc42

    Yes! that solved it. Once I sent M552 S-1, M552 S0
    I was able to successfully send the M587 command with the SSID and PW and receive an IP adress to connect to

    Thanks for the input!


Log in to reply