DWC 1.17+1 (and 2) controlling extruders issues?



  • I have a mixing hot end. So multiple tools all sharing the same heater. Previously, to extrude or retract filament from one particular extruder, I'd set the relevant tool to active, set the feed amount and feed rate and hit extrude. With this latest version, all tools are active together (because they share the same heater - but see later edit) so I assumed that I'd need to select the correct extruder drive before hitting extrude or retract. However, it seems only "1" or "All" work but setting to "All" is the same as setting to "1". Setting extruder drive to 2 or 3 doesn't do anything. Could this be because I've re-mapped the drives thus M584 X0:3 Y1:4 Z2 E5:6:7:8:9 ? I doubt this is the reason because the driver that was assigned to extruder 1 (or zero as I prefer it- see later) currently has nothing connected to it. Edit - just tried it with tool 0 as a mixing tool and all 3 extruders do move. I actually only have 3 extruders fitted at the moment but the other two will be fitted shortly.

    Another little gripe. I haven't used the S1 parameter in M563 so my tool definitions start with tool 0 and they are displayed on DWC correctly as such. When I set mixing ratios or define tools, I use extruders 0 (zero) to 2 (soon to be 4). Yet DWC shows extruder drives 1 to 3. Could they possibly be labelled starting at drive zero unless the S1 parameter is set in M563 please?

    Lastly, DWC shows only 3 drives although 5 drivers are mapped but I'm assuming that's because I haven't yet assigned the other two extruders to any tools?

    In a nutshell, how can I extrude or retract filament from any given extruder via DWC 1.17+1?

    Thanks

    Ian

    Edit. Actually, I don't like how all tools that share the same heater can be active together. If I want to test my mixing ratios for a tool that uses say 2 of the 5 extruders, how can I do that? Setting tool 0 to active sets all the others to active as well. So all extruders are tuned on and there is no way to turn a particular one off.


  • administrators

    Have you checked whether any of the above is fixed in DWC 1.17+2?



  • I would think you would need all extruder motors on regardless of how many are in actual use at any given moment in time. If the unused motors were turned off what would keep pressure on the unused filaments?

    Frederick



  • Ref 1.17+2 - didn't know there was one - my fault for not keeping abreast. I've just stripped the machine down so it's a pile of bits right now and I can't check anything.

    @Frederick - I haven't fitted the 5 colour hot end or extruders to the machine yet I just mapped the drives ready as I'm moving all the extruders to the Duex5. It's 3 colour at the moment (actually is no colours right now - just a pile of bits).



  • @deckingman:

    @Frederick - …actually is no colours right now...

    Something to be said for a "no color" unit - it always work perfectly and never needs cleaning or adjustment.

    Frederick



  • Ok so I've updated to DWC and the drive buttons still only work on drive 1 and "All". I'm still on firmware 1.19 beta8 so I'll update that as well and reports back.



  • Upgraded to 1.19.beta11 and still have the problem in that only Drive1 and "All" work. Maybe this is related to the other problem I have in that I can't change the XY direction on my coreXY by swapping plugs. Maybe something to do with M584 mapping?



  • Shameless bump because this is actually quite a problem for me right now as I'm trying to commission 5 extruders. The only way I can move a particular extruder is to use the gcode console and enter a series of commands like T(nn), then G1 E(nn) F(nnn) and repeat for all 5 extruders. This works by the way so I now know that my wiring and configuration are OK. It's just the fact that making a tool active in DWC now makes all the other tools that share that heater active as well, even though they have different extruders. I could probably live with that if the drive buttons worked but they only work for Drive 1. Selectiong "All" sort of works but it only moves drive 1 and none of the other 4. Also the fact that drive buttons are labelled 1 to 5 but I haven't used S1 on M563 so my extruders are 0 to 4, my tools are 0 to 4, my extruder mount has the numbers 0 to 4 embedded into the surface and having to use buttons 1 to 5 is driving me nuts (or it would if they worked). 🙂

    Rant over (but I'd be happier if I saw some comment like "we'll look into it" or some such)


  • administrators

    Only one tool can be active at a time in RRF, so this must be an issue with how DWC is reporting them.



  • Hope Chris Ham sees this thread - be nice to have it fixed before September.


  • administrators

    I've alerted Chris.



  • Any news on this?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.