Probe points with bltouch



  • Hello,

    I am new here, so sorry if the topic is in a wrong category.

    I have build a hevo rs with duet2wifi at our first lockdown in april. Now I am finished but i have some problems with the probe.

    So fist my setup:
    Heatbed: 220x220 ultrabase
    Hotend: e3dv6

    The Hevo is a a frame for 300x300 heatbed but will change the heatbed to a bigger one in the future.

    To set the 0 point (x=0 y=0) to the fron left corner from the heatbed i have the following line in config.g:

    ; Axis Limits
    M208 X-36 Y-70 Z0 S1 ; set axis minima
    M208 X257 Y290 Z700 S0 ; set axis maxima

    With these Lines when i run g1 x0 y0 after g28 the nozzle is at the right position (left front corner from heatbed).

    The BLtouch is mounted 37mm right from the nozzle (x) and 12mm to the front (y). So I have the following line in config.g for the probe:

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T2000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X37 Y-12 Z2.35 ; Set Z probe trigger value, offset and trigger height
    M557 X0:220 Y0:220 S40 ; Define mesh grid

    So the problem is now, when I run G29 it skipps some points and I receive the following error. What I want is to beginn with the first probe at the corner front with 40 or 20 mm distance between the points.

    12.12.2020, 15:34:01 Warning: Skipping grid point (0.0, 120.0) because Z probe cannot reach it
    Warning: Skipping grid point (0.0, 160.0) because Z probe cannot reach it
    12.12.2020, 15:33:07 Warning: Skipping grid point (0.0, 40.0) because Z probe cannot reach it
    Warning: Skipping grid point (0.0, 80.0) because Z probe cannot reach it
    12.12.2020, 15:32:16 M290 R1 Z0.05
    Warning: Skipping grid point (0.0, 0.0) because Z probe cannot reach it

    Could someone help me with the right settings?

    And my second problem is, I have 2 part cooling fans (connected to fan2 and fan1), how can start them together?

    Than your for your help, and sorry for my english :).


  • Moderator

    So your error messages seem to indicate that it can't probe the far left side of the bed, which makes sense because your probe is 37mm to the right of the nozzle, so unless the nozzle can go 40mm off the edge of the bed, the probe can't reach it.

    M208 X-36 Y-70 Z0 S1 ; set axis minima

    When your hotend hits the x endstop is the nozzle actually 36mm off the edge of the bed?

    Change your M557 X0 to M557 X40


  • Moderator

    @ozi said in Probe points with bltouch:

    And my second problem is, I have 2 part cooling fans (connected to fan2 and fan1), how can start them together?

    In your tool definition you would need F1:2 instead of just F1. However, it's best to have Fan1 as the hotend heatsink fan, and use Fan0 and Fan2 for your part cooling fans. This is because Fan1 will turn on automatically at boot briefly which is useful in the case of a power cycle while the hotend is hot to help prevent a clog. In that case, the tool definition would have F0:2

    Post your fan and tool config if you need more help.


Log in to reply