IDEX z-offset still not working



  • When I installed my first duet board on May23, I was unable to get z-offset for my second head to work, so today I gave it another go.

    It still does not work.

    I have defined the z-offset of my second head to 10mm but it still prints at the same height as head 0

    You promised to fix it in beta 7, but no change.

    Can you please fix this? - I already installed a customer printer with this firmware and I keep promising him that the second head will work soon, yet show up with nothing.

    Did I misconfigure it? - Config.g here:

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed May 17 2017 18:05:05 GMT+0200 (Romance Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P5 ; Set firmware compatibility to look like Repetier

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards X
    M569 P1 S1 ; Drive 1 goes forwards Y
    M569 P2 S1 ; Drive 2 goes forwards Z
    M569 P3 S1 ; Drive 3 goes forwards X2
    M569 P4 S1 ; Drive 4 goes forwards ********UNUSED
    M569 P5 S0 ; Drive 5 goes backwards E1
    M569 P6 S1 ; Drive 6 goes forwards E2

    M584 X0 Y1 Z2 E5:6 U3; Create U axis for second X carriage before we try to configure it

    ; test A-axis for rotating head
    ;--------------------------------------------------------
    ;M584 V9; Create V axis for second X carriage before we try to configure it
    ;
    ;M208 V-999999999 ; Set axis minima
    ;M208 V999999999 ; Set axis maxima
    ;
    ;M350 V16 I1 ;Configure microstepping without interpolation
    ;M92 V8.882 ; Set steps per degree
    ;M566 V1000 ; XYZEE-Jerk - Set maximum instantaneous speed changes (mm/min)
    ;M203 V52000 ; Set maximum speeds (mm/min)
    ;M201 V3000 ; Set accelerations (mm/s^2)
    ;M906 V1200 ; Set motor currents (mA) and motor idle factor in per cent
    ;--------------------------------------------------------

    M208 X-28 Y0 Z0 U0 S1 ; Set axis minima
    M208 X290 Y300 Z420 U387 S0 ; Set axis maxima

    M350 X16 Y16 Z16 U16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 U80 Z1600 E1850:1850 ; Set steps per mm
    M566 X1000 Y1000 U1000 Z100 E500:500 ; XYZEE-Jerk - Set maximum instantaneous speed changes (mm/min)
    M203 X52000 Y52000 U52000 Z500 E400:400 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 U3000 Z250 E1000:1000 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 U1200 Z1200 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Endstops
    M574 X1 Y1 Z1 U1 E0 S0 ; Define active low and unused microswitches
    ;M558 P6 X0 Y0 U0 Z0 H1 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    ; G31 P600 X20 Y-8 Z-5 ; Set Z probe trigger value, offset and trigger height
    ;M557 X15:235 Y15:285 S20 ; Define mesh grid

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2

    ; Tools
    M563 P0 D0 H1
    M563 P1 D1 H2 X3 ; tool 0 uses extruder drive 0 and heater 1 and maps X to U
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R00 S00 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 X3 ; tool 1 uses extruder drive 1 and heater 2 And maps X to U
    G10 P1 X0 Y2.06 Z10 ; Set tool 1 axis offsets
    G10 P1 R00 S00; Set initial tool 1 active and standby temperatures to 0C

    ; Network
    M550 P"Awesomemaker 3 Wifi" ; Set machine name
    M552 S1 ; Enable network
    ;M587 SAtlas Connect P"Atlas Connect" ; Configure access point. You can delete this line once connected
    ;M586 P0 S1 ; Enable HTTP - Not implemented
    M586 P1 S1 ; R21 T1; Enable FTP
    ;M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0 I0 F200 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F200 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F200 H2 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings
    M575 P1 B57600 S1 ;Setup PanelDue
    ;Override fan controls for hotend cooling fans
    ;M106 P0 S0 I0 F100 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ;M106 P1 S0 I0 F100 H2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Miscellaneous
    ;T0 ; Select first tool
    ; BLTouch
    M307 H3 A-1 C-1 D-1 ; BLTouch - on heater 3 pin
    M558 P5 X0 Y0 Z1 H3 F200 T5000 ; Homing Z axis, P5 for BLTouch
    G31 X-24.00 Y-7.0 Z1.65 P50 ; Set the probe height - Larger number is closer

    M557 X20:280 Y20:280 S20 ;Define bed probing grid

    G29 S1 ; Load calibration height map

    M280 P3 S1500 I0 ;Make sure the BLTouch probe is up


  • administrators

    Have you tried beta 11?



  • I forgot to mention that I updated everything to latest version today, so yes.


  • administrators

    Strange, in beta 7 I fixed a bug in that area, and after that I had a report from another user that the tool Z offset was working correctly. The first G0 or G1 command after a tool change should adjust the Z height, whether or not the command includes a Z coordinate. I'll add this to the test schedule for beta 12 (or RC1 as it may be).



  • What machine do you have?



  • I design my own printers, so you wouldn't know it.
    This one is this: https://www.youtube.com/watch?v=ZgT_-GMgTfY but in the video it is running repetier firmware on a rumba board.

    DC42: the z-coord on the paneldue shows the correct z-coordinate, so it is 0.2mm for head 1 and 10.2 mm when using head 2, printing the same layer. Yet the heads are in fact printing at 0,2mm both of them. So the offest is read and used, just not to control the z-axis.



  • Yes, i see your videos last days. Thanks


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.