Z axis problem and Firmware installation problem



  • Hello,

    I've tried updating my duet 2 wifi but it doesn't seem to have worked it still says that I'm running on 3.1.1. Meanwhile, my Duet wed control is 3.2.0. When I try to install it, it gives me the message (Error: M997: In-application programming binary "Duet2CombinedIAP.bin" not found).
    But that's not my biggest problem, the problem that I've been having is that when I start a print, it prints the base of the model (I've just tried with components with small bases) it prints it fairly well but when it starts printing the wall ( the model is like a box without a lid), it just won't print. It's like if it was going down instead of going up. So the extruder gets stuck and then the print is ruined.
    I've looked in cura to see if I haven't put a mirrored setting or something but I couldn't find anything wrong.
    I've also looked in my config.g file to see if I haven't put a - somewhere, but I can't find anything.

    The strange thing is that I can move all my axes in every directions, the values are right and there is no problem here.
    I've also tried printing letters and they came out mirrored compared to cura.

    All of these strange things started to happen when I put a probe on the machine and "tried" to update to 3.2.0

    The machine :

    • Duet 2 wifi + deux 5
    • Original BLTouch
    • Custom machine (1200x1000x850), Cartesian type

    That's my config.g

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sat Nov 14 2020 12:54:59 GMT+0100 (Central European Standard Time)
    
    ; General preferences
    G90                                                                     ; send absolute coordinates...
    M83                                                                     ; ...but relative extruder moves
    M550 P"The Dream Machine"                                               ; set printer name
    
    ; Network
    M552 S1                                                                 ; enable network
    M586 P0 S1                                                              ; enable HTTP
    M586 P1 S0                                                              ; disable FTP
    M586 P2 S0                                                              ; disable Telnet
    
    ; Drives
    M569 P0 S1                                                              ; physical drive 0 goes forwards
    M569 P1 S0                                                              ; physical drive 1 goes forwards
    M569 P2 S1                                                              ; physical drive 2 goes forwards
    M569 P3 S0                                                              ; physical drive 3 goes forwards
    M569 P4 S1                                                              ; physical drive 4 goes forwards
    M569 P5 S0                                                              ; physical drive 5 goes backwards
    M569 P6 S1                                                              ; physical drive 6 goes backwards
    M569 P7 S1                                                              ; physical drive 7 goes forwards
    M569 P8 S0
    M569 P9 S0
    M584 X0 Y1:5:6:7 Z8:9 E3:4                                                ; set drive mapping
    M350 X16 Y16 Z16 E16:16:16:16:16 I1                                     ; configure microstepping with interpolation
    M92 X160.00 Y80.00 Z800.00 E420.00:420.00:420.00:420.00:420.00           ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00:120.00:120.00:120.00:120.00         ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00:1200.00:1200.00:1200.00:1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00:250.00:250.00:250.00:250.00         ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200:1200 I30                      ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                                                 ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                                        ; set axis minima
    M208 X1000 Y1200 Z850 S0                                                ; set axis maxima
    
    ; Endstops
    M574 X1 S1 P"xstop"                                                     ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop"                                                     ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S1 P"zstop"                                                     ; configure active-high endstop for low end on Z via pin zstop
    
    ; Z-Probe
    M558 P9 C"^zprobe.in" H5 F120 T7200
    G31 P500 X-50 Y-4 Z1.7
    M950 S0 C"duex.pwm1"                                                   
    M557 X70:900 Y70:1100 S100
    M671 X-12.75:1255 S2.5
    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138                          ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                                                   ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00                                                        ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                                                 ; map heated bed to heater 0
    M143 H0 S75
    M570 H0 P150 T15                                                             ; set temperature limit for heater 0 to 75C
    M308 S1 P"spi.cs1" Y"thermocouple-max31856"                          ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                                                    ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00
    M570 H1 P150 T15                                                        ; disable bang-bang mode for heater  and set PWM limit
    M308 S2 P"e1temp" Y"thermistor" T100000 B4138                           ; configure sensor 2 as thermistor on pin e1temp
    M950 H2 C"e1heat" T2                                                    ; create nozzle heater output on e1heat and map it to sensor 2
    M307 H2 B0 S1.00                                                        ; disable bang-bang mode for heater  and set PWM limit
    
    ; Fans
    M950 F0 C"fan0" Q500                                                    ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                                          ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                                                    ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H-1                                                          ; set fan 1 value. Thermostatic control is turned off
    
    ; Tools
    M563 P0 S"Super Volcano" D0 H1 F0                                       ; define tool 0
    G10 P0 X0 Y0 Z0                                                         ; set tool 0 axis offsets
    G10 P0 R0 S0                                                            ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Volcano" D1 H2 F1                                             ; define tool 1
    G10 P1 X0 Y0 Z0                                                         ; set tool 1 axis offsets
    G10 P1 R0 S0                                                            ; set initial tool 1 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M575 P1 S1 B57600                                                       ; enable support for PanelDue
    
    
    

    That's my M122 :
    IMG_3588.jpg

    If someone could help me, it would be awesome because there I'm stuck.

    Cheers,
    George


  • Moderator

    If you still have access to DWC. Upload these 3 zip files, one at a time in the system tab. Don't extract them. Reboot after each. Use M115 to verify the firmware has been applied.
    https://github.com/Duet3D/RepRapFirmware/releases/download/2.05.1/Duet2Firmware-2.05.1.zip
    https://github.com/Duet3D/RepRapFirmware/releases/download/3.0/Duet2and3Firmware-3.0.zip
    https://github.com/Duet3D/RepRapFirmware/releases/download/3.2/Duet2and3Firmware-3.2.zip
    That will get your firmware and DWC up to date.

    It may seem silly to start with 2.05 but it will ensure that all the required files are present in case you ever need to move between versions. In all it would take 10 minutes tops.



  • @Phaedrux I tried to instal the 2.0, the 3.0 and 3.2 and it gave me the same message, so I can’t install any one of them.





  • I've installed all the updates one by one. And tried to print something and it seems like everything is working. All of my problems have been resolved after the 3.2 update.

    Thank you very much for you're time and you're help.
    Cheers
    George


Log in to reply