Tronxy X5SA-400 Z-probe Calibration issue



  • Hi to all !

    I have upgraded my tronxy X5SA-400 with the duet2-wifi (fw 3.2.0) and I have managed everything to working fine but I have one last problem, I'm not able to calibrate the Z-Probe !

    Whatever I try after Calibration my nozzle stick a couple of millimeters over the bed which is really sad !

    I have follow this procedure : Test And Calibrating the Z probe but each time I restart the nozzle stick a couple of mm over the bed.

    The first try was with this Z-probe config :

    ; Z-Probe
    M574 Z1 S2
    M558 P1 C"!zprobe.in" H5 F100 T36000 
    G31 P250 X-32 Y-10 Z1.89                            
    M557 X60:320 Y60:320 S65                          
    

    After some research I tried to change the probe type to P5 :

    ; Z-Probe
    M574 Z1 S2
    M558 P5 C"!zprobe.in" H5 F100 T36000 
    G31 P250 X-32 Y-10 Z1.89                            
    M557 X60:320 Y60:320 S65                          
    

    I have adjusted the G31 Z value as indicated in the calibration procedure but nothing changed after homing and getting the Z to 0 I'm not touching the bed at all.

    Has anybody I great idea ?



  • did you change your homing scripts to use the probe?



  • I don't think so, if I remember right they are more or less the defaults :

    My homez.g :

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v3.2.2 on Thu Jan 28 2021 17:56:19 GMT+0100 (CET)
    G91               ; relative positioning
    G1 H2 Z5 F6000    ; lift Z relative to current position
    G1 H1 X-405 Y-405 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 X80 Y50 F6000		; Move head in postion to trigger z-stop
    G1 H1 Z-405 F1800 ; move Z down until the endstop is triggered
    G92 Z0            ; set Z position to axis minimum (you may want to adjust this)
    
    ; Uncomment the following lines to lift Z after probing
    ;G91              ; relative positioning
    ;G1 Z5 F100       ; lift Z relative to current position
    ;G90              ; absolute positioning
    

    and the homeall.g :

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v3.2.2 on Thu Jan 28 2021 17:56:19 GMT+0100 (CET)
    G91                     ; relative positioning
    G1 H2 Z5 F6000          ; lift Z relative to current position
    G1 H1 X-405 Y-405 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 H1 X-405             ; home X axis
    G1 H1 Y-405             ; home Y axis
    G1 X5 Y5 F6000          ; go back a few mm
    G1 H1 X-405 F360        ; move slowly to X axis endstop once more (second pass)
    G1 H1 Y-405				; then move slowly to Y axis endstop
    G1 X80 Y50 F6000		; Move head in postion to trigger z-stop
    G1 H1 Z-405 F360        ; move Z down stopping at the endstop
    G90                     ; absolute positioning
    G92 Z0                  ; set Z position to axis minimum (you may want to adjust this)
    
    ; Uncomment the following lines to lift Z after probing
    G91                    ; relative positioning
    G1 Z5 F100             ; lift Z relative to current position
    G90                    ; absolute positioning
    
    


  • you did not.

    2 options
    if you did not change anything in your config. load the config.json into the configurator and change the z endstop to probe. then use the newly generated homing scripts.

    or read
    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z



  • GREAT ! thank you 🙏

    Everything is now working as expected!



  • it was the G30 that was missing :

    the new code :

    ; Uncomment the following lines to lift Z after probing
    G91                    ; relative positioning
    G1 Z5 F100             ; lift Z relative to current position
    G90                    ; absolute positioning
    G1 X80 Y50 F6000 ; put head over the centre of the bed, or wherever you want to probe
    G30 ; lower head, stop when probe triggered and set Z to trigger height
    

Log in to reply