Calibration issues Part 293



  • I was really hesistant to create this post, because there's already so much information about the topic.

    But for whatever reasons, I'm still struggling to get an accurate calibration going.

    Let me show you my config files

    Config.g:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Feb 26 2019 21:31:01 GMT+0000 (Greenwich Mean Time)
    
    ; General preferences
    G90                                         				; Send absolute coordinates...
    M83                                         				; ...but relative extruder moves
    
    ; Network
    M550 PPredator                                                                   ; Set machine name
    M552 S1                                                                                   ; Enable network
    M586 P0 S1                                                                                ; Enable HTTP
    M586 P1 S0                                                                                ; Disable FTP
    M586 P2 S0                                                                                ; Disable Telnet
    
    
    ; Delta Settings
    ; default B was 185
    ;Height changed due to new hotend
    ;M665 L440.000 R227 H422.5 B185 						 	; Set delta radius, diagonal rod length, printable radius and homed height
    M665 L440.000 R227 H419.7 B185 						 	; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 A0.00 B0.00               			     	; Put your endstop adjustments here, or let auto calibration find them
    
    ; Network
    M552 P0.0.0.0 S1  	                        				; Enable network and acquire dynamic address via DHCP
    M586 P0 S1                                  				; Enable HTTP
    M586 P1 S0                                  				; Disable FTP
    M586 P2 S0                                  				; Disable Telnet
    
    ; Drives
    M569 P0 S1                                  				; Drive 0 goes forwards
    M569 P1 S1                                  				; Drive 1 goes forwards
    M569 P2 S1                                  				; Drive 2 goes forwards
    M569 P3 S1                                  				; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1                     				; Configure microstepping with interpolation
    ;M92 X80.00 Y80.00 Z80.00 E380.45             				; Set steps per mm
    ; Updated E for Bondtech Extruder
    M92 X80.00 Y80.00 Z80.00 E415             				; Set steps per mm
    M566 X1000 Y1000 Z1000 E1000    	            			; Set maximum instantaneous speed changes (mm/min)
    
    ; Default XYZ=12000 makes 200mm/sec
    M203 X12000.00 Y12000.00 Z12000.00 E10000 				; Set maximum speeds (mm/min)
    ; Increase to 350mm/sec = 350 * 60 = 21000 - Extruder 18000=300mm/sec
    ;M203 X21000.00 Y21000.00 Z21000.00 E18000 				; Set maximum speeds (mm/min)
    
    M201 X3000.00 Y3000.00 Z3000.00 E3000.00    				; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E1000.00 I30 				; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                     				; Set idle timeout
    
    ; Retraction
    ;M207 S4.0 F5000 R-0.025 T2500 Z0.5							; Firmware retraction
    
    ; Axis Limits
    M208 Z-0.4 S1                                  				; Set minimum Z - WARNING, possibly too low, but only setting a minus value allows the printer to baby step below ZERO-Z position
    
    ; Endstops
    M574 X2 Y2 Z2 S1                            				; Set active high endstops
    
    ; Z-Probe
    ; F Dive speed in mm/sec default 120
    ; T Probe Speed in mm/sec default 6000
    ; Very slow settings for testing: F=20 T=600
    ; H Dive height default 5
    M558 P5 H5 F120 T6000 L1                      				; Set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z18.0                      				; Set Z probe trigger value, offset and trigger height - increase if nozzle to far away from bed after calibration
    M557 R185 S70                               				; Define mesh grid
    ;G29 S1                                                                 ; Load default heightmap generated by auto delta calibration
    G29 S3 P"heightmap-mesh.csv"						; Load the mesh-bed-heightmap
    
    
    ; Heaters
    M307 H0 A137.8 C533.3 D1.5 V24.3 B0                       		; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4300 C0 R4700                 				; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                                				; Set temperature limit for heater 0 to 120C
    ; Default china sensor
    ;M305 P1 T100000 B4300 C0 R4700                 				; Set thermistor + ADC parameters for heater 1
    ; Mosquito Temperature sensor
    M305 P1 B3800 T500000 R4700						; Set thermistor + ADC parameters for heater 1 - Mosquito temperature sensor
    M143 H1 S450                                				; Set temperature limit for heater 1 to 450C
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                    				; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ; Currently not connected fan below
    ;M106 P1 S1 I0 F500 H1 T45                   				; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S.5 I0 F18000 H1 T45 B1						; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    Currently my issue is that on one area of the print bed the calibration is accurate, but on other areas the print head is either slightly too high or too low. I can basically only print small parts right now.
    
    ; Tools
    M563 P0 D0 H1                               				; Define tool 0
    G10 P0 X0 Y0 Z0                             				; Set tool 0 axis offsets
    G10 P0 R0 S0                                				; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    ; ATTENTION, Testing Pressure advance of 0.35
    M572 D0 S0.35
    ;M572 D0 S0.1												; Pressure Advance
    ;M591 D0 P2 C4 S1											; Activate filament sensor
    M404 N1.75 												; Set for print monitor
    ; Disabled, not sure what it does
    ;M592 D0 A0.07772 B-0.00029 									; Nonlinear extrusion. Set parameters for extruder drive 0
    
    ; Miscellaneous
    M501                                               			; Load saved parameters from non-volatile memory
    

    bed.g

    ; bed.g
    ; called to perform automatic delta calibration via G32
    ;
    
    ; generated by RepRapFirmware Configuration Tool v3.2.2 on Wed Jan 27 2021 14:09:37 GMT+0100 (Mitteleuropäische Normalzeit)
    M561 ; clear any bed transform
    G28  ; home all towers
    ; Probe the bed at 6 peripheral and 6 halfway points, and perform 6-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    
    ; radius: 180
    G30 P0 X0 Y179.9 H0 Z-99999
    G30 P1 X155.8 Y89.95 H0 Z-99999
    G30 P2 X155.8 Y-89.95 H0 Z-99999
    G30 P3 X0 Y-179.9 H0 Z-99999
    G30 P4 X-155.8 Y-89.95 H0 Z-99999
    G30 P5 X-155.8 Y89.95 H0 Z-99999
    G30 P6 X0 Y89.9 H0 Z-99999
    G30 P7 X77.86 Y44.95 H0 Z-99999
    G30 P8 X77.86 Y-44.95 H0 Z-99999
    G30 P9 X0 Y-89.9 H0 Z-99999
    G30 P10 X-77.86 Y-44.95 H0 Z-99999
    G30 P11 X-77.86 Y44.95 H0 Z-99999
    G30 P12 X0 Y0 H0 Z-99999 S6
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    
    G29
    

    I thought that after running a delta calibration, and then running a mesh bed calibration that the firmware can figure out any missalignments and compensate for that.

    But it kinda seems like that all this calibration information is not used at all. As I mentioned, in one area the print head is too high, in another area it's too low, and then in some areas it's just fine.

    What am I doing wrong?



  • @AdrAs said in Calibration issues Part 293:

    G29

    that should not be in bed.g

    G30 P12 X0 Y0 H0 Z-99999 S6

    try s8 or s9 and see if that inproves the result.



  • OK, I'll give both a try.

    But where should I put my G29 then? Why is it an issue if I have it in my bed.g?

    Oh, and btw, here are the calibration macros I'm using:

    1_DeltaCalibration:

    M117 "Is the probe connected?"
    G4 P5000
    
    ;Tune probing speed
    ;M558 P5 H0.6 F120 T6000 L1
    G32
    

    2_MeshBed:

    ;G28
    M117 "Is the probe connected?"
    G4 P5000
    
    
    ; Use some very speedy settings with a probe height of only 1mm
    ; F Dive speed in mm/sec default 120
    ; T Probe Speed in mm/sec default 6000
    ; Very slow settings for testing: F=20 T=600
    ; H Dive height default 5
    M558 P5 H0.6 F120 T6000 L1
    
    ; stuff in bed.g is delta calibration, which is different from mesh bed compensation
    ; Probing example, for mesh bed compemsation
    M557 R185 S20 ; probe within a radius of 180mm from the centre with a mesh spacing of 20mm
    
    ; Dann z.B.
    ;  G29 S3 P"filename.csv" ; Probes bed and saves result to filename.csv
    ;  G29 S1 P"filename.csv"; Loads bed probing info
    ; G29 als default mit heightmap.csv
    G29
    ;G29 S3 P"heightmap-mesh.csv"
    
    ; The height map file is normally called /sys/heightmap.csv but you can specify a different filename in G29, M374 and M375 commands. You can view, edit or download it using the System Editor tab in Duet Web Control.
    
    ; Running G32 to auto calibrate a delta printer or to adjust leadscrews to level the bed will clear the local height map info (but not the copy in heightmap.csv). Therefore, if you wish to use both auto calibration/leadscrew bed levelling and mesh bed compensation, you must run G32 before you run G29, not after. You can include a G29 S0 or G29 S1 command at the end of your bed.g file if you wish.
    
    ; Set probe height back
    M558 P5 H2 F120 T6000 L1
    
    

    So far I was only using the first macro. But now that g29 was removed from bed.g, I guess I need to use both macros?



  • create a macro or put in the the start g code



  • This post is deleted!

  • administrators

    @AdrAs said in Calibration issues Part 293:

    I thought that after running a delta calibration, and then running a mesh bed calibration that the firmware can figure out any missalignments and compensate for that.
    But it kinda seems like that all this calibration information is not used at all. As I mentioned, in one area the print head is too high, in another area it's too low, and then in some areas it's just fine.
    What am I doing wrong?

    Are you using a Z probe that is offset from the nozzle?



  • the predator, like the anycubic kossel, has a probe that you mount under the hotend.
    it just has a big z offset, but no x or y



  • Yes, Veti's right, the probe is about 20mm below the nozzle. Besides that the situation seems to be improved, but I've still got an area in front where the nozzle is too low and area opposite to it, where the nozzle is too high.


Log in to reply