Duet2 wifi Wish : Bed heats up, and i can start leveling



  • Dear friends
    Again a small question from me.

    First, my both printers works perfect with Duet2 wifi!
    Great product, nice help from all of you, thank you.

    So my question is, for example, i switch printer on,
    activate bed heating to 80 degress.
    Bed heating starts.
    then i want to move the axis, but this is in this moment not possible.
    At DWC is shown Change tool......
    Can i adjust the config that i can do this when heating is not ready?
    In the moment i can move axis when heating is ready.



  • for the moment, activate the tool/bed and then set the temperature, not the other way around



  • Ok, so i can´t adjust this into the Software?



  • @uneumann36 How are you setting the bed temp?

    If you use M140 to set the bed temp then control should be returned right back to you to do other tasks while it heats up.

    See https://duet3d.dozuki.com/Wiki/Gcode#Section_M140_Set_Bed_Temperature_Fast_or_Configure_Bed_Heater



  • No, i mean, i use every time DWC.

    For example i adjust on DWC switch Bed Heating on, to 80 degrees.
    After i set these, (Because it takes long to rech this)
    I want to change filament in the mean time, so i will bring the axis to me in front.
    But this will not work, answer:
    Change toll......



  • @uneumann36 said in Duet2 wifi Wish : Bed heats up, and i can start leveling:

    No, i mean, i use every time DWC.

    For example i adjust on DWC switch Bed Heating on, to 80 degrees.
    After i set these, (Because it takes long to rech this)
    I want to change filament in the mean time, so i will bring the axis to me in front.
    But this will not work, answer:
    Change toll......

    It's not entirely clear what you are trying to do.

    Starting the bed to heating using the DWC should not prevent you from moving on X,Y or Z.

    Are you executing some gcode that is issuing one of the commands that waits for the bed to reach it's target temperature?

    Frederick



  • So i am not an expert in programming !

    I would be very happy if someone can have a look on my config below.
    Not only for this problem, also for better setting , proposals for better settings are very welcome.

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.2.2 on Mon Feb 01 2021 09:45:52 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G21 ; Units in mm (mm)
    M149 C ; Units in Celsius
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Silent Goliath" ; set printer name
    M575 P1 B57600 S1

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E136,50 ; set steps per mm
    M566 X900.00 Y900.00 Z60.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E2000 ; set maximum speeds (mm/min)
    M201 X2500.00 Y2500.00 Z250.00 E5000.00 ; set accelerations (mm/s^2)
    M906 X1500 Y1500 Z1500 E1200 I50 ; set motor currents (mA) and motor idle factor in per cent
    M84 S200 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X400 Y400 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"exp.heater7" ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X45.1 Y-2.5 Z3.655 ; set Z probe trigger value, offset and trigger height
    M557 X5:205 Y5:165 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5 on the Duex board.
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • Hi,

    I'm not sure why you posted your config.g file.

    It seemed as if you were talking about a problem that occurred while using the DWC?

    Is that correct?

    Frederick



  • Yeah that is right.

    But i thought the Config file is the basic for the printer and belog together ?!
    As i told you, this is not my job with programming.



  • @uneumann36 said in Duet2 wifi Wish : Bed heats up, and i can start leveling:

    Yeah that is right.

    But i thought the Config file is the basic for the printer and belog together ?!
    As i told you, this is not my job with programming.

    I understand that you are not a "programmer".

    But there is nothing in the config file that would cause this problem.

    Using the DWC I can set the bed AND the extruder to start heating AND still move any axis X, Y or Z as needed.

    Do you have any files that begin with TPRE, TPOST or TFREE?

    Have you created any Filament Types using the DWC?

    Frederick



  • Thank you for your reply.
    But i don‘t know what you mean
    Adjustments in DWC ?
    No i have Nottingham safed in DWC


  • Moderator

    Could you perhaps make a video showing what you're talking about?



  • Add a T0 at the end of the config file and restart the printer. See if it causes the issue to go away.

    That way once the printer is running it will already have a tool loaded so it won't change tool (go to busy state) when you change the temperatures.

    Otherwise try this,
    So instead of setting the bed temp with the buttons on dashboard screen.
    Try typing M140 S80 on the console screen and sending it to the printer. It should heat to 80 but still allow you to move the printer around. It should go right back ti idle after you send the command. It should not say busy.

    If that works then create a macro to run the bed heat command.



  • Thank you for your reply.

    So do i understand you right?
    I add in my config.g in the last line only
    T0 ??
    0 = Zero ?


  • Moderator

    yes, T0

    Are you trying to heat the bed or a tool?



  • Hi

    The T0 command don´t help.

    I can report you follwoing:

    I homed all axis.
    Then i play with axis also set Z for example to 50mm.
    The i press all home button, all axis work to go home.
    Of course the z axis take time.
    In the mean time i will switch the nozzle an .
    This will not work till all axis are homed.

    Is this normal ?



  • @uneumann36 said in Duet2 wifi Wish : Bed heats up, and i can start leveling:

    I homed all axis.
    Then i play with axis also set Z for example to 50mm.
    The i press all home button, all axis work to go home.
    Of course the z axis take time.
    In the mean time i will switch the nozzle an .
    This will not work till all axis are homed.

    Is this normal ?

    Any changes you make in the heaters should show on the DWC as soon as the homing is finished.

    What exactly are you trying to do?

    Is this something you do before starting a print?

    Frederick



  • Basicly this is not a problem.
    I am only wondering why i can´t do this together.



  • @uneumann36 said in Duet2 wifi Wish : Bed heats up, and i can start leveling:

    Basicly this is not a problem.
    I am only wondering why i can´t do this together.

    Well you would have to ask the folks that created the firmware about the details but the basic answer is that once you started the homing process the printer was "busy" (as shown on the DWC) and it could not process the heater changes until it was "idle".

    You can do the reverse - you can make changes to the heater settings and while they are changing start the homing process.

    Frederick


  • Moderator

    @fcwilt said in Duet2 wifi Wish : Bed heats up, and i can start leveling:

    you can make changes to the heater settings and while they are changing start the homing process.

    This is the correct answer. If you set the temps first the firmware will do the heating while the motion is happening, but once the homing has started it won't accept any new commands until it's finished what you've asked it to do.



  • Ah ok,
    This is what i need to know.
    If this is normal, all good.
    Thank´s guys.


Log in to reply