SOLVED Duet 2 Wifi not connecting to Apple Router Wifi Network



  • Hello all,

    Banging my head against a wall trying to figure out what I am doing wrong here. Long story short I switched internet providers, I am now using my own router system for the LAN and WLAN (Apple Airport Extreme and Express), yes I know they are horrid and old, but I do not have the money to spend on a new setup at the moment.

    Anyhow I am having a real bear of a time getting my Duet 2 on my Rostock MaxV4 to connect to the network. I got my OctoPi to do so with ease. But I do not understand why the duet will not work.

    I get the message of "invalid ssid" or "MillerWiFi IP=0.0.0.0, ..... " when running the Network Macro and then sends error messages and won't connect. I've tried everything I can think of, but with no success.

    Is there something in my "Network" macro that I can add to query the Apple router for an IP? I have the SSID and password correctly written into the macro but it just will not connect at all.

    Thank you in advance.

    Jordan


  • Moderator

    @Jordan_Miller41 Please post your network macro (obfuscate your password), and response to M122 (for firmware and WiFi firmware versions).

    Have you tried the USB connection setup method from https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7?lang=en#s9 ?
    Usually, I find it more reliable to turn off WiFi with M552 S-1, then turn it on in idle mode with M552 S0 before adding SSID, if there's no existing WiFi connection. Then send M552 S1 to enable WiFi.

    Ian



  • Just tried the guide you sent, you can see the response I get.

    Screen Shot 2021-02-10 at 9.36.13 AM.jpg Screen Shot 2021-02-10 at 9.37.27 AM.jpg

    My SSID is "MillerWiFi" and then the password.

    Here is the Network Macro screenshot.

    Screen Shot 2021-02-10 at 9.43.19 AM.jpg

    SOLVED:

    So in the above picture I have "MillerWifi" which should've been "MillerWiFi", so I ran the macro twice and somehow it connected, although I swear I had it right before.

    Thank you for your help though, I appreciate it 👍🏻.


Log in to reply