PSU not turning on when connected to Duet WiFi



  • Hello everyone!

    I am a mechanical engineering student at the university of Alabama. I work for a department on campus called AIME (Alabama Innovation and Mentoring of Entrepreneurs). We are expanding our prototyping center and have decided to build an FT-5. We have been working on the build throughput the summer and are almost finished with it.

    We decided to go with the Duet WiFi and Panel Due ( 7 inch). All of the wiring is complete and we are in the testing phase. I am currently experiencing an odd issue with my power supply, however. Also, I cannot seem to connect to the Duet through a browser using the IP. A summary of the problems is below. Any help would be greatly appreciated!

    Problem#1

    Duet WiFi : I have been following these instructions (https://duet3d.com/wiki/Getting_connected_to_the_Duet_WiFi).

    I can get the board to communicate with Pronterface and broadcast a WiFi signal. I can connect to the signal via WiFi (laptop and desktop), but when I try to connect to the IP address via chrome, I get a blank screen. I have tried connecting to the IP through a browser on my laptop (windows) and a Mac desktop with no success.

    All of the correct drivers are up to date (https://github.com/dc42/RepRapFirmware/tree/dev/Driver).

    I have the correct firmware (1.15c) for the Panel Due (https://github.com/dc42/PanelDueFirmware/blob/master/Release/Stable/PanelDue-7.0-1.16.bin).
    I believe that I have the correct firmware installed on for Duet (https://github.com/dc42/RepRapFirmware/blob/dev/Release/Duet-WiFi/Stable/DuetWiFiFirmware-1.18.1.bin).
    Any ideas what could be going on here??

    Problem #2

    We decided to go with a 24v power supply. Same style as the 12v model that comes with the FT-5 kit (24v/360w).

    When we wire the PSU up to the Duet, it will not power on. You can hear it make a noise with a slight buzz sound and a brief flash of the green power LED. We tested the PSU at the terminals and it registers 24v on our meter.

    When we disconnected the PSU from the Duet, and powered it on, it comes on with no issue. We wired two 24v fans to it and it still came on with no issue. I have no idea what is going on here. Any suggestions??


  • administrators

    Regarding #2, it sounds as though the short circuit protection of the PSU is tripping. Are you sure that you have the + and - wires from the PSU connected to the Duet VIN terminal block the right way round?

    Regarding #1, we will very soon release firmware 1.19 which uses a completely different connection procedure. I suggest you try the 1.19RC5 version. See https://duet3d.com/wiki/DuetWiFiFirmware_1.19beta.



  • Thank you for the suggestions.

    That diagram is exactly the one I used when wiring everything. I still have not solved my first issue, but I believe we figured out what is going to with the power supply.

    The diagram says "GND" on the connection opposite of the VIN power in. We had this connected to the ground terminal on the PSU, but also had a ground on our switch side. We wired the power switch according to the wiring diagram which comes with the FT-5 kit. We removed the ground from the switch to the PSU and made it a chassis ground. We took the "GND" wire from the VIN and connected it to a negative terminal on the PSU and everything powered on!

    Seems the problem has been solved. Forgive me if my terminology is off or vague. Electrical is an area that I am still learning about.



  • Thank you, that is pretty much what we ended up doing.

    Any suggestions on flashing the firmware to the SD? I cannot seem to figure out how to get the firmware loaded to the SD card properly, so the board will communicate with Pronterface.



  • Check the baud settings. Been a while since I had mine hooked up that way, but I think that was the issue I was having. You can always take the SD card out and put that into your computer.



  • I am following the directions here

    https://docs.google.com/document/u/1/d/1whV779t_660hpgTxYxFomgqrOk1CpEQi-8QttTHaI-Q/pub

    but I keep getting an error message that says "try specifying serial port with the '-p' option". I tried the –p=COM7 and it says there is no connection. Although in device manager, it says they the device is connected. It is labeled Bossa Program Port (COM7), indicating that there is no firmware uploaded.



  • I have also changed the port settings to make sure the baudrate matches 115200, as mentioned here

    https://reprappro.com/documentation/troubleshooting-introduction/electronics-problems/#Duet_software_connection_problems


  • administrators

    You are looking at old documentation that pre-dates the Duet WiFi. See https://duet3d.com/wiki/Duet_Wiki for the current documentation. As you have already pressed the Erase button, you will need to use either SAM-BA 1.16 or bossac 1.18 to upload the firmware. You were probably using an o!d version of bossac.

    The baud rate setting doesn't matter.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.