Printer wont print even after a new config file



  • So I'm in the process of fine tuning my Prints and I have started making some parts for my car.
    Finally get a good model happening and when I Hit the button to Upload and print. It up loads the Gcode file and then turns the hotend and bed off and tells me the print has completed.

    The printer doesnt even home or try to do a preprint calibration.

    I was printing 2 days ago turned it off and then came to print today and got given this.

    Any ideas?

    Heres my config file:

    [[language]]
    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Aug 09 2017 11:08:15 GMT+0800 (W. Australia Standard Time)
    
    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    
    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R150 L310 B130 H320 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them
    M208 Z-5 S1 ; Set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z0 H5 F200 T2400 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X0 Y0 Z0.367 ; Set Z probe trigger value, offset and trigger height
    M557 R80 S10 ; Define mesh grid
    
    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100 Z100 E420 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E1200 I60 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    
    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H0:1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H0:1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Custom settings are not configured
    
    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    
    


  • The usual cause for this is that the print tried to start with no tool selected. Try putting T0 (or whatever tool you want to use) in the start gcode of the file you want to print. You don't have to re-slice the model. Just use a text editor like notepad++ and put T0 somewhere before the first G1 command. If it works, add that to your slicer start gcode so that you don't have to do it every time.



  • I'll give it a try tomorrow but I don't understand why it is doing it all of a sudden, but I will see maybe I'll just but it in the start file from the beginning, And see if it works thanks deckingman



  • Ok so I tried it and placed T0 in the start up section on two gcode files that i have printed before and still didn't do anything stated it uploaded 100% printer doesn't re-home and start calibration and both the bed and hot end switch off and start to cool down.



  • Check the contents of the file you are trying to print.

    I tried to print a calibration file from thingiverse - nogo - the model was invalid - nothing to print.

    Frederick



  • What happens if you don't turn on the bed and hot end before trying to print?



  • I checked the content and it's there and I have tried not turning on the hot bed and hotend. Funny thing is it prints when I teither it by usb and use simplify3d. But the calibration doesn't actually do anything and results in a very high nozzle. I just find it weird that it was working perfectly fine before and i was printjng everything then all of a sudden this happens


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.