Updated firmware - no connection - no port



  • Hi,
    Last night I updated to 19.rev5. The update failed, and I lost connection to my duet-wifi. I went through all the troubleshooting steps - nothing.

    I pressed the erase button, it flashed dark and then the lights came back (see below), and held for a slow count of 5, then pressed the reset button, nothing seemed to happen, so I unplugged and replugged back into my laptop. This is all done with mains power off and only a USB connection to a computer. From this point on,

    I have no port, no device at all. I've tried 2 USB cables, different USB ports, nothing. I tried 3 different operating systems on two different laptops (one is dualboot), even installing the new device drivers (.inf) files in Windows10. Not one can see any device - no com port, no USB-serial on mac, no Duet-device on windows, no USB from dmesg in linux.

    On my duet-wifi, when plugged into a USB port on any computer, the lights above and below the usb connector are solid red, there is a solid green light and below that another solid red light.

    When I press the reset button, nothing happens (no momentary blink or lights flash).
    and now if I try the erase button, nothing happens.

    I was hoping to use the bossac option to reinstall the firmware, but neither bossac, arduino and the sam-ba can see the device.
    Any ideas what happened, and how to fix?


  • administrators

    I'm puzzled by the "it flashed dark" bit. If either VIN power (with the internal 5V regulator enabled) or USB power is applied, at least the green 3.3V led and the red 5V LED next to it should be illuminated.

    If you have a Panel Due attached, disconnect it. Many USB ports can't supply enough power for both the Duet and the screen.

    Open Device Manager in Windows, then connect the Duet via USB. Does Windows refresh the device listing? If so, that is a sign that it has detected a new USB device. Look for changes to the COM port list, the USB device list, and for any Unknown Device.

    If Device Manager doesn't refresh, press Erase for about a second, then Reset and see whether it refreshes then.



  • what i meant was that there was a response when I pressed the erase button. There wasn't one when I pressed the reset button.

    I had already looked in the device manager for any USB device and for any addition to the COM port list. Nothing. I also plugged it into a linux box, dmesg didn't show a new USB connection, and there was no addition to /dev/tty - Same on OS X - no /dev/cu* and no new /dev/tty* -
    that's what I meant when it couldn't see any com port. The device isn't recognized by any OS, yet it is receiving power. I even moved the cable to different USB ports.

    I'll try erase and reset again, as well as trying a newer cable.


  • administrators

    How old is your Duet, and which country are you in?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.