M997 acting weird. Can't install firmware. Want to reconfigure wifi.



  • Can't wait to get started with my duetwifi.

    With only USB connected (no Vin), I went ahead and set up Wifi using the step by step guide. I encountered two problems:

    Problem 1: On step 9, I was supposed to choose my wifi network. I am on a Guest (WifiName-Guest) network at my apartment. I saw the name of the guest network, but it was in the list twice! Perhaps one was 2.4GHz and the other was 5GHz, but the names in the list were identical. I saw the non-guest version listed twice as well. Neither show up twice when looking for wifi networks on my Mac. I chose the first guest network. Should it matter which one?

    Problem 2: I was able to proceed up to (but not including) step 12 with no problems. When I entered the IP address that Pronterface showed when connected, the browser would not connect. I tried in Chrome, Firefox, and Safari (on Mac).

    So I thought maybe I would try to upload new firmware. I tried using USB (no Vin power), and also with Vin power. But the same thing always would happen - DuetWiFiFirmware.bin would somehow become deleted from the sys folder! The M997 messages are displayed below:

    SENDING:M997 S0
    Error: Firmware binary "DuetWiFiFirmware.bin" not found
    [ERROR] Error: Firmware binary "DuetWiFiFirmware.bin" not found

    I tried many times.

    Then I followed fallback procedure #3. After struggling with Atmel to download SAM-BA, I was able to upload the DuetWiFiFirmware.bin file no problem. Then I decided to try M997 S0 again. I got this error:

    [ERROR] Can't read from printer (disconnected?) (OS Error 6): Device not configured

    I tried M997 S0 an additional 3 times, and got this message:
    [ERROR] Disconnecting after 4 failed writes.

    I disconnected and power cycled the board, then connected via pronterface and tried M997 S0 again and got:

    [ERROR] Error: Firmware binary "DuetWiFiFirmware.bin" not found

    And I checked the SD card and that file was gone.

    I tried Fallback Procedure #3 a second time. I got this error after M997 S0:

    Connecting…
    Printer is now online.
    Using tool 0.

    M997 S0
    SENDING:M997 S0
    [ERROR] Can't write to printer (disconnected?) (SerialException): Write timeout
    [ERROR] Can't read from printer (disconnected?) (SerialException): call to ClearCommError failed

    I disconnected then connected via the pronterface button. This time I saw this message:

    Error: Temperature reading fault on heater 2: sensor open circuit
    [ERROR] Error: Temperature reading fault on heater 2: sensor open circuit

    And tried M997 S0, and got:
    Error: Firmware binary "DuetWiFiFirmware.bin" not found
    [ERROR] Error: Firmware binary "DuetWiFiFirmware.bin" not found

    Sure enough, I put the SD card in my computer and that file had disappeared from the sys folder.

    Question: there is a folder on the SD card called DuetWifiFirmware-1.18.1stable. I have put the most recent stable DWC, Firmware, and Server .bin files in there (and renamed them to not have the -#### suffix… is that ok?)

    What is going on? What should I try next?



  • I am going to try fallback#3, then not try M997 S0 (because fallback#3 takes care of the DuetWiFiFirmware installation… I think). Then I'll try M997 S1, then M997 S2. Then I'll try to set up wifi, but I'll select the 2nd guest network and see if it works.



  • I should also note that fallback procedure #1 is something I've tried many times which also did not work.


  • administrators

    After flashing the new firmware successfully using M997, the firmware file is deleted from the SD card. That will be why it disappears. You can check which version is running by sending M115.



  • Thank you dc42. Can you help with the next part below?

    Ok after doing what I proposed two comments ago (which was to do fallback#3, then M997 S1, M997 S2, Pronterface shows that "WiFi server connected to access point WifiName-Guest…."

    But I want to create a new access point. How do I do that?



  • Based on another post, I should do one of three things.

    First is to turn off the router, turn on the board, do M552 S1, then it'll go into AP mode. I don't have access to the router.

    Second is to carefully wrap aluminum foil around the antenna so it won't be able to find the network, and it will go into the access point mode. I tried it, but the wifi is too good here.

    Third is to pick it up and walk away out of range of the wifi signal. I can do this because its just the PCB board and the computer. But if I ever have this problem again in the future, I don't want to have to transport the entire printer!



  • If anyone knows of any other method to enter the AP mode, please let me know.



  • have a GOOD read of the following https://duet3d.com/wiki/DuetWiFiFirmware_1.19beta

    Particularly the section re doing the upgrade the last couple of lines should be what you are looking for the M587 and M588 Commands.

    The process changed at FW 1.19



  • If anyone knows of any other method to enter the AP mode, please let me know.

    Not tested but should work - create an access point on your mobile phone or laptop, connect printer to that, shut it down, restart the printer (it is unable to find that network -> enters AP mode)



  • Thanks everybody! I'm going to carefully read the link Dougal sent, and get that working.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.