SOLVED BLTouch Not Responding



  • Hello, I recently installed a BLTouch 3.1 on my CR 10 controlled with a Duet 3 6HC. I have double checked the wiring harness, and 5 volts is being pushed all the way to the end, right where the BLTouch connects. I have tried configurations for IO Pin 7, and IO Pin 5, but to no avail. Because this is a first install, I do not have any previous data of the sensor working, or not.

    When the probe is unplugged from the wire, the z-probe out on the dashboard for DWC indicates 1000. When it is plugged in, the reading is 0.

    I have tried manual "M280 P0 S10" and "M280 P0 S90" commands, but there was no change. I think I am missing something.

    Here is a copy of my config.g:

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.2.3 on Wed Feb 17 2021 16:50:37 GMT-0700 (Mountain Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"CR 10" ; set printer name

    ; Network
    M552 P192.168.0.99 S1 ; enable network and set IP address
    M553 P255.255.255.0 ; set netmask
    M554 P192.168.0.1 ; set gateway
    M586 P0 S1 ; enable HTTP
    M586 P1 S1 ; enable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0.0 S0 ; physical drive 0.0 goes backwards
    M569 P0.1 S0 ; physical drive 0.1 goes backwards
    M569 P0.2 S0 ; physical drive 0.2 goes backwards
    M569 P0.3 S1 ; physical drive 0.3 goes forwards
    M584 X0.0 Y0.1 Z0.2 E0.3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E398.00 ; set steps per mm
    M566 X900.00 Y900.00 Z60.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E1300 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y-18 Z-7.70 S1 ; set axis minima
    M208 X285 Y292 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"io0.in" ; configure active-high endstop for low end on X via pin io0.in
    M574 Y1 S1 P"io1.in" ; configure active-high endstop for low end on Y via pin io1.in
    M574 Z1 S1 P"io2.in" ; configure active-high endstop for low end on Z via pin io2.in

    ; Z-Probe
    M950 S0 C"io5.out" ; create servo pin 0 for BLTouch
    M558 P9 C"^io5.in" H5 F100 T2000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X0:280 Y5:285 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 B3950 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out1" T0 ; create bed heater output on out1 and map it to sensor 0
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S150 ; set temperature limit for heater 0 to 150C
    M308 S1 P"temp1" Y"thermistor" T100000 B4267 ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out2" T1 ; create nozzle heater output on out2 and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M143 H1 S305 ; set temperature limit for heater 1 to 305C

    ; Fans
    M950 F0 C"out6" Q500 ; create fan 0 on pin out6 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"out7" Q20 ; create fan 1 on pin out7 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    Thank you in advance for all of your help.



  • Hi,

    The two wire connection (black and white) is the signal from the probe to the board.

    The three wire connection (brown/blue, red and orange/yellow) carries power to the probe and the control signal.

    If the probe does a self-test on power up then the power (red) and ground (brown/blue) connections on the three wire connector are good.

    If the probe does not deploy something is wrong with the control signal connection (orange/yellow) or the output feeding the probe is configured wrong.

    So for starters do this from the DWC console:

    M98 P"config.g"

    If there is something wrong in the config.g file you should see something on the console mentioning the problem.

    Let us know.

    Frederick



  • Hey Frederick,

    Thanks for your reply!

    Running the M98 P"config.g" returns no errors.

    Thank you for the explanation on what the wires do, I actually had no idea as far as their functions. I wired it according to the guide here: Duet 3 BLTouch Guide

    Here is a link to the picture of my wiring.

    I tied the blue and black wires together on the same pin because the table defines them both as ground. Is this table potentially out of spec?



  • check the extension cable. bad connection there is often the cause for the problems



  • @Veti I have just continuity tested all 5 wires and confirmed their connections.



  • As an update, I have ordered a second BLTouch to make sure it's not just a dead-on-arrival issue. I will keep posted. Thank you again to all who have posted suggestions. I really appreciate your additional eyes.



  • Hi,

    It's a little hard to tell but the crimps don't look as good as they could be.

    You may want to invest in a IWISS SN-28B Crimping Tool for AWG28-18 Dupont Pins - you can get one from Amazon for $23 or so.

    Assuming they are good the connections appear to be in the correct places.

    Have you read up on how to use the BLTouch adjustment screw?

    Have you tried a different connector - with the appropriate config changes?

    Frederick



  • @fcwilt Thank you for the suggestion on the crimper! Yes, I actually have a IWISS crimper for the Molex KK type crimps (the kind used for the IO pins on this duet board), and used it for this cable. I could definitely go back and retry it, but I am not sure if much will change since I was able to verify proper continuity on all pins from a variety of cable positions... If all else fails, it won't hurt 🙂 I really appreciate you verifying that my wires were in the correct spot. Extra eyes are always a good thing.

    I have not read about the adjustment screw and will look into that shortly.

    Yes, I have tried with IO pin 5 and 7, changing the configs appropriately to no avail sadly.

    Warmly,
    Eric



  • @linuxinstalled said in BLTouch Not Responding:

    Yes, I actually have a IWISS crimper for the Molex KK type crimps (the kind used for the IO pins on this duet board), and used it for this cable.

    You have of course noticed that the crimper has a section for crimping the bare wire and a section for crimping the insulation.

    Sometimes the wire and insulation sizes don't perfectly match the tool.

    I often will re-crimp the insulation using the section for the wire being careful to not over crimp - you can always force the tool to release using the ratchet.

    You always want to get a good crimp on the wire AND the insulation. You only need 2-3 mm of bare wire - it's easy to strip too much.

    Frederick



  • @fcwilt I came looking for advice on a BLTouch and have left with some more knowledge on how to use my crimpers haha. Thank you very much for your description of the re-crimping on the insulation. This will be a tool in my mental tool box 🙂



  • TLDR: there was a problem between the probe side connector of the cable and the actual electrical connections to the probe where the connector is received

    The second probe arrived today and I used its cable to if the new probe would function. After plugging it in, the probe started up and ran its self test. I had not seen this behavior with the prior cable.

    Attaching the prior cable again, I connected its end to the new probe, with no response whatsoever.

    The reason I am inclined to believe it was on the connector that attached to the probe itself was that I was able to continuity test each wire individually, each coming back with a positive connection. What I didn't test was physically stabbing a wire into the front of the connector to see if the connection there was working.

    Instead, my continuity testing was done on the exposed metal parts of the pins just on the back of the connector.

    After testing, I now have 2 fully working BL Touch modules, and 1 good cable haha.

    Thank you again to all of you for your suggestions and help. Because of you, I was literally able to just wire the new probe up and instantly have it working when it arrived. I also greatly appreciate the crimping tips, which I used this time around on the new cable.



  • @linuxinstalled said in BLTouch Not Responding:

    Instead, my continuity testing was done on the exposed metal parts of the pins just on the back of the connector.

    You've learned a valuable less about crimps and how they can malfunction.

    If you can add to your collection of tools PC board mating connectors for the connectors that you crimp then it is easier to test the cable "end to end".

    Glad to hear you got it sorted.

    Frederick


Log in to reply