Creality CR-10 upgrade



  • @Agniusm:

    I think you will need to rewire. I swapped my cables and built them from scratch so i don't really know.

    Not wat I was hoping for, but thanks for letting me know..
    I'll go and hunt down the wiring of the cr-10 connectors.


  • administrators

    You can test whether the connectors need to be rewired in either of two ways:

    1. Use a multimeter to measure the resistance between pins. If the wiring is correct for the Duet, you should get a few ohms resistance between pins 1 and 2, and a few ohms between pins 3 and 4. There should be no continuity between 1 or 2 and 3 or 4.

    2. If you don't have a multimeter, then you can try shorting pins together to see if it makes the motor harder to turn. If it is wired correctly, then if you short pins 1 and 2 together, or pins 3 and 4 together, it will be harder to spin the spindle with your fingers.



  • @tychop:

    @Agniusm:

    I think you will need to rewire. I swapped my cables and built them from scratch so i don't really know.

    Not wat I was hoping for, but thanks for letting me know..
    I'll go and hunt down the wiring of the cr-10 connectors.

    Rewiring is basically swapping pins. There is not much to it. Like DC42 said or you can simply plug generic LED and spin the motor by hand. If it lights up, you got a pair.
    On cr10 i think pairs are layed out as follows on motor connector: 1 and 4 one pair, 3 and 6 the other one. On duet you have 1b1a and 2a2b.
    Now just connect you wires so 1 goes to 1a 4 to 1b 3 to 2a 6 to 2b and if its reversed, reverse it back in firmware. It is different for y axis only.



  • The AJAX error still does my head in. I pulled out old router to test, where all AP's are stored so i could edit the list? I have ordered new AP so i can dedicate it to the printer


  • administrators

    The latest (1.20) version of DWC gives a more precise error message instead of "AJAX error".



  • Is there a way to set baby stepping on LCD to be something else than 0.05 or is it precompiled in LCD firmware?



  • I do not think that these AJAX errors are caused by your wifi connection but by the firmware (Firmware 1.9 and up)
    I had them all the time after upgrading, im back to the old firmware and dont have them anymore
    see also my tread :
    https://www.duet3d.com/forum/thread.php?id=3831

    i hope this will be fixed



  • Is there somewhere i could find how long last print took?


  • administrators

    Different users find different firmware versions work best for them, so I caution against generalising. The main changes to DuetWiFiServer.bin were:

    • Firmware 1.19 moved the web server form the WiFi module to the main processor
    • Firmware 1.19.1 tries harder to restore the wifi connection if it is lost than all earlier versions did
    • Firmware 1.20 uses the latest SDK from Expressiv to fix the KRACK vulnerability that is present in all earlier versions
    • Firmware 1.20+1 uses version 2 of the LWIP TCP/IP stack instead of version 1, and a still-later SDK version


  • Dc42 what do you mean worked best for them? I liked the new version, i hope my problem wil be fixed.



  • I'll get new AP, place it in the same room and then we will see. I have IP wifi camera further away and it works fine. I don't know why this is problematic. Is it poor hardware (wifi module) or something else causing so many people problems?


  • administrators

    I mean that some users found DWS 1.03 and earlier gave unreliable connections, and the more recent versions more reliable; and a few users such as yourself have the opposite experience.



  • but DC42 to whole point of having the duet wifi for me is that i can control it from a distance and the active development of the firmware to get even better printing results.

    i would like to have some help to get things going again with the new firmware.


  • administrators

    Unfortunately we are dependent on the Expressiv SDK for management of the WiFi connection. It's closed source, and FCC rules prohibit Expressiv from open-sourcing it even if they wanted to. There was some indication on the Arduino github pages that the new SDK version that fixes the KRACK vulnerability doesn't play nice with some brands of WiFi router.

    There remains the possibility that some of the connection issues are due to our own firmware. To help identify whether this is the case, recent versions of RRF and DWS have a debug facility whereby any debug messages coming from the wifi module will be echoed to USB if you send M111 S1 P14 first. You must have a USB connection active to use this facility.

    There is a 1.21RC1 version of DuetWiFiServer almost ready for release. It fixes a known issue with repeated use of FTP. I suggest you try that along with DuetWiFiFirmware 1.21RC1 when it is released (I hope tomorrow), and enable the debug facility if the disconnections persist.



  • ik wil try the 1.21RC1 firware when its ready,
    but i dont think i have a problem with the wifi connection , i tryed the M111 command but it didnt show any problems with the wifi connection , my duet shows up connected on my router and i can also ping it. it looks like the http server is closing the connection..



  • So i have fitted new AP and its a lot better. I mean a lot.
    David, i have this thing i cant sort out. I print PLA and PETG but it needs different z offset. I want to be able to add that offset to start gcode in slicer. i read the solution you provided with G91 but i would like to have it set no matter layer hight. I tried adding G31 P500 ZXX.X but it did not work. I have created macro with this and then was calling macro file with G98 to no success. Perhaps i am doing something wrong here.


  • administrators

    Probably the easiest way is to use the new absolute babystepping command in firmware 1.21. I expect to release RC1 later this afternoon.



  • How would one set up safety for Z axis so it would back off if the nozzle hits build plate? I had it happen for no reason twice now so i thought it might be good to do before i change to PEI. Thanks



  • Have another request. My bed. Has 1kw heater and i use ups for power outages. Is there a way to initiate power failure mode by a switch or 5v? I found 5V out when on battery power so i could connect relay. But how to set it up using an endstop or something else?
    Thanks


  • administrators

    You can initiate a pause using an endstop input a a trigger. See the M580 command in the GCode wiki.



  • The M580 is something "select Roland". I don't even know what that is. Was it a typo and should i just look up pause M25 (M24 to resume) in combination with M581 for external trigger?


  • administrators

    I am sorry, I misremembered - I meant M581. You can use the T1 trigger number to make the printer pause, without having to set up a trigger macro.



  • So if i put: M581 E1 T1 S1 C1 in config.g, it should suffice to execute <pause>and when power is restored, i would execute <resume>macro or it should still be available on print menu on LCD?
    Probably i would want to have T2 to execute macro file as i will need to shutdown all the heaters to prevent UPS drain</resume></pause>


  • administrators

    That all sounds good to me, except that you will also need to restore the heater temperatures in your resume macro.



  • Regarding build plate. I cant seem to find the difference between Mesh grid compensation (G29) and Auto bed compensation (G32)
    When i run G29 and add G29 S1 to my starting gcode, nothing happens but when i run G32 just before a print, i can see Z lead screws move tiny bit when printing a model.
    On the wiki it says G32 is obsolete, and better to use G29. But what i am missing here. My bed is quiet level at about ~0.09mm (on G32, probing 5 points).

    EDIT. probably it does the job. Since G29 grid is multiple points adjustments are not that noticeable.


Log in to reply