Issues getting E0 to register as active low



  • Hello,

    I have a Duet Wifi running 1.18.2 my setup is a core xy printer. I have low end stops for X and Y and am trying to use a NO NPN inductive sensor with a voltage divider circuit to get ~3.2 Volts to the inputs on the Duet. I was able to get homing to work when the Sensor was connected to the Z-axis endstop but when ever i tried to do a mesh leveling my bed would crash into the nozzle. I've sense tried to hook the sensor up to the E0 input but i can't get it's status to switch to active low. When i run M558 P4 X0 Y0 Z1 H5 F120 T6000 i successfully get the zprobe to register my sensor on E0 however when i run the M574 E0 S0 command it wont switch from active High to Active Low. I have tried a number of varaitions on the M574 command but no matter what i do the E0 port never registers a Active Low single properly. What is the right command to get E0 to run active low



  • Whelp I figured it out I missed the part where the M588 command added the "I" capability. By adding I1 the board inversed the sensing and triggered properly even though M119 and the duet board still acted like it was a NC device. seems odd but it's work..just need to get mesh leveling working now!!!!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.