Reinstalled for calibration and now the hotend won't heat



  • After the previous thread where almost everything was running perfectly, I redid the RFF Configuration tool to calibrate the movement for My CoreXY… Now the movement are well mesured.

    I believe that I have done everything as I did previously, the sensor works, no error, BUT it doesn't heat up anymore...

    I am starting to do backup of my sys folder...

    I am using a 24V E3D V6 Direct Hotend.

    Thanks you


  • administrators

    Perhaps you had a T0 command at the end of config.g before and you don't any more?



  • @dc42:

    Perhaps you had a T0 command at the end of config.g before and you don't any more?

    I looked, but I couldn't find it…

    Here is my Config.g

    ; Configuration file for Duet 0.8.5 (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Aug 13 2017 20:14:19 GMT-0400 (Eastern Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    M667 S1 ; Select CoreXY mode
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X350 Y350 Z350 S0 ; Set axis maxima

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z1 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:335 Y15:335 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M92 X160 Y160 Z800 E420 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2

    ; Tools
    M563 P0 D H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D0 H ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Network
    M550 PMy printer ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P192.168.2.50 S1 ; Enable network and set IP address
    M553 P255.255.255.0 ; Set netmask
    M554 P192.168.2.254 ; Set gateway
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    If you see anything that cause my issue, thanks you for letting me know.



  • He is saying you need to put T0 at the end of your config.g.



  • I apologize, I have misread.
    I just added T0 on the last line and it didn't work.

    I also noticed that in the document, it says that we should use Reprap software, but by default in the configuration tool says Marlin…

    Also, noticed that both heater (bed and hotbed) display temp but don't heat up.

    Thanks for your help.


  • administrators

    Do you have 12V or 24V power applied to the Duet? Are the VIN terminal block screws still tight? Did you run heater tuning after changing the config.g file?



  • I have a 24V power supply.
    I was able to run:

    M307 H1
    Heater 1 model: gain 506.7, time constant 200.3, dead time 6.0, max PWM 1.00, mode: PID
    Computed PID parameters for setpoint change: P11.8, I0.059, D49.4
    Computed PID parameters for load change: P11.8, I0.715, D49.4

    But I can't do it for the bed (with H0):

    M303 H0 S120 ; AUTO TUNE HEATER 0, DEFAULT PWM, 140C TARGET OR MAXIMUM TEMPERATURE M303 ; REPORT THE AUTO-TUNE STATUS OR LAST RESULT
    Auto tuning heater 0 using target temperature 120.0C and PWM 1.00 - do not leave printer unattended
    Auto tune phase 1, heater on
    Auto tune cancelled because temperature is not increasing

    added the Code
    M307 H1 A506.7 C200.3 D6.0 B0 ; Save hotend PID

    I also made sure that the T0 was after.

    in Web Control, I can heat up the Hotend but not the hotbed…


  • administrators

    Is your bed heater particularly slow to heat? If so, send M307 P0 D60 before you run the M303 command. That will allow it additional time to wait for the temperature to increase.

    OTOH if the temperature really doesn't increase after a minute, then you have a fault somewhere. If the bed heater is showing Fault status in DWC, clear it using M562 P0. Then check that the bed heater LED on the Duet lights up when you command the bed heater on. If so then the fault lies in the cable or in the bed heater itself.



  • found the issue on the hot bed…
    I am using a Mosfet and the wire that was to do the contact went in and around...
    I have no clue how this happened, but there was no contact... found out when I tried to measure the resistance of that wire and never found anything, while I was pulling it out it was stuck, after the resistance was standard and the hotbed is now getting the PID

    Thanks for your help


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.