Heater Confusion in 1.19



  • I've upgraded my DuetWifi with 1.19 (running before on 1.19RC's).

    Using E3D-Chimera DualNozzle with 2 24v HeaterCartridges and Semitec-Thermistor.

    If i try to heat up either Tool 0 (Heater 1) or Tool 1 (Heater 2) it will always shows up the same temperature-Raise on both Tools.

    I've also checked that X-Parameter according to the Changes for the heaters were setup'd correctly:

    [[language]]
    ; Heaters
    M143 S300
    M305 P0 T100000 B3950 R4700 X0
    M305 P1 T100000 B4267.0 R4700 X1
    M305 P2 T100000 B4267.0 R4700 X2
    
    

    What can be wrong?

    Tool-Configuration was also correct:

    [[language]]
    ; Tools
    M563 P0 D0 H1         ; tool 0 uses extruder drive 0 and heater 1
    G10 P0 S0 R0 X0 Y0  ; set tool 0 temperatures and offsets
    M563 P1 D1 H2         ; tool 1 uses extruder drive 1 and heater 2
    G10 P1 S0 R0 X18 Y0   ; set tool 1 temperatures and offsets
    
    

    Can someone can drop me an hint where to look at?

    Have also tried to reset the DuetWifi, flashed Firmware again and also created new configuration from scratch. Issue still persists.

    Cheers
    MoS-tekknix



  • Have also tried to switch X1 to X6 and X2 to X6 to eleminate Issues with the E0 and E1 - Default-Sockets for the Thermistors and VSSA-Fuses.

    Anyhow, the reading is correct but always very very close ot each other. External Temperature-Reading with my Fluke-DMM shows up that the Heating is always correct and DuetWifi is showing the correct LED on the Board for the selected heater.

    I'm running out of ideas and think myself if i should downgrade to 1.18


  • administrators

    So to confirm both heaters are heating with either tool?

    What do you have the active and standby temperatures set to when heating?



  • No the heaters are not heating both only the Temperature shows as raising in the same level.

    Standby and Active-Temp are set both to 0 in config.g and if i'll set it i.e. to 180°C active for Heater 1 (Tool 0) the Temp for Heater 2 (not the real Temp) (Tool1) raises too.


  • administrators

    I just tested it on my dual nozzle printer, and it's working correctly for me. Please run this command:

    M408 S0

    and in the response, look at the values in the array that is prefixed by "heaters". Do those values look correct? Is DWC displaying values that are different from those?

    DWC 1.19 gives you a choice of views: Tools and Heaters. Do both of them display the wrong temperature?



  • Mhh, no. The Values are the same as in the WebIf, even in the Tab Heaters or in Tools

    11:27:34M408 S0
    {"status":"I","heaters":[25.3,50.1,50.0],"active":[0.0,50.0,0.0],"standby":[0.0,0.0,0.0],"hstat":[0,2,0],"pos":[0.000,0.000,0.000],"sfactor":100.00,"efactor":[100.00,100.00],"babystep":0.000,"tool":0,"probe":"0","fanPercent":[0.00,0.00,0.00,0.00,0.00,0.00,0.00,0.00,0.00],"fanRPM":0,"homed":[0,0,0],"msgBox.mode":-1}
    
    

    My Fluke says (tested with a PTC on my DMM and putted a few seconds to the Heaterblock):

    Heater 1 (Tool 0) : 45.9°C
    Heater 2 (Tool 1) : 23.6°C

    That values seems to fit after touching the blocks with my fingers.

    That is driving me nuts.

    Any other idea?

    Regards
    MoS-tekknix



  • Additional note:

    Have reflashed with SAM-BA the FW 1.19 but nothing changed.


  • administrators

    There is one other report of something similar, so I suspect a firmware bug. The temperature monitoring code was refactored extensively in 1.19 so it's by no means impossible.

    If you run M305 P1 and then M305 P2 with no other parameters, does it print the correct temperature sensing channels?



  • Hi dc42,

    yep. The Channels are correct in these Outputs:

    [[language]]
    12:37:41M305 P2
    Heater 2 uses Thermistor sensor channel 2, T:100000.0 B:4267.0 C:0.00e+00 R:4700.0 L:0 H:0
    12:37:19M305 P1
    Heater 1 uses Thermistor sensor channel 1, T:100000.0 B:4267.0 C:0.00e+00 R:4700.0 L:0 H:0
    
    

    But i cannot understand why it is working in your Setup (and i assume at other Printers too) and not in mine?


  • administrators

    Firmware bugs can be like that, changes in the config.g file cause the memory layout to change, which causes the bug to appear or disappear or its effects to change.

    Please try auto tuning heater 2 e.g. M303 H2 S200 and let me know which heater number it says it is auto tuning.



  • Hi,

    i know 😉 have dealed a long time with Bugs in Marlin …

    12:54:14M303 H2 P0.8 S240
    Auto tuning heater 2 using target temperature 240.0C and PWM 0.80 - do not leave printer unattended
    12:54:20Auto tune phase 1, heater on
    12:56:34Auto tune phase 2, heater off
    12:56:41Auto tune phase 3, peak temperature was 243.5
    Heater 2 switched off
    12:59:35Auto tune heater 2 completed in 320 sec
    Use M307 H2 to see the result, or M500 to save the result in config-override.g
    
    13:10:27M307 H2
    Heater 2 model: gain 433.2, time constant 189.9, dead time 3.4, max PWM 0.80, mode: PID
    Computed PID parameters for setpoint change: P23.3, I0.123, D54.8
    Computed PID parameters for load change: P23.3, I2.216, D54.8
    
    

    Can you do me a favoour and drop me your Dual-Setup' config.g File so that i can try to compare where maybe differences are.

    Thanks so far
    MoS-tekknix


  • administrators

    Sure, it's at https://www.dropbox.com/s/uak4t4iqdxc4bnv/config.g?dl=0. Please share your config.g file too and I'll see if I can reproduce the problem.




  • administrators

    I've just tried your config.g on a Duet WiFi and the temperature readings on H1 and H2 are different for me. I had to disable debugging because you had it enabled (M111 S1 in config.g).

    Is there any chance that your E0 and E1 thermistor inputs are shorted together? You could check with a multimeter.

    PS - if you are using a common ground wire for the 2 thermistors to save on wiring, perhaps you have commoned the 'live' side of the thermistors instead of the VSSA side.



  • Hi,

    Fault located. One of the Thermistor-Wires touch the Heater-Block and make perfectly grounding everything!

    Seems to be a Layer8-Error after sleeving the cables after successfull dry-run.

    Will solder some new wires and test if afterwards. But i'm pretty sure that this was the issue and therefore you are'nt able to reproduce it in a working environment.

    Sorry for that Dumb Question.

    Cheers
    MoS-tekknix


  • administrators

    One thermistor wire touching the heater block wouldn't cause that problem, but one wire from each thermistor touching the heater block could. So check the other thermistor too.

    Doesn't E3D supply cartridge heaters with the Chimera yet?



  • Only to clarify things.

    Indeed there where one wire of each thermistor touching the respective blocks. That causes the Problem.

    After close inspection i've seen it.

    The Heaters of Chimera are simple Heaterblocks and you need to insert Thermistor and Heater yourself.

    Anyway i've swapped out the delivered 12v Heaters against 24V and new Semitic-Thermistors. It has worked flawlessly but i assume after sleeving all the things together that i've slide out the inbuild sleves of the Themistors and that the contact was there.

    Sorry again for this trouble which was my own fault. Too many wires ….

    But again a big thanks for this nice build Hardware and your Fork of the original RepRap-FW!

    I'm back in business again.

    Cheers
    MoS-tekknix


  • administrators

    Thanks, I'm glad the mystery was solved! Your report prompted me to review the heater setup code, whereupon I discovered bug involving named heaters. So it wasn't all wasted time!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.