New duetwifi motors not homing



  • using rrf configuration tool(RepRapPro Ormerod 1)settings , all motors move in right direction good but non will home right . X and Y move up and down little bit and go to blue homed state, but not going to home limit switch, And Z keeps going down till crashes, have wired on outside connections and red light goes on when press limit switch.

    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.18.1 (2017-04-09)
    WiFi Server Version: 1.03 (ch fork)
    Web Interface Version: 1.15a


  • administrators

    Sounds like you have your homing switches configured in the wrong sense, i.e. you are using NC switches with parameter S0 in your M574 command, or NO switches with parameter S1 in M574. Use M119 or the Machine Configuration page of DWC to test that your homing switches are reading correctly.



  • 5:47:21 PMM119
    Endstops - X: at min stop, Y: at min stop, Z: at min stop, Z probe: not stopped

    5:51:03 PMM574
    Endstop configuration: X low end (active high), Y low end (active high), Z low end (active high),

    x and y and z were nc changed to no now x and y work but z still crashes past limit
    just noticed when hit plus 100 it tries crashing top also, have set to 200



  • cant get z, dont know why have same settings as x and y


  • administrators

    Read https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer#Homing_Z.

    Active high selection (S1 in M574) is correct for NC switches.



  • got working, had to switch z probe setting to switch even when had the top section in the configuration tool to switch, weird

    thank you


Log in to reply