Print starts too low past home z



  • how do i fix when i start a print it starts lower than my z home position, i even installed newest firmware and problem still there. I even paused print rehomed z and it went to perfect position but as soon as resumme print went too low right against bed pushing down. home g28 is in the right possition


  • administrators

    How are you homing Z? Do you have a Z probe, if so what type isn't?



  • home with Duet Web Control home buttons on computer and panel due, and sent g28 threw web control g code area and is always in good set up position but as soon as start any print job goes down right in glass scrarapping table. And use just regular z endstop active low normally open switch


  • administrators

    Is your Z endstop switch connected to the Z endstop switch input, and have you adjusted your homez.g and homeall.g files to use a Z endstop switch instead of a Z probe? See https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer#Homing_Z.



  • Chris, just trying to get new core xy running and had this same problem, home z perfect then when i went to print rams head into bed, found that homez.g and homeall.g had an instruction to set bed height to 2.5mm after doing home action. sorry cant give you g-code because i deleted them.



  • im using RepRapFirmware Configuration Tool, and had z endstop limit switch setting on top of page and not the z probe and thought that would cancel out z probe settings on bottom, but there was these default settings in switch colum:
    Trigger height at Z axis: 2.5mm
    mmTrigger height on bed: 2.5mm
    mmTrigger value: 600mm
    A switch is used to determine the distance between nozzle and bed
    i changed all settings to 0
    and now works perfect


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.