Bed Leveling with IR Probe not working…



  • Hi All,

    I just got my IR Probe and Duet WiFi installed onto my Kossel Mini and have been getting some really strange behaviour. When I run the delta calibration or G32 the console reports numbers which look like my bed has been leveled, however when I actually run a part with G32 built into my start-up (with no homing after it) the bed doesn’t appear to be level at all, in-fact its consistently low at one of the towers (X I believe).

    I changed the bed.g to probe the bed and only report the positions, then probe it and do 6 factor adjust and finally probe and report again and I get the following.

    Initial report:
    Bed probe heights: -5.135 -5.471 -5.376 -5.420 -5.361 -5.235 -5.190
    -5.328 -5.332 -5.355, mean -5.320, deviation from mean 0.099

    S6 Leveling:
    Calibrated 6 factors using 10 points, deviation before 5.272 after 0.032

    Post Level Report:
    Bed probe heights: 0.019 -0.026 0.035 -0.040 0.016 -0.040 0.035 0.034
    0.033 0.012, mean 0.008, deviation from mean 0.030

    Another strange thing is that when I run the calibration and put some paper under the head opposite the X tower the level is a little high, at X0 Y0 its great but moving 10-20mm closer to the X tower the level gets really low and the nozzle starts crashing into the bed.

    Maybe I am misinterpreting something here but I've been scratching my head over it all weekend!

    I'm using a glass build plate with blue tape on it so it so I'm confident that the plate is pretty level.

    Any help would be greatly appreciated!
    Thanks MK



  • The first bed report will always have the z offset in it, this is normal and I do get the same. you can change it my modifying the value in the config, but I understand it is not recomended because you want some margin for the first probing (just in case sth moved in your bed or so) the second third etc will be corrected for z offset.
    What is your M665 and M666 responding?
    Maybe try probing points closer to the bed rim if you can.
    Try making a 32 point calibration and maybe try a 7 factor.
    Despite the recommendations that 7 factor shall only be used if you can probe distances far from the tower. I found that my arm length was "evaluated" 4 mm longer than what I carefully measured (which is strange admittedly) but resulted in my overall flatness suddenly getting better (in theory and in practice).
    And that only measuring from a 300mm bed on a 500mm tower distance.


  • administrators

    The most likely cause is that you have a geometrical error in your build that is causing the effector to tilt as it translates in the XY plane. The tilt varies the relative heights if the IR sensor and the nozzle, which changes the nozzle height at which the IR sensor triggers. This type of tilt is very common in delta printers, and it also causes position errors, so you need to eliminate it as far as possible.

    On my delta I have a bulls-eye spirit level mounted on the effector so that I can see if there is any tilt. You can also check for tilt by dropping the nozzle until it is touching the bed, then use feeler gauges to measure the height of the bottom edge of the IR sensor above the bed. Repeat at different positions (in your case, at positions increasingly distance from the X tower). If the height you measure isn't constant, then you have effector tilt, assuming the bed is flat.

    Common causes of effector tilt include:

    1. Diagonal rods in a pair not the same length, measured between bearing centres
    2. Bearing spacing not the same at the top of a pair of rods as it is at the bottom
    3. A carriage is rotated about its face, so that the two bearings on it are not at the same height (bearings on the effector not at the same height would have the same effect)
    4. A carriage is rotated about the Z axis. This can happen if you use wheeled carriages and the carriage truck is warped, or the spacers between the wheels and the carriage truck are not the same length for all 3 or 4 wheels
    5. Play in the joints, coupled with the sideways force applied by the Bowden tube changing direction with XY position

    My delta initially had issues 2 (fixed by adding washers and shims between the effector and the bearings), 3 (fixed by loosening the screws holding the carriage, rotating it, and re-tightening the screws), 4 (caused by using one washer too few under one of the wheel bearings), and 5 (fixed by supporting the Bowden tube from the top frame with elastic to reduce the sideways force, and by adding springs between the rods in each pair).

    Any residual tilt that you can't eliminate can be accounted for by measuring the IR sensor trigger height at each probe point and using the H parameter on each G30 command in bed.g (except for the one in the centre) to account for the change in trigger height.

    HTH David



  • There is a nice stl to check for effector tilt here http://www.thingiverse.com/thing:1369444 clip it onto your effector and move the head around, its easy to see if there is tilt. You can use it in several orientations.

    I've got a similar problem but fixing it is on hold as my magnets in my magnetic arms are not strong enough and they keep becoming detached, I am waiting until stronger magnets turn up. I have redesigned a fan shroud to position the IR sensor as close to the nozzle as I dare (which is quite close as I've got the E3D silicone cover), this reduces the magnitude of the nozzle-probe discrepancy.

    Whilst I really like the IR sensor, having just moved it from my corexy, it does seem a little trickier on a delta machine where a small amount of mechanical error in the build and therefore tilt, is inevitable until we start building them using robots or on jigs to ensure 100% mechanical precision. Its hard not to conclude that if a totally reliable nozzle to bed contact probe were available it would be preferable. I've tried FSR's and they seem reasonable. I believe some promising work with piezo discs is being done.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.