PWM fan 1 not working properly ?



  • Today I did some fan tests with my brand new Duet.

    When I execute 'M106 P0 B1.0 S0.3 F250', the fan on that port starts nicely , the same for P2, Playing with speeds and other parameters just works, but P1 refuses to modulate.
    Only when I invert = sending 'M106 P1 B1.0 S0.3 F250 I1', the fan goes to full speed and changing the I-parameter to 0 stops the fan. So I suppose electronics is working properly.

    Board reports temperatures (both NTC and PT100) in some previous testing with USB-5V power.
    I connected now for the first time to a 20V supply to check the power electronics. In this case with a 24V axial fan.

    I do not find any difference between F0, F1 and F2 in the descriptions.

    Any idea??

    I did comment out all FAN-related commands in the config file :

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Aug 16 2017 22:24:32 GMT+0200 (Romance Daylight Time)
    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X270 Y290 Z360 S0 ; Set axis maxima
    ;
    ; Endstops
    ;
    M574 X1 Y1 Z0 S0 ; Define active low (S0), X/Y : low end (1), Z : unused(0)
    ;
    ; ** BLTouch in config.g
    M307 H3 A-1 C-1 D-1 			; BLTouch - servo pulse on heater 3 pin - disable heater
    M558 P5 X0 Y0 Z1 H5 F200 T5000 	; P5 for BLTouch (Normally closed switch on Z-probe inputs)
    ;
    G31 X-22.00 Y7.0 Z1.5 P5 ; Z=trigger height, P=trigger value, not needed for contact probe
    
    ; Steppers
    ;Map steppers to drives
    M584 X0 Y1 Z2 E4
    ;
    ; M569 - direction : S0=back, S1=forward
    M569 P0 S0            ; Drive 0 forwards - X
    M569 P1 S0            ; Drive 1 Backwards - Y
    M569 P2 S0            ; Drive 2 Backwards - Z
    ; -- M569 P3 S1            ; Drive 3 Not used
    M569 P4 S1            ; Drive 4 goes forwards - E0
    ;
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z400 E804 ; Set steps per mm
    M566 X600 Y600 Z600 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z500 E500 ; Set accelerations (mm/s^2)
    M906 X800 Y1200 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    ;
    ; Heaters
    M143 S320 ; Set maximum heater temperature to 320C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 S"BED" T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 S"Extruder" X200 ; Set PT100 for heater 1 and remap it to channel X200
    
    ; Tools
    ; Define tool 0 = Extruder 0, Heater 1 and Fan 0
    M563 P0 D0 H1 ;F0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Network
    M550 BigOne					; Machine name and Netbios name (can be anything you like)
    M551 MySecret
    M552 S1 ; Enable network
    ; Access point is configured manually via M587 by the user
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S1 ; Enable Telnet
    
    ; Fans
    ; i0=default, i-1=disabled, fxxx=frequency, Lnnn=minimum speed, Bnnn=Blip time, Hnn:nn:nn=heaters selected thermostatic mode, Tnnn or Tnn:nn trigger temp or range
    ;
    ; Hotend cooling fan
    ;M106 P0 I0 F500 H1 T50 L1.0; Set fan 0 value, Thermostatic control start at 50°C, directly to 100%
    ; Electronics cooling fan
    ;M106 P2 H100:101 T45:55 L0.3   ; @30% when above 45°C gradually increasing to 100% at 55°C, virtual heaters =CPU and TMC's
    
    ; Custom settings are not configured
    
    


  • So … started again once reading through some issues and although I restarted the duet without fans referenced in the config file, it seemed to be in thermostatic mode.
    After sending M106 P1 H-1 S0, the fan worked fine.

    learned a lesson 🙂


  • administrators



  • Got it…
    Thanks for not throwing RTFM 😉
    Learning !


  • administrators

    I guess it's hidden away rather. I'll add it to the "Common problems" section too.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.