No USB connection, broken device?



  • I got a duet ethernet that has never been used and cannot get it to connect to any of my computers.

    It looks like this:

    On two windows machines I get a unknown device (error 43).
    My linux box has this in the syslog:

    Aug 24 20:39:53 server kernel: [2407929.900833] usb 2-1.5: new full-speed USB device number 66 using ehci-pci
    Aug 24 20:39:53 server kernel: [2407929.972788] usb 2-1.5: device descriptor read/64, error -32
    Aug 24 20:39:54 server kernel: [2407930.148642] usb 2-1.5: device descriptor read/64, error -32
    Aug 24 20:39:54 server kernel: [2407930.324492] usb 2-1.5: new full-speed USB device number 67 using ehci-pci
    Aug 24 20:39:54 server kernel: [2407930.396437] usb 2-1.5: device descriptor read/64, error -32
    Aug 24 20:39:54 server kernel: [2407930.572297] usb 2-1.5: device descriptor read/64, error -32
    Aug 24 20:39:54 server kernel: [2407930.748148] usb 2-1.5: new full-speed USB device number 68 using ehci-pci
    Aug 24 20:39:55 server kernel: [2407931.155818] usb 2-1.5: device not accepting address 68, error -32
    Aug 24 20:39:55 server kernel: [2407931.227759] usb 2-1.5: new full-speed USB device number 69 using ehci-pci
    Aug 24 20:39:55 server kernel: [2407931.635437] usb 2-1.5: device not accepting address 69, error -32
    Aug 24 20:39:55 server kernel: [2407931.636247] hub 2-1:1.0: unable to enumerate USB device on port 5

    I also tried reset and erase and a number of different cables.

    Is there anything else I can try or is the device simply broken?

    Thanks,
    Jan



  • With the exception of mine having been in commission I'm now having the same issue you are 😞


  • administrators

    Have you installed the Windows device driver?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.