No networks found after 1.19+4 upgrade



  • with the number of people having problems with network communications after upgrades, i would think that there is a problem somewhere in the instructions, possibly assumptions that we know everything. it appears that step one of loading the Duet Web Control can be done with DWC, but nowhere do i see a place to replace the /www folder, so i remove the SD card and replace and rename the files accordingly. i then send the M997 S0:1, which downloads fine, but i have to reboot the duet wifi module, after that everything works fine until i try to get the access point.

    m98 p/macros/setnetwork
    SENDING:M98 P/MACROS/SETNETWORK
    WiFi module started

    m587
    SENDING:M587
    Remembered networks:
    Coyote Delta
    COYOTE DELTA

    m552 s1
    SENDING:M552 S1
    WiFi reported error: no known networks found
    Wifi module is idle

    i dont know what i am missing, i have tried this procedure several times including a m997 s0 then a m997 s1. if i try the update firmware button and the DWC it losese connection right after the firmware finishes updating.
    as soon as i revert back to1.18, everything works fine. Could you rewrite the procedure a with a little more detail involved and include what to do if a certain step does not work. It would probably save you a lot of time having to answer all of the thread regarding network connection issues.


  • administrators

    The error "No known networks found" means that the WiFi module couldn't find a wireless network with name either Coyote Delta or COYOTE DELTA. Is one of those really the SSID of your WiFi router?



  • To me it happens exactly the same as arwaug. I can not connect to my ssid after updating. To return to 1.18 all correct.I've tried it all afternoon, several times but I have not been able to.



  • This might be where the confusion comes from. Coyote Delta is the machine name and reprap the password set in the config.g file, which is what I used to set up the SetNetwork macro, is this wrong?



  • M587 when called should your home wifi SSID, it looks like you programmed in your machine name instead of your wifi access point and password.
    This link may help: https://duet3d.com/wiki/Getting_connected_to_the_Duet_WiFi
    look at the Connecting to your access point using firmware 1.19 or later section
    Connect via USB and pronterface or the like and:
    You can use M588 to erase the coyote delta , just send M552 S0 and then M588 S"COYOTE DELTA" and the same for the lower case to delete them

    And the send M587 S"your-network-ssid" P"your-network-password"
    and lastly M552 S1 and it should connect to the strongest network if you have entered more than one

    Also I reserve the right to be completely wrong if I am but it worked for me



  • Should work with v1.19+4. Installed that release last night and connected without issues.
    Best take your smartphone and do a wifi survey. Use the name exactly as shown (upper case/lower case).
    Survey tools I use on android : IP tools for more technical info and wifi analyzer (gives a graphical overview)


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.