Can't Connect DuetWiFi to Network



  • I've already connected it once before, but had to wait several months for parts to ship in.

    I've looked at the wiki process and typed M552 S0, which says "WiFi server stopped". But when I type in M587 Snetgearxx Ppassword123 it says unsupported command. Even when I typed M587 it says it's an unsupported command.

    The firmware version is 1.18, and I haven't changed anything since it was last connected and working. I don't know why it's dropped the IP address assigned to it either.


  • administrators

    The M587 command is supported in firmware 1.19 and later. See https://duet3d.com/wiki/Upgrading_to_DuetWiFiFirmware_1.19 for how to upgrade.

    Note that if you send M587 from Pronterface, Repetier or another 3D printer host program, it will convert the characters in your password to uppercase. That's why we suggest creating the macro file to do it. Alternatively you can send the command over USB from a plain terminal emulator such as YAT.



  • If I update my firmware, is that going to erase all of the Gcode I used to calibrate my printer as well?

    I don't know how to create a macro file, and I don't know what a terminal emulator is either. It's rocket science to me…


  • administrators

    No, you can keep your config.g file. If you use G29 S1 to load an existing height map, you will need to generate a new height map by running G29 S0 (or just G29 with no parameters) again.



  • OK. How do I save my existing config.g file out while I load the new firmware on? Like a backup before I update the board…

    Can I access the Duet console via my USB connection? Or can I just connect to the Duet using my existing set up first. It was working with 1.18, so it should still work right? I just need to get into the console so I can manage the config. I can't see why I can't connect when it's had no outside network influences since it was working.

    UPDATE I got into the console with M115 and restarting the Duet server.

    I don't however and SD slot on my computer. I have a Surface Pro 4, and it doesn't have an SD card slot in it, or in the docking station either. When it says upload to /www on the SD card, is that while it's in the Duet board slot? If so, how do I access the SD on the Duet through the network or USB?



  • I uploaded the 1.19 firmware and server files through the console, and I installed YAT.

    After connected to the printer through the USB I start the connection process but I get this:

    M552 S0
    ok<lf>WiFi module started<lf>Error: Failed to initialise WiFi module, code -10 <lf>M115
    FIRMWARE_NAME: RepRapFirmware for Duet WiFi FIRMWARE_VERSION: 1.19 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2017-08-14<lf>ok <lf>M552 S1
    ok<lf>WiFi module started<lf>Error: Failed to initialise WiFi module, code -10</lf></lf></lf></lf></lf></lf></lf>



  • I'm now trying the firmware update Fallback Procedure #3.

    I've successfully installed both a version of SAM-BA and BOSSA. Both start up, but neither of them recognise COM7, which I've been working with since the update.

    BOSSA doesn't even list COM7. SAM-BA is such as small window, the only way I can change the COM directory is by typing it into the address bar, and it doesn't recognise COM7. I've gone back to Pronterface to see if I can connect to COM7, and it fails as well.

    So it appears that I now can't connect to the Duet via USB. I've checked the Device Manager and it fails to recognise the device. I've downloaded the latest Duet Driver and tried installing it with the Have Disk process, and it just says that the folder doesn't contain a compatible software driver for the device.

    Windows has stopped this device because it has reported problems. (Code 43)

    A request for the USB device descriptor failed.



  • I should simplify where I'm at…

    I downloaded DuetWiFi firmware version 1.19
    I connected to the Duet console with the correct IP address
    I uploaded the firmware and server bin files
    The Duet was then no longer accessible by USB or wireless
    I hit erase and reset on the Duet according to Fallback Procedure #3
    I downloaded and installed SAM-BA and BOSSA
    Neither of these programs can connect to the Duet COM port
    I now cannot update the driver for the Duet device in Device Manager


  • administrators

    When you connect the USB cable, what port shows up in Device Manager?



  • After restarting both the computer and printer, it doesn't show up as a device that doesn't have a driver anymore. It shows up as Bossa Program Port (COM5), which is the first time I've seen it on COM5.

    I went back to the Fallback Procedure #3 and followed the instructions through on the SAM-BA process. I couldn't get SAM-BA v.216 to work at first because it only works if I lower the display resolution to 1024x768. Once I did that I could see the connect button and follow the rest of the procedure through.

    I've uploaded the v.19 firmware now and can connect to the printer with the USB in Pronterface, which is now changed to COM7.



  • I'm not sure what to do next. I'm guessing it doesn't have a server for me to connect to on the board yet…

    M115 says it's wifi firmware is 1.0.

    I tried connecting to the Duet using SAM-BA again, but it just says Invalid Chip ID.

    Is there a to update the wifi firmware without using an SD card?


  • administrators

    It's not possible to update the WiFi firmware without an SD card. Do have an SD card reader that plugs into a USB port? If not, you can get one on Amazon or eBay



  • I've ordered a SD reader, but it won't arrive until Friday. I'll come back to the update on the weekend.



  • They sent the SD reader early.

    I followed the server and web control installations through, but I received an error:

    Connecting…
    Printer is now online.

    M997 S1
    SENDING:M997 S1
    Trying to connect at 460800 baud:
    success
    Erasing 295232 bytes...
    Uploading file...
    5% complete
    10% complete
    15% complete
    20% complete
    25% complete
    30% complete
    35% complete
    40% complete
    45% complete
    50% complete
    55% complete
    60% complete
    65% complete
    70% complete
    75% complete
    80% complete
    85% complete
    90% complete
    95% complete
    Upload successful
    WiFi module started
    Error: Failed to initialise WiFi module, code -10
    [ERROR] Error: Failed to initialise WiFi module, code -10


  • administrators

    Check that you have compatible versions of main firmware and the WiFi firmware, preferably both 1.19.2 which is available from https://github.com/dc42/RepRapFirmware/releases . To check the main firmware version, run M115. If the main firmware is out of date, you can copy the DuetWiFiFirmware.bin file to /sys on the SD card, pop it back in the Duet, start the Duet and send M997 S0 to install it. It will disconnect while it installs, but you should be able to reconnect one minute later.



  • Downloaded 19.2 firmware and server, and copied them to the /sys folder of the SD card, ran M997 S0, and also M997 S1 and got this error:

    Connecting…
    Printer is now online.

    M115
    SENDING:M115
    FIRMWARE_NAME: RepRapFirmware for Duet WiFi FIRMWARE_VERSION: 1.19 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2017-08-14

    M997 S0
    SENDING:M997 S0
    [ERROR] Can't read from printer (disconnected?) (SerialException): call to ClearCommError failed

    M997 S1
    SENDING:M997 S1
    [ERROR] Can't write to printer (disconnected?) (SerialException): WriteFile failed ([Error 22] The device does not recognize the command.)

    I then tried M997 S1 first and it worked.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.