Duet failed after 4 days of usage, Keeps disconnecting from wifi..



  • Good Morning Everyone,
    I would like to take a moment to thank you for taking the time to look at this thread.
    So I finally assembled UltiBots D300VS a couple days ago and every thing seems to be working fine until yesterday when I kept getting kicked out of the web interface due to "AJAX" errors. I ignored it thinking it was the wifi just acting up but this morning I have been trying to connect into the web interface with no avail. Ultibots has not updated their firmware to 1.19 yet so I am stuck on 1.18.1.

    1. I power cycled the D300VS, thinking it may help
    2. Didn't work so I connected to prointerface to M552 S0 then M552 S1 to restart the server
    3. After doing this a few times I noticed it was emitting DuetWifi again, so I reconfigured it to my wifi
    4. Didn't work but I saw a post where someone just configured their wifi signal channel from auto to a single channel, so I tried that (Tried M552 S0 and S1 again )
    5. Tried updating the router, even though the rest of the devices are good (Tried M552 S0 and S1 again )
    6. Then I reinstalled the firmware via the SD card option and then SAM-BA
    7. Then I came across a few threads to update the wifi firmware via M997 S1 (Wifi) and M997 S2 (Webinterface)

    Alas I came here to post something as I could not find another post (well I did find another post but David mentioned updating to a beta 1.19).

    This is the error message:

    M552 S1
    SENDING:M552 S1
    WiFi server starting up
    DuetWiFiServer version 1.03 (ch fork)
    Flash size 4194304, free RAM 32840 bytes, WiFi Vcc 3.14V, host name: duetwifi, reset reason: Turned on by main processor
    WiFi server connected to access point Fireworks, IP=192.168.20.81, signal strength=-43dBm
    DuetWiFiServer version 1.03 (ch fork)
    Flash size 4194304, free RAM 32584 bytes, WiFi Vcc 3.14V, host name: duetwifi, reset reason: Exception
    WiFi server connected to access point Fireworks, IP=192.168.20.81, signal strength=-45dBm

    The "reset reason: Exception" part appears every time I try connecting to it via the ip address (I tried via the host name but that didn't work on my mac or windows)

    If anyone wants it this is M122 the diagnostics

    M122
    SENDING:M122
    === Diagnostics ===
    Used output buffers: 1 of 32 (12 max)
    === Platform ===
    Static ram used: 20320
    Dynamic ram used: 72784
    Recycled dynamic ram: 1104
    Stack ram used: 3280 current, 4112 maximum
    Never used ram: 32752
    Last reset 00:32:57 ago, cause: reset button or watchdog
    Last software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Spinning module during software reset: GCodes, available RAM 33080 bytes (slot 4)
    Error status: 0
    [ERROR] Error status: 0

    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 34.7, current 41.2, max 45.6
    Supply voltage: min 1.1, current 1.3, max 1.4, under voltage events: 0, over voltage events: 0
    Driver 0: ok
    Driver 1: ok
    Driver 2: ok
    Driver 3: ok
    Driver 4: ok
    Date/time: 1970-01-01 00:00:00
    Slowest main loop (seconds): 1.458130; fastest: 0.000000
    === Move ===
    MaxReps: 0, StepErrors: 0, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    Probe change coordinates:
    === Heat ===
    Bed heater = 0, chamber heater = -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    Code queue is empty.
    === Network ===
    WiFiServer is running
    SPI underruns 0, overruns 0
    === Webserver ===
    HTTP sessions: 0 of 8



  • Oh I also reset the cache on both my mac and windows to confirm it wasn't that and tried safari/chrome.


  • administrators

    Ultibots is using standard firmware AFAIK so I see no reason for you not to upgrade to firmware 1.19. Get it from https://github.com/dc42/RepRapFirmware/releases and read the upgrade notes first.



  • Hello David,
    On the Ultibot forums they cautioned users not to upgrade the firmware, probably for their own testing purposes..I will try it later today and get back to you on it



  • Upgrading to 1.19.2 may not solve your "Ajax error" or "failure to connect to Duet".
    A few of us are on the newest firmware and continue to have the issues you describe


  • administrators

    I'm not aware of anyone who has has the WiFi module exception messages since upgrading to 1.19 or 1.19.2. That is why I suggested upgrading.



  • I posted the issue on the ultibot forum and someone stated that upgrading to 1.19.2 fixed this problem. I'll try it later tonight and post my results back here



  • Today I updated the Firmware, Wifi Server and Web Interface to 1.19 and AJAX problems started. The board could only stay connected for like 10 seconds. Luckily I was able to fix it. What worked for me was changing the Wifi transmission channel of the router to "1" (it was set to "automatic"). If you don't know which channel to use, then download this program:
    http://www.nirsoft.net/utils/wifi_information_view.html
    It's a free tool and you don't need to install it. Once you launch it, it will scan the wireless networks in your area and display a lot of info about them. Locate the Channel header, and click it to sort by Wi-Fi channel. Switch to the less crowded one. 1, 6 and 11 are the most frequently used.

    Hope it helps.

    EDIT: oh… you tried this already =(


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.