COM PORT disappeared while updating to 1.19



  • I was updating my firmware, following the instructions for 1.19. I connected with Pronterface and started the upgrade. I got this message.

    Connecting…
    Printer is now online.

    M997 S0:1
    SENDING:M997 S0:1
    Trying to connect at 460800 baud:
    success
    Erasing 244400 bytes...
    Uploading file...
    5% complete
    10% complete
    15% complete
    20% complete
    25% complete
    30% complete
    35% complete
    40% complete
    45% complete
    50% complete
    55% complete
    60% complete
    65% complete
    70% complete
    75% complete
    80% complete
    85% complete
    90% complete
    95% complete
    Upload successful
    [ERROR] Can't read from printer (disconnected?) (SerialException): call to ClearCommError failed
    Disconnected.

    Now I have no COM port in the device manager, it just says duet with the yellow triangle. I can't get a COM port so I can't connect to start with wifi.



  • Hi,

    Did you disconnect and reconnect the USB cable?

    When I upgraded from 1.18.x to 1.19.x I simply removed the SD card from the Duet, plugged into my computer and copied the new files into place.

    Once the SD card was restored to the Duet, a reboot and it was done.

    Frederick



  • Thanks for the reply. I did it the same way, by putting the card in my computer. I unplugged and plugged the USB cable in several times, tried it with and without power to the board. I tried uninstalling the duet device from the device manager. I finally tried it in a different USB port and it loaded. I had a new com port but that's not a bug deal.



  • Glad to hear you got it working. Even with up-to-date gear USB can be a bit strange at times.

    When things that used to work stop working one of the first things I try is to reboot my computer.

    Frederick


  • administrators

    It's normal for the COM port to disappear while the main firmware is being updated. It should reappear about 30 seconds later when the upgrade completes. However, there is some sort of bug in Windows 10 that sometimes causes it to ignore the USB port that a Duet was connected to after a firmware upgrade. When it happens to me I either change to a different port, or if I am using a USB hub, disconnect and reconnect the hub.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.