Connecting Duet Wifi to slicer software



  • Hi
    Please forgive me. I am just starting out and just finished installing my duet wifi.

    I don't understand how the board and the slicer software interface. In looking at it from the slicer documentation, it always has a step to connect to the printer board. Obviously, with a Wifi board that wouldn't make much sense. I haven't seen any settings in the Duet setup that talk about what slicer to use and where it is located.

    I have loaded my first item to be printed on the SD card on the Duet board, but I can't see it from the slicer software.

    So, do I run the slicer software locally, and then just copy the gcode file up? Do I edit the gcode file after the slicer is done for items that are specific to the board?

    An overview would be greatly appreciated as I didn't find anything in the wiki that went beyond setting up the links between the hardware and the firmware.

    Thanks,
    Tim


  • administrators

    The Duet will work with most (all?) Slicers. Slice your file and save it to your harddrive. Upload it to the Duet in the web browser ( gcode files tab) then print.



  • Do you have the Duet connected to your Wifi? If so, determine what the IP address of the Duet is (192.168.. is usually the address) and type that into your address bar. Should pull up the DWC (Duet Web Control) screen. Note, IE works for most stuff but you can't access the System Editor, so Chrome is the next best thing.

    Once the DWC is open, at the top middle is an Upload and Print button. Click it, find the file on your computer that you want to print and select it. It will begin uploading to the Duet and start printing.

    There isn't an onboard slicer, so you need to do that yourself outside of the DWC. If using Cura, you need to add M82 to the start of the g code file. Should be a setting in Cura to adjust the start script. S3D takes care of that for you.



  • Hi T3P3Tony and number40fan

    Thank you both for your responses.

    I have a laptop that is almost always connected to the printer through the DWC. I have Cura and Slic3r. I've played with Cura, so I will get more familiar with that and figure out how to edit the g code file.

    Getting closer…
    Thanks,
    Tim


  • administrators

    It's possible to have most slicers send data direct to the printer, and a few very basic 3D printer kits require you to do that because they don't have a SD card. But it's generally better to save the file to SD card and print from that - not just for the Duet but for any 3D printer electronics. Otherwise, it's hard to guarantee that the PC will always be able to provide data to the printer fast enough, and won't decide to go to sleep, or start installing software updates, or run a backup etc. 3D printing is a real-time application, and PC operating systems are not designed for that.



  • Ok!!

    More positive progress. First, I bought and installed Simplify3d, then I watched their introductory tutorials.

    I am perfectly clear on the relationship between the Slicer and the DuetWifi and have a good solid process for loading my file, slicing it, and then using File Upload to SD.

    I have the nozzle heater come up to temperature by starting it manually, and the bed come up to temperature also by manual input, and then I start seeing messages that I am trying to heat without a tool selected, and then trying to extrude without a tool selected.

    In Simplify3d, I have the Extruder in Process1 set as Primary Extruder. In the Primary Extruder Toolhead, Index is set to Tool 0.

    My start script is:
    G21; Metric Values
    M116; wait for all temps
    M561
    T0
    M116
    G28 ; home all axes
    G32

    What am I missing to link the Primary Extruder in Simplify3d to tool0 in DuetWifi, or should it be something else?

    I have a Titan Bowden Extruder that is E0 on the Wifi board. It seems that at the best of times, I am only getting a tiny little bit of filiment coming out of the nozzle, and sometimes none at all. I'm not sure if that is because of the tool error message or something related to steps / mm on the Titan Extruder. (where do I set that and to what value?)

    In Simplify 3d, the diameter is set to 0,4, the extrusion multiplier is 1 and extrusion width is auto. I do know that the Titan extruder has a 3:1 ratio.

    Should my extrusion multiplier be set to 3?

    Making progress but not printing yet….
    Thanks.
    Tim


  • administrators

    Have you set the extruder steps/mm value correctly, in the appropriate M92 command in config.g ?



  • I have not set an M92 command anywhere. I know pretty much 0 about g codes

    Is there a document anywhere that explains how to setup Simplify3d with DuetWifi? I feel like I'm twisting in the wind.



  • Did you download the .fff file for the Tevo for S3D?

    Try adding a M104 T0 to the top of the startup script.

    M92 defines the number of steps of your motors. I found this for the Tevo.

    #define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,1600,822}

    Add M92 X80 Y80 Z1600 E822 to your config.g before your M906.

    It would then be best to manually move each stepper motor in DWC 100 mm and check that it does move that far. With the extruder, mark the filament 150mm before it enters the motor, warm up the hotend, command 100mm movement at 1mm/sec (so it won't skip) and measure how far away the mark on the filament is now from the motor. Should be 50mm,



  • Hi number40fan

    Thank you so much for your post with this level of detail. You are amazingly helpful and I really appreciate it. I will follow your outline and report back.
    I am having some problems also with setting the initial Z height. It is too high.

    I will look for the .fff file for the Tevo for S3D



  • Hi number40fan

    I downloaded the .fff Tevo file for S3d. It was for a dual extruder model, where mine is a single. I removed the 2nd extuder and the heater for it within Simplify3d and saved the profile.

    I will modify the script to reflect your contribution above and then test my actual distances.

    My configuration has the Titan extruder which they were including with the purchase of the printer. I mention it because from what I read, it changes the distance / mm from what the stock extruder would provide.

    I will keep you posted.

    Tim



  • Ok:

    I was under the impression that the script file from Simplify3d would overwrite the bed / config files from DWC.

    Here is my current script file:
    M104
    T0
    M92 X80 Y80 Z1600 E822 ; define steps / mm configurations
    G28 ; home all
    G92 E0
    G1 Z0.1 F1000
    G1 X8.0 F2000
    G1 Y60.0 E4.0 F1000.0 ; prime
    G1 Y100.0 E8.5 F1000.0 ; prime
    G92 E0

    When I uploaded the file to DWC, the printer ran what appears to be the autobed compensation file as I saw errors indicating that the Z probe had not triggered during the hot end's move.

    Here is the home all content which is called from the Simplify3d script:
    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Sep 08 2017 09:50:05 GMT-0400 (Eastern Daylight Time)

    ; Relative positioning
    G91

    ; Lift Z
    G1 Z5 F6000

    ; Course home X and Y
    G1 X-195 Y-285 F1800 S1

    ; Move away from the endstops
    G1 X5 Y5 F6000

    ; Fine home X and Y
    G1 X-195 Y-285 F360 S1

    ; Move Z down until the switch triggers
    G1 Z-185 F1800 S1

    ; Absolute positioning
    G90

    ; Tell the firmware where we are
    G92 Z2.5

    ; Uncomment the following line to lift the nozzle after probing
    ;G1 Z5 F100

    The hot end is still high and I am not getting much extrusion (if any), so I killed the print.

    I am now going to go through the manual tests to measure the steps / mm settings that you referenced in your post.
    Thanks,
    Tim



  • Note
    Sorry, I forgot to mention that I still get the messages indicating movement with no tools selected and then heating an extruder without a tool selected.



  • Ok . Travel distances

    X moved forward 100MM
    Y moved forward 100MM
    Z moved up 30MM

    E made a lot of noise but did not move. Set the heater to 240 and clicked to unload filament. No unload.
    Unlocked the plastic tube where it enters the hot end and removed it with the filament. Good solid 5mm length of filament at the end that was removed. Looks like the tube did not go all the way in, or something else is off in the hot end. I will take it apart, check the nozzle for a clog, and then check to make sure the metal tube is sitting against the back end of the nozzle before I put it back together.

    Nozzle is clogged.

    Thanks,

    Tim



  • Unclogged. I can manually push on the filament and it will flow out of the nozzle. I've played with the feedrate and amount settings and it doesn't seem to want to push it through.

    If I manually get it started, it will feed for a bit, and then it will stop and the stepper just rocks back and forth, seemingly between forward and backward. Any chance it need more current to turn the motor against the backpressure of feeding the filament out of the nozzle?
    Thanks
    Tim



  • Could be. A sent you an email, btw.



  • Ok, after your post of 20:12

    Current M92 in config.g :
    X640 Y640 Z3200 E400

    Changed to
    M92 X80 Y80 Z1600 E822

    Commented two lines that set Z probe since I don't have mine yet.
    Rmoved M92 line from script file

    Edited last line in Config.g to change tool to T0 since I only have 1 extruder.
    Moved T0 to M104 line in script file:

    Thanks
    Tim

    Script:
    M104 T0
    G28 ; home all
    G92 E0
    G1 Z0.1 F1000
    G1 X8.0 F2000
    G1 Y60.0 E4.0 F1000.0 ; prime
    G1 Y100.0 E8.5 F1000.0 ; prime
    G92 E0

    Config.g
    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Sep 08 2017 10:03:01 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    ;M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X210 Y280 Z180 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Define active low and unused microswitches
    ;M558 P0 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    ;G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X25:175 Y25:175 S20 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X128 Y128 Z128 E16 I0 ; Configure microstepping without interpolation
    M92 X80 Y80 Z1600 E822 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z1200 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z100 E5000 ; Set accelerations (mm/s^2)
    M906 X855 Y855 Z855 E855 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B3988 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4725 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P1 D0 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Network
    M550 PTevo Tarantula ; Set machine name
    M552 S1 ; Enable network
    ; Access point is configured manually via M587 by the user
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool



  • How many amps do your motors use? Should be a sticker on them.



  • Woah

    I think it might be doing something, but it is really hard to tell. It took forever to make the effort to home all and it did that very slowly and so far it has not moved off of home.

    I had forgotten the other change to M92. for the extruder settings so I have done that and reset.

    I am still getting "attempting to extrude with no tool selected" and the extruder is not feeding.



  • After the last reset, the speed is ok, but still "attempting to extrude with no tool selected."


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.