Unable to Edit Config Files in Duet Web Control



  • I have been unable to edit config files in DuetWebControl since I fired up my Duet Ethernet. I upgraded to 1.19.2 but that doesn't make a difference. I attached a screenshot from Chrome showing the errors in the console. Further, when the AJAX error occurs, the web interface drops the connection to the board and I have to click Connect again. Also, I am unable to upload a .zip file w/o at least one file causing an error in the upload. What shall I look for to address this issue?


  • administrators

    I haven't seen that error before. I suggest you delete (or rename) and recreate the /www folder on the SD card and extract the version 1.19 DuetWebControl.zip file into it, in case you have a mixture of files for different versions. Also you could put the SD card in a PC and scan it for errors.



  • Would it be best to also format the SD while I'm at it? i should be able to rebuild the folder structure as define in the wiki.


  • administrators

    If you like, but it shouldn't be necessary unless your PC indicates that it has errors.



  • OK, freshly formatted SD card with a fresh unzip of Web Control and I'm still receiving errors. I also noted that even the bootstrap css file failed. I also tried in Safari with the same results.



  • I had issues with Java on my computer. It took removing every Java related file before downloading the latest version to fix it. That meant going into regedit and deleting everything I found in there as well.



  • @number40fan:

    I had issues with Java on my computer. It took removing every Java related file before downloading the latest version to fix it. That meant going into regedit and deleting everything I found in there as well.

    this is a mac. further, the errors are coming from the server.


  • administrators

    Looks to me that either there is something strange going on with your network, or there is a hardware fault that is causing data corruption. Are you using an ordinary home network? Have you tried a different Ethernet cable? If so then I'm happy to recommend that your supplier exchanges your Duet for another one.

    The web interface doesn't use Java, it use JavaScript which is completely different despite the similar name.



  • Only concerning the not being able to edit configfiles I can say that I have seen that, sometime after updating from 1.17e to something newer I believe, I have been struggling with that for an hour or so, left it with that, and after a good night sleep all suddenly worked okay again… I know this is not helpful, but at least you know that not being able to edit could be due to a firmware upgrade (or more likely the DWC upgrade).


  • administrators

    Yes, this sort of problem could possibly be caused by using incompatible DWC and firmware versions. That's why I suggested recreating the /www folder.



  • dc42,
    I'm not the only one here reporting this problem. I'll grab another switch and setup a dedicated network with my laptop to see if that does it however confidence is low.



  • OK. I grabbed a 10/100 switch off the shelf and created a two host network between my Macbook Pro and the Duet Ethernet. Both machines have manually configured IP addresses. I am still receiving the same errors in the browser and I still cannot edit a system file in web control. Like before, the failure associated with the editing of the file causes the web control app to loose connection to the Duet. This screenshot was taken just after the app lost its connection.



  • can you show a screen shot of the General page of the Settings tab please?



  • As requested:



  • ok next request can you take a screen shot of the contents of the WWW Directory you can use a FTP Client to get it if you dont want to remove the SD Card? I have a hunch but don't really want to elaborate for fear of sending you down the garden path.

    Doug



  • as requested. at some point, i reformatted the SD card and reloaded the data. The www folder should just be the contents of the web control .zip file.



  • Just as an add-on, I'me getting kicked out of an FTP connection as well.



  • um well that has got me stumped now think you may have to wait on David. My hunch was wrong which is why I didn't want to say anything.


  • administrators

    Can you install Wireshark on the Macbook and get a Wireshark trace of the packet exchange when it gives that error?

    Do you have any other laptop or PC that you can try running DWC on?



  • Maybe try installing Chrome I believe that DWC sometimes gets upset with Safari


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.