Suggestions on my layer shift issues?



  • Large delta with Duet Wifi.

    I am having layer shift issues. It seems it is ALWAYS:

    • Between 1CM and 2.5CM into the print
    • When my prints are large - as in 250mm across

    If I print something smaller, say 50mm across, it never seems to happen
    It does not always happen when I print large items
    I am always printing slow (need to get it reliable first), typically running about 15-30mm/s

    What I have tried to fix and or have changed for other reasons:

    • Checked for binding, found a bit and fixed it
    • Upped drivers to 2A with 60% holding
    • Switched from GT2 to GT3 (in case it was a belt slip)
    • Moved from Nema 17 1.8 to Nema 17 0.9 steppers (to not loose resolution with larger GT3 pulleys)
    • Added cooling fans to Steppers (they were VERY hot, now run about 80-85F [less than 30C])
    • Added fan for Duet (though driver chips never seemed hot)

    The cooling fans on the steppers seemed to have helped as I could NOT get a complete large print before that point. Now I can…. sometimes.

    What seems weird, is that if a single tower had an issue - belt slip or stepper issue, it should cause one end of the print to be high or low. But that is not the case.

    In the pictures, I choose to let this print finish because I can 'fix' this part manually. This part is about 10in / 25cm across in X and Y on this print. Shift roughly 6-8mm. With a part this far across, it seems a shift would be catastrophic as it would lift one side a bunch, or grind the head into one side a bunch.

    There is no way for my bed to shift without it being noticed - and that seems to me to be the 'logical' way for a shift like this to happen.

    A bit more data that may or may not be relevant....

    Parts designed in F360
    Sliced with Slic3r Prusa edition (latest)
    Printer uses THK 15 size linear rails (bit bigger than those used on small deltas)
    Printer uses a flying extruder, but the weight of it is held from the frame of the delta, not from the carriages

    The attached pictures show the shift about 20mm into the print, and a possible smaller shift about 20mm higher.

    Suggestions on what to check/change/investigate from here?

    Thanks,

    Frank


  • administrators

    If it only occurs on large prints then perhaps the travel speed is too high. Use https://duet3d.com/wiki/Choosing_stepper_motors#How_to_work_out_the_power_supply_voltage_you_need to work out whether you have a high enough supply voltage to maintain torque at the maximum speed you are using, and/or try reducing the maximum speed.



  • The above print is at 25mm/s print, 40mm/s travel.

    40mm/s gives me 5.7 volts on the calculation (7.7 if you add a couple of extra volts). I am running 12v and am happy to upgrade to 24 as needed. The power supply has ample amperage and my bed heater is running on mains.



  • Here is what went into my calculation:

    Target Speed 40 mm/sec

    Delta Smallest Rod Angle 30 degrees
    Belt pitch 3 mm
    Pulley Size 20 teeth
    Motor Current (Used) 2 amps
    Motor Inductance 3.00 mH
    Step Size 0.9 Degrees
    Rated Current 2 amps
    Rated Holding Torque 0.46 Ncm

    Maximum Belt Speed 69 mm/sec
    Max Motor Revs 1.2 second
    Back EMF due to inductance 4.5
    Back EMF due to rotation 1.2

    Suggested voltatge 7.7


  • administrators

    Looks like the problem isn't loss of torque during travel moves then.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.