Start second print without hotend activation



  • When I start printing, especially 1 ^ normally starts the hot-end without any problems while starting another print starts without launching the hotend and continues printing without the extrusion of the material. How is it possible ?


    My configuration:
    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.18.1 (2017-04-09)
    WiFi Server Version: 1.03 (ch fork)
    Web Interface Version: 1.15a


    I attach my config.g:

    ; Configuration file for Duet Ethernet (firmware version 1.18.1)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon May 22 2017 22:56:20 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M665 R157 L397.1073 B175 H525 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0.6 ; Put your endstop adjustments here, or let auto calibration find them
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    M557 R130 S20 ; Define mesh grid

    ; BL-Touch
    M307 H3 A-1 C-1 D-1 ; reserve pin 21 for M42 or servo use
    M558 P4 X0 Y0 Z1 H20 F200 T5000
    G31 P25 X0 Y0 Z0.2 ; Set Z probe trigger value, offset and trigger height

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 E32 I0 ; Configure microstepping without interpolation
    M350 X32 Y32 Z32 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z160 E837 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E3000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X39960 Y39960 Z39960 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1500 ; Set accelerations (mm/s^2)
    M906 X1800 Y1800 Z1800 E1500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 1
    G10 P0 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P0 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Network
    M550 PTevo little monster ; Set machine name
    M552 S1 ; Enable network
    ; Access point is configured manually via M587 by the user
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

    Best Regards


  • administrators

    It's because you don't have a T0 command in your slicer start gcode. The T0 in config.g works for the first print.

    RRF tries to handle start gcode that doesn't have a T0 command these days, by recognising that a M109 command doesn't make sense if no tool is selected. So if you upgrade to firmware 1.19.2 (READ THE UPGRADE NOTES FROM 1.18->1.19 FIRST) then your code may work even without a T0 command.



  • Good morning, I updated the firmware 1.19 but I have not solved the issue of the next prints. I checked that in the slicer there is T0 in the startup script. The message that comes out at the start of the print without having to call the hotend is as follows:

    Warning: Tool 0 was not driven because its heater temperatures were not high enough or it has a heater fault

    In the slicer there is the T0 for activating the tool so I can do it to start all the next prints without losing the boring problem?

    Example of program Head generated by the slicer:

    G90
    M83
    M106 S0
    M140 S40
    M104 S230 T0
    M109 S230 T0
    G28 ; Homing
    M98 Pbed.g
    T0 ; Seleziono il primo strumento
    G1 E-2.8000 F3600
    G1 Z0.450 F9600
    ; process Process1
    ; layer 1, Z = 0.450
    T0
    ; tool H0.450 W0.864
    ; skirt
    G1 X-18.021 Y-4.986 F9600
    G1 E2.8000 F1080
    G1 X-14.996 Y-9.70

    Settings Duet

    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.19 (2017-08-14)
    WiFi Server Version: 1.19
    Web Interface Version: 1.19

    Best regards



  • Try moving your M104 T0 to the top of the startup script.

    [[language]]
    M104 T0
    G28 ; Homing
    M98 Pbed.g
    ;T0 ; Seleziono il primo strumento (Remove this one)
    
    


  • Doesn't the T0 need to occur before any M104/M109?


  • administrators

    Strange, I would expect the M109 command in that sequence to activate tool 0 automatically and then wait for the heater to reach temperature. I'll test that.

    Try adding command M116 after the T0 command in your slicer start GCode.



  • I added the M116 command in the Slicer but the problem reappears again! Other solutions to my problem?

    My file after add M116

    G90
    M83
    M106 S0
    M140 S40
    M104 S230 T0
    M109 S230 T0
    G28 ; Homing
    M98 Pbed.g
    T0 ; Seleziono il primo strumento
    M116
    G1 E-2.8000 F3600
    G1 Z0.375 F9600
    ; process Process1
    ; layer 1, Z = 0.375
    T0
    ; tool H0.375 W0.864
    ; skirt
    G1 X-1.152 Y60.801 F9600
    G1 E2.8000 F1080
    G1 X-3.411 Y60.736 E0.5328 F480
    G1 X-3.480 Y60.733 E0.0161

    Best regards



  • Here is what works for me in S3D.

    G90
    M82
    M106 S0
    M140 S60
    M190 S60
    M104 S220 T0
    M109 S220 T0
    ;G32
    M104 T0
    G28 ; home all axes
    M98 Pstart.g
    G92 E0
    G1 E-6.6000 F3000
    G1 Z0.162 F2000
    ; process Process1
    ; layer 1, Z = 0.162
    T0
    ; tool H0.162 W0.400
    ; skirt


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.