Z-homing trouble



  • Mystery z-endstop trouble.
    I have a Folgertech FT-5 with a Duet WiFi, Duex5 and a 3 color Diamond hotend. All endstop are the original Ultimaker like and they are all connected the same way.
    Their led and the led”s on the Duet light when hit. I have no probe and they work on x and y axis but not on z axis, why???
    Here is my config.g and homez.g:

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Sep 21 2017 17:16:32 GMT+0200 (Rom, sommertid)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y300 Z350 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Define active low and unused microswitches
    M558 P1 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    ;G31 P600 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    ;M557 X15:285 Y15:285 S20 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes forwards
    M584 X0 Y1 Z2 E4:5:6 ; Apply custom drive mapping
    M350 X16 Y16 Z16 E16:16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z400 E420:420:420 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250:250:250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800:800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    M563 P2 D2 H1 ; Define tool 2
    G10 P2 X0 Y0 Z0 ; Set tool 2 axis offsets
    G10 P2 R0 S0 ; Set initial tool 2 active and standby temperatures to 0C

    ; Network
    M550 PFT-5 DD ; Set machine name
    M552 S1 ; Enable network
    M587 Sfarce95taske53lufffe P"be81b0f702d6d23152c28d870e" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S1 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Sep 21 2017 17:16:32 GMT+0200 (Rom, sommertid)

    ; Lift Z relatively to current position
    G91
    G1 Z5 F6000

    ; Back to absolute positioning
    G90

    ; Go to first bed probe point and home the Z axis
    G1 X15 Y15 F6000

    ; Uncomment the following lines to lift Z after probing
    G91
    G1 Z5 F100
    G90
    G92 Z0.1

    What the f*#@ is going on?
    Any way thank you for a wonderful product and friendly support.


  • administrators

    Your Z homing file doesn't do a Z homing move. It looks like a homing file for using a Z probe but with the G30 probing move removed. See #1 at https://duet3d.com/wiki/Common_problems_and_their_solutions.



  • Now my homez.g look like this and it still dont't work???
    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by Jens Kej on Mon Sep 25 2017 13.18

    G91 ; relative mode
    G1 Z4 F200 ; raise head 4mm to ensure it is above the switch trigger height
    G90 ; back to absolute mode
    G1 X0 Y0 F2000 ; put the head wherever you want it to be when you home Z (omit this line if it doesn't matter)
    G91 ; relative mode
    G1 Z-200 S1 F100 ; move Z down until the switch triggers
    G90 ; back to absolute mode
    G92 Z0.1 ; tell the firmware that we are at Z=0.1mm


  • administrators

    That looks better.

    • Can you confirm that the Z endstop switch is at the minimum end of the Z axis?

    • Have you used either the Machine Properties page of DWC or M119 to check that the switch is working?

    • What does it do when you try to home just the Z axis? Don't forget that when you Home All, it runs the homeall.g file instead of the individual ones.



  • Thanks now I made it work



  • I think for clarification, can you explain what you did to make it work? thx


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.