Ex0 thermistor trouble



  • Hi,

    I have installed my duet wifi and most of it works well now. Motors, endstops, z-probing all works as supposed. The only issue I have is the Ex0 thermistor input on the board.

    While the bed thermistor worked from the start, the Ex0 always shows 2000C.

    Here is what I tried:

    1. I connected the thermistor directly to the cable coming from the board (not through the smart effector plug) –> still 2000C
    2. Plugged the Ex0 thermistor in the bed thermistor plug on the board --> works and shows correct temps
    3. Plugged the bed thermistor in the Ex0 plug on the board --> doesnt works and shows 2000C
    4. I defined Tool1 and added the added the 2nd thermistor like this:

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Bed Set thermistor + ADC parameters for heater 0
    M305 P1 T10000 B3988 C0 R4700 ; Ex0 Set thermistor + ADC parameters for heater 1
    M305 P2 T10000 B3988 C0 R4700 ; Ex1
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    M563 P1 D1 H2 ; Tool 1
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    which also shows –>2000C

    Im using Firmware version 1.19.2 and the config from rff configurator. I have the feeling im missing something in the firmware.

    Ill apriciate any help or suggestions
    Cheers



  • your M305 lines for the extruder Thermistors are wrong the T Params Should be T100000 note 5 zero's you only have 4 in yours?



  • Aha!

    I thought all the Epcos thermistor are similar, so I used the values from the specific epcos from the wiki.

    Works now, thanks!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.