Firmware 1.19 Upgrade - No Known Network Found



  • Hello,

    I recently purchased a Wifi Duet and am in the process of updating all of the firmware before installing into my printer. I have installed the program "YAT" and have followed the instructions posted here: https://duet3d.com/wiki/Upgrading_to_DuetWiFiFirmware_1.19 but am still facing challenges.

    I have added all three files - appropriately renamed and enter the M997 S0:1 command and the Duet successfully reboots. I then enter the command "M98 P/macros/SetNetwork" and receive an error that the macro file is not found.

    Since the macro did not work - I entered the commands through YAT and the following appears on the terminal:

    M552 S0
    ok <lf>G4 P1000
    ok <lf>M587 S"networkname" P"networkpassword"
    ok</lf></lf>

    I check that the network has been stored by entering the command "M587" and get the following return:

    M587
    Remembered networks:<lf>correctnetworkname<lf>ok</lf></lf>

    I then proceed to try and connect using "M552 S1" and receive the following message:

    M552 S1
    ok<lf>WiFi reported error: no known networks found<lf>Wifi module is idle</lf></lf>

    I have confirmed several times that the network name spelling is correct and the password is correct. I have tried use the M588 S"networkname" to erase the network and attempted to re-add. I receive the same error message every time.

    M115 shows the following:
    m115
    FIRMWARE_NAME: RepRapFirmware for Duet WiFi FIRMWARE_VERSION: 1.19.2 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2017-09-01<lf>ok</lf>

    Since I am new to this controller - I am wondering if there is an obvious step that I am missing. Can anyone provide insight into what I should try next?

    Thank-you,



  • I was able to get the Macro to work - and am now receiving a "Bad IP address" error that could be the root of my issues. Any suggestions as to what would cause this?
    M98 P/macros/SetNetwork
    Bad IP address<lf>ok</lf>

    Thank-you,

    Simon W.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.