Z probe stuck at 1000 with smart affector



  • You have two M558.



  • Comment out the one in the Endstop with a colon ; and test it. Can always change it back.


  • administrators

    Unplug the 8-pin socket from the effector and push the 2 ends of a piece of wire into pins 5 and 6 of it. That should give a Z probe reading of zero. If it doesn't, then the problem is most likely a bad crimp connection in the cable, or a wiring error, or a firmware configuration error. You can check that by shorting together the IN and GND pins of the Z probe connector on the Duet. If that makes the reading go to zero, then the fault lies in the cable.


  • administrators

    I'm glad you solved it. I find it impossible to check by visual inspection that crimped cable connections are OK, so when I make PanelDue cables up for customers, I always check the cable with a multimeter, or by using it to connect a PanelDue to a Duet.



  • Hi, i have almost the same problem, that the probe is stuck at 1000. If i short pin 5 and 6 it goes down to 0. When i try setting using M558 P1it goes down to ~939. Any idea what the problem could be?


  • administrators

    Does the green LED on the smart effector behave normally?

    Are you shorting pins 5 and 6 on the effector itself to get the reading to go down to 0, or are you shorting them somewhere else?

    Is resistor R5 present on your effector and properly soldered? It should measure 1K.



  • The green led is behaving normally, it's blinking twice at boot-up and is green all the time when the reading is at 1000. It is when I've shorted the pins on the effector that i get the reading 0.
    The resistor R5 is present on the board and from what i can see it's properly solderd, but I havn't mesured its resistance yet, have to do it this afternoon.



  • The R5 measures to 996 ohm so it should be fine


  • administrators

    After blinking at startup, the green LED should be off, at least when the effector is stationary. If it's always on, then either the effector is faulty, or something (most likely one of the fans) is generating enough interference to trigger the sensor. If you disconnect the 6-pin cable that feeds power to the heater and fans and then power up, does the green LED still remain on? If so, then the effector is faulty and you should ask for a replacement.



  • You are correct, if I disconnect the fans the sensor behaves normally; its off after the initiall two flashes and then flashes if i tap the hotend with my finger.

    But since the fans are triggering a signal of 939 of 1024 I guess I'll just have to drop the sensitivity till the fans doesn't trigger it anymore

    Edit: I should add that I use the supplied 30mm fan for the hotend and the 40mm fan attached via your design:https://www.thingiverse.com/thing:2467663 if it helps someone else


  • administrators

    It is OK with just the E3D 30mm fan running? It doesn't matter of the print cooling fan interferes with the sensing, because you don't need to probe with the print cooling fan on.

    Is it a 12V or a 24V system?

    Make sure that both wires in the pair from the fan follow the same route to the connector. This should normally be the case, unless you have split the wires apart.

    Some people using large heatsink cooling fans have extended the heatsink fan duct to place the heatsink fan further away from the electronics.

    HTH David



  • No, on factory settings just the 30mm fan is triggering the sensor. The system is running on 12V.



  • How about turning the fan to get the wires coming out of it away from the effector?


  • administrators

    I agree, it looks to me that the separate red and black wires from the fan are running close to the amplifier on the effector. The separate red and black wires will create a magnetic field that will induce current in the electronics. You should route them at a greater distance from that part of effector PCB and preferably twist them together - although that's difficult with the fan connector already crimped on, so holding them next to each with twine or tape may be easier.

    Here's a photo of my effector and heatsink fan. You will see that the fan wires are close together and well away from the PCB.



  • I have sort of a combination of both cases discussed here:

    • the green D3 LED blinks twice on startup and is off if the effector is at rest
    • the LED blinks every time I tap the nozzle upwards
    • it blinks five times if I send the M672 S131:131
      However, the DWC reading is stuck at 1000 if I use the P5 type Z-Probe in my config.g.

    I have tried to Bridge the pin 5 and 6 on my cable loom on the effector side - no effect, if I Bridge the ground and Z-Probe in directly at the DUET 0.85 - result is the same, no effect on the Z-Probe reading.
    I have used a multimetrer tool to ring the wires, it seems I have a solid connection there.
    If I rewire the effector to use the IR Probe and reconfigure the config.g accordingly - the IR sensor works fine.
    it seems to me, that the FW is not liking the P5 type Z-Probe, or I have an interfering configuration somehow.

    If I set the M558 to P1, the Z-Probe seems to work (the G30 will be stopped by a gentle tap). Is it a valid solution? what is the difference between P1 and P5 then?

    I am on 1.19 FW, running a 1.19DWC and Duet 0.85.


  • administrators

    @Teilchen:

    … if I Bridge the ground and Z-Probe in directly at the DUET 0.85 - result is the same, no effect on the Z-Probe reading....it seems to me, that the FW is not liking the P5 type Z-Probe.

    I agree, it looks like Z probe type 5 doesn't work on your Duet 0.8.5. Does the IR sensor work if you set the Z probe type to 5? You will need to power off and on again after setting Z probe type 5 in config,g, so that the IR sensor starts up in digital mode (2 flashes of the LED).


  • administrators

    I've just tested M558 P5 on a Duet 0.8.5 and it isn't working. Looks like there may be a firmware bug. I will investigate.



  • Ok, that sounds promising…
    can I use the P1 in the meanwhile? Will it accept the R and F parameters still?
    I guess I will have to adjust the P value in G31? If I tap the nozzle in P1 mode, the Z-Probe value jumps to over 900...
    I cannot try the actual bed probing just yet, since my printer is opened for maintenance. But I would like to finish the cablework, so I can close it up.


  • administrators

    I found the problem. Will be fixed in firmware 1.20beta12. Meanwhile, with the smart effector you can use P1 in the M558 command and P50 in the G31 command.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.