Odd Probing behaviour - Smart Effector



  • I've changed something, and now I seem to have a very odd probing behaviour.

    The smart effector probes down through its normal routine, doing its 19points S6 calibration.

    At some point, not always the same, it doesn't make it far enough down to touch the bed, green led does not go on, the effector goes back up and on to the next point, where it may miss again. It probes between 1-3 points without touching the bed then the following probe touches the bed and skips 2-3 times likes its doing the missed probes all at one time.

    https://www.dropbox.com/s/z1lze5dgml2hfyg/File%202017-10-02%2C%209%2039%2029%20AM.mov?dl=0

    Edit: video shows one missed probe, I've also had it miss 2-3 and then it seems to skip 2-3 times when it does connect.

    I've adjusted sensitivity on the effector, no change. Set effector back to factory, no change. Adjust H height, min Z, so far my combinations of fixes have not stopped it.
    Its also not every time, sometimes it does an Auto Calibration fine, other times it does this. Its also not always the same points

    Im sure I've done something while trying to zero in calibration.



  • I believe DC said that only 16 points were allowed post 1.19. It is 32.

    Do you get any errors after attempting to probe? Any H numbers on the end of your G30 in bed.g?



  • All the bed.g G30 commands are similar to these with H0 at end

    G30 P0 X0.00 Y113.00 Z-99999 H0
    G30 P1 X56.50 Y97.86 Z-99999 H0

    I do get the following error :

    G32
    Error: Z probe was not triggered during probing move

    Which is correct, it wasn't triggered since it didn't probing far enough


  • administrators

    If it doesn't go down far enough to trigger, this means that the homed height (H parameter) set in your M665 command is too low, and/or the dive height (H parameter again) in your M558 command is too low. I suggest you increase the H parameter in the M558 command to get successful probing. Then run M665 without parameters to establish the new homed height. Edit that into config.g, and run M500 to store the new value in config-override.g if you are using it. Then you can restore the M558 dive height to a lower value, for faster probing.



  • I Just increased the
    M665 H to another 3mm higher

    M665 L360.280 R179.698 H466 B140.0 X0.253 Y0.251 Z0.000

    Changed M558 H to 15 from 5

    ; Smart effector
    M558 P5 R0.4 F1000 H15
    G31 P100 X0 Y0 Z-0.2

    -rebooted

    • Homed printer
    • Auto Calibrate

    Went through 4 probes correct, then skipped 2, then multiple skips on next probe

    Edit : there is no config override file.


  • administrators

    If the skips are due to the probe not reaching the bed, you need to increase M558 H more. Try 20.



  • The M558 H (Dive Height) changes how high above it starts though doesn't it not how far below it goes?

    When I change it to 30, it does the auto calibration much higher above the bed,


  • administrators

    It changes both how high it starts and how far below z=0 it is prepared to go.



  • Worked the first time.
    Then today, M558 H set to 30.

    Reboot system, Home, Auto Calibrate.
    Probe now stops 30mm above bed center then moves to the outer diameter, then probes down to bed for 3 probes, 4th probe it only goes down about 5mm, very obvious now that the H30 has the effector so far above.

    So this is not a "settings" issue. Why would it probe down the full 30mm sometimes, and only probe 5mm or so on other random probes.? The green LED does not trigger when it fails to probe.

    Heres a video:
    This is after its done 8 probes on the outter diameter successfully and is moving to the inner diameter of the last 8 probes and centre probe.
    The first 4 probes in the clip are fine, the 5th it stops half way, the 6ths hits and skips.

    https://www.dropbox.com/s/zwaaiy2wjkf6ibk/File%202017-10-03%2C%203%2058%2058%20PM.mov?dl=0

    I have tried unsuccessfully about 6 times in a row now to get calibrate to work.


  • administrators

    I suspect that you have a bad crimp connection in one of the wires between the 8-way connector on the effector and the Z probe connector on the Duet. Probably at the effector end of the cable.



  • I ripped everything apart, rewired, seemed to go away a while. But its back lately. its always been intermittent so hard say if my rewiring ever did anything.

    https://www.dropbox.com/s/pymyybrgm1zs47z/duet%20smart%20effector%20false%20trigger.mov?raw=1

    And I cannot believe its a "bad crimp"

    It goes down, hits the bed, skips twice, the led does not go off.
    Then it lifts and goes to the next point, the led fires off the 3 times while its in the air moving.

    Does that make sense for a "bad crimp".. or a delayed signal, full buffer or something ?

    Typically after it does one of these , following probes has it dive only part way, and not make it to the board , and continue on to next point where again it only probes a portion of the dive height set.


  • administrators

    That does make sense for a bad crimp. But another possibility is that one of the pins on the 8-pin connector hasn't been soldered. That connector has to be hand soldered, so it's possible that a pin has been missed. Please check. Failing that, it could be a bad solder joint on the effector.

    What I think is happening is that at or shortly before the probe point that is skipped, the effector is receiving no power. Then the cable flexes and the dodgy connection makes contact. So after a couple of seconds the sensor completes its initialisation, which is why it flashes 3 times.

    The particular connection i suspect is the one that carries +3.3V to the effector. Try moving the effector in the XY plane as if between probe points with a pause afterwards, and see if you can make the led flash 3 times with the same interval that you get when you first power the printer on.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.